Article ID: 2612822 - Last Review: September 15, 2011 - Revision: 8.0

Computer Record is Rejected in MBAM

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SYMPTOMS

When using Microsoft BitLocker Administration and Monitoring (MBAM) users may receive a Warning message stating, "Computer Record is Rejected" in the application logs on MBAM Server.

When users experience this problem they will not see the UI prompt on Windows 7 client to start the encryption process.

Also in some cases you may see the UI prompt to Start Encryption Process, but the process will fail and you will see "Encryption Failed" in the UI prompt.

If we open EventViewer on MBAM Server and check Application Logs, you will see the below warning message.

Application Logs on MBAM Server:

Log Name:      Application
Source:        ASP.NET 2.0.50727.0
Event ID:      1310
Task Category: Web Event
Level:         Warning
Keywords:      Classic
Description:
Event code: 100002
Event message: Client Machine Name mismatch
Event ID: 39949c6a19e84c14a6f3baffee2ad790
Event sequence: 2
Event occurrence: 1
Event detail code: 0

Application information:

    Application domain: /LM/W3SVC/2/ROOT/MBAMRecoveryAndHardwareService-1-129594585755957178
    Trust level: Full
    Application Virtual Path: /MBAMRecoveryAndHardwareService
    Application Path: C:\inetpub\Malta BitLocker Management Solution\MBAM Recovery And Hardware Service\
 
Process information: 
    Process ID: 1112
    Process name: w3wp.exe
    Account name: NT AUTHORITY\NETWORK SERVICE
 
Exception information:
    Exception type: FaultException
    Exception message: The computer record is rejected. The request from machine "DOMAIN\COMPUTERNAME$" contains invalid machine name "COMPUTER.FQDN". 

Request information:
    Request URL: 
    Request path: 
    User host address: 
    User: 
    Is authenticated: False
    Authentication Type: 
    Thread account name: NT AUTHORITY\NETWORK SERVICE

Thread information:
    Thread ID: 7
    Thread account name: NT AUTHORITY\NETWORK SERVICE
    Is impersonating: False
    Stack trace: at Microsoft.Mbam.AgentSupportService.CoreService.PostKeyRecoveryInfo(Message recoveryInfoMessage)

Custom event details: 
    Application: MBAMComplianceStatusService
    Error Message: The computer record is rejected. The request from machine "DOMAIN\COMPUTERNAME$" contains invalid machine name "COMPUTER.FQDN".

On Windows 7 client you will see this error message under
Event Viewer -> Application and Services Logs -> Microsoft -> Windows -> MBAM

Log Name: Microsoft-Windows-MBAM/Admin
Source: Microsoft-Windows-MBAM
Event ID: 4
Task Category: None
Level: Error
User: SYSTEM
Computer: machinename.domainname.com
Description: An error occurred while sending encryption status data.
Error code: 0x803d0013

Details: A message containing a fault was received from the remote endpoint.

CAUSE

This is a known issue with the product specified.

RESOLUTION

Follow steps below to create a new registry key on MBAM Server where you have MBAM Administration and Monitoring Server role installed. 

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
For information about how to back up, restore, and edit the registry, click the following article: 

256986 (http://support.microsoft.com/kb/256986/EN-US) Description of the Microsoft Windows Registry


a.  Start Registry Editor.
b.  Navigate to following registry key:
HKEY_LOCAL_MACHINE\Software\Microsoft

c.  On the Edit menu, click New -> Key, and add the following registry key value:
MBAM
 
d. Under the newly created registry key name, on the Edit menu, click New -> DWORD (32-bit) Value and name it as:
DisableMachineVerification

e. Set the value to 1.
f. Exit Registry Editor.

After you make these changes, you must restart the MBAM server for the modifications to take effect.

Note: The above registry key has nothing to do with hardware compatibility checking on the server and hardware compatibility check functionality still works as designed.

MORE INFORMATION

For further information on MBAM and how it can help your environment, please consult the following documentation.

Planning Guide: http://onlinehelp.microsoft.com/en-us/mdop/hh285653.aspx (http://onlinehelp.microsoft.com/en-us/mdop/hh285653.aspx)

Deployment Guide: http://onlinehelp.microsoft.com/en-us/mdop/hh285644.aspx (http://onlinehelp.microsoft.com/en-us/mdop/hh285644.aspx)

Operations Guide: http://onlinehelp.microsoft.com/en-us/mdop/hh285664.aspx (http://onlinehelp.microsoft.com/en-us/mdop/hh285664.aspx)

Troubleshooting MBAM: http://onlinehelp.microsoft.com/en-us/mdop/hh352745.aspx (http://onlinehelp.microsoft.com/en-us/mdop/hh352745.aspx)
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use (http://go.microsoft.com/fwlink/?LinkId=151500) for other considerations.

APPLIES TO
  • Microsoft BitLocker Administration and Monitoring
Keywords: 
KB2612822