Verschlüsselungsstärke wird in Internet Explorer mit 0 Bit angezeigt

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 261328 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Dieser Artikel wurde zuvor veröffentlicht unter D261328
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
261328 Cipher strength appears as 0-bit in Internet Explorer
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

In Microsoft Internet Explorer ist möglicherweise das folgende Verhalten zu beobachten:
  • Wenn Sie im Menü ? auf Info klicken, wird unter Verschlüsselungsstärke der Wert 0-Bit angezeigt.
  • Sie können keine Webseiten auf SSL-gesicherten Websites aufrufen oder anzeigen.

Ursache

Dieses Problem kann auftreten, wenn die Dateien "Schannel.dll", "Rsabase.dll" oder "Rsaenh.dll" fehlen, beschädigt sind oder nicht in der richtigen Version vorhanden sind.

Lösung

Wenden Sie je nach Betriebssystem die entsprechende Methode an, um das Problem zu beheben.

Methode 1: Microsoft Windows Millennium Edition

Schritt 1: Umbenennen der Dateien "Schannel.dll", "Rsabase.dll" und "Rsaenh.dll"

  1. Legen Sie die Startdiskette für Windows Millenium Edition in das Diskettenlaufwerk ein und starten Sie anschließend den Computer neu.

    Weitere Informationen zum Erstellen von Windows Millennium Edition-Startdisketten finden Sie im folgenden Artikel der Microsoft Knowledge Base:
    267287 Erstellen einer Startdiskette in Windows Me
  2. Wählen Sie mit den Pfeiltasten die Option Computer mit CD-ROM-Unterstützung starten, und drücken Sie dann die [EINGABTASTE], wenn das Startmenü angezeigt wird.
  3. Merken Sie sich den Laufwerkbuchstaben Ihres CD-ROM-Laufwerks.
  4. Geben Sie an der Eingabeaufforderung die folgenden Befehle ein, und drücken Sie nach jedem Befehl die [EINGABETASTE].

    Hinweis: C: ist das Laufwerk, auf dem Windows installiert ist:
    C:
    cd windows\system
  5. Benennen Sie die Dateien "Schannel.dll", "Rsabase.dll" und "Rsaenh.dll" um (falls diese Dateien vorhanden sind), indem Sie ihnen die Dateinamenerweiterung ".old" zuweisen. Geben Sie hierzu die folgenden Befehlszeilen ein, und drücken Sie anschließend die [EINGABETASTE] nach jeder Zeile:
    ren schannel.dll schannel.old
    ren rsabase.dll rsabase.old
    ren rsaenh.dll rsaenh.old

Schritt 2: Extrahierung von neuen Kopien der Dateien "Schannel.dll", "Rsabase.dll" und "Rsaenh.dll"

  1. Legen Sie die Windows Me-CD-ROM in Ihr CD-ROM-Laufwerk oder DVD-ROM-Laufwerk ein.
  2. Geben Sie an der Eingabeaufforderung die folgenden Befehle ein, und drücken Sie nach jedem Befehl die [EINGABETASTE]:
    A:
    ext
  3. Wenn Sie aufgefordert werden, den Pfad zu den Windows-CAB-Dateien einzugeben, geben Sie die folgende Befehlszeile ein und drücken Sie danach die [EINGABTASTE].
    Laufwerk::\win9x
    Hinweis: Laufwerk steht für den Laufwerksbuchstaben Ihres CD-ROM-Laufwerks. Zum Beispiel
    E:\win9x
    Hinweis: Wenn Sie über eine OEM-Installation (Original Equipment Manufacturer, Originalcomputerhersteller) von Windows verfügen, befinden sich die Windows-Installationsdateien möglicherweise in folgendem Ordner:
    Laufwerk:\Windows\Options\Install
    Hinweis: Laufwerk steht für das Laufwerk, auf dem Windows installiert ist.

    Falls sich diese Dateien auf Ihrem Computer befinden, benötigen Sie Ihre Windows-CD nicht, da Sie diese Dateien in diesem Fall aus dem betreffenden Ordner auf Ihrer Festplatte extrahieren können. Geben Sie beispielsweise folgenden Befehl ein, und drücken Sie die [EINGABETASTE]:
    C:\Windows\Options\Install
  4. enn Sie dazu aufgefordert werden, die Namen der Dateien einzugeben, die Sie extrahieren möchten, geben Sie die folgende Zeile ein, und drücken Sie anschließend die [EINGABETASTE]:
    schannel.dll rsabase.dll rsaenh.dll
  5. Wenn Sie zur Eingabe des Pfades aufgefordert werden, geben Sie die folgende Befehlszeile ein, und drücken Sie anschließend die [EINGABETASTE]:
    Laufwerk:\Windows\System
    Hinweis: Laufwerk steht für das Laufwerk, auf dem Windows installiert ist.
  6. Wenn Sie aufgefordert werden, die Eingabe zu bestätigen, drücken Sie die Taste J und danach die [EINGABTASTE].
  7. Entfernen Sie die Windows Me-Startdiskette aus dem Diskettenlaufwerk, und starten Sie den Computer neu.

    Weitere Informationen zum Extrahieren von Dateien mit dem Systemkonfigurationsprogramm finden Sie im folgenden Artikel der Microsoft Knowledge Base:
    265371 Unter Windows Me eine geschützte Datei extrahieren und ersetzen

Schritt 3: Prüfen der Version der Datei "Advapi32.dll"

  1. Starten Sie Microsoft Windows Explorer und suchen Sie anschließend folgende Datei:
    Laufwerk:\Windows\System\Advapi32.dll
    Hinweis: Laufwerk steht für das Laufwerk, auf dem Windows installiert ist.
  2. Klicken Sie mit der rechten Maustaste auf Advapi32.dll und danach mit der linken Maustaste auf Eigenschaften.
  3. Klicken Sie auf die Registerkarte Version.
  4. Notieren Sie sich die Version der Datei "Advapi32.dll". Ist die Versionsnummer nicht 4.90.0.3000 oder höher, müssen Sie die Schritte 1 und 2 wiederholen, um eine neue Kopie dieser Datei in den Ordner "Laufwerk:\Windows\System" zu extrahieren.

Schritt 4: Die Dateien Schannel.dll, Rsabase.dll, Rsaenh.dll, Security.dll und Secur32.dll neu registrieren

Hinweis: Sie müssen die folgenden Schritte für jede Datei, die Sie neu registrieren möchten, einzeln durchführen.
  1. Klicken Sie auf Start und anschließend auf Ausführen.
  2. Geben Sie in das Feld Öffnen einen der folgenden Befehle ein (je nachdem, welche Datei Sie neu registrieren möchten), und klicken Sie danach auf OK.
    Laufwerk:\windows\system\regsvr32.exe c:\windows\system\schannel.dll

    Laufwerk:\windows\system\regsvr32.exe c:\windows\system\rsabase.dll

    Laufwerk:\windows\system\regsvr32.exe c:\windows\system\rsaenh.dll

    Laufwerk:\windows\system\regsvr32.exe c:\windows\system\security.dll

    Laufwerk:\windows\system\regsvr32.exe c:\windows\system\secur32.dll
    Hinweis: Laufwerk für das Laufwerk, auf dem Windows installiert ist.
  3. Wenn die Meldung "DllRegisterServer in Dateiname erfolgreich durchgeführt" angezeigt wird, klicken Sie auf OK.

Schritt 5: Überprüfung der Verschlüsselungsstärke in Internet Explorer

Starten Sie Internet Explorer. Klicken Sie danach im Menü ? auf Info. Vergewissern Sie sich, dass unter Verschlüsselungsstärke der Wert 128-Bit angegeben ist.

Methode 2: Microsoft Windows 98 oder Microsoft Windows 98 Second Edition

  1. Klicken Sie auf Start, zeigen Sie auf Einstellungen, klicken Sie auf Ordneroptionen, und klicken Sie dann auf die Registerkarte Ansicht.
  2. Klicken Sie im Feld Erweiterte Einstellungen auf Alle Dateien anzeigen, deaktivieren Sie (falls nötig) das Kontrollkästchen Dateinamenerweiterung bei bekannten Dateitypen ausblenden, und klicken Sie danach auf OK.
  3. Starten Sie Windows Explorer, und wechseln Sie zu dem Ordner "Laufwerk:\Windows\System".

    Hinweis: Laufwerk steht für das Laufwerk, auf dem Windows installiert ist.
  4. Benennen Sie die Dateien "Schannel.dll", "Rsabase.dll" und "Rsaenh.dll" um (falls diese Dateien existieren), indem Sie ihnen die Dateinamenerweiterung ".old" zuweisen. Gehen Sie hierzu folgendermaßen vor:
    1. Klicken Sie mit der rechten Maustaste auf die Datei Schannel.dll und danach mit der linken Maustaste auf Umbenennen.
    2. Geben Sie schannel.old ein, und drücken Sie die [EINGABETASTE].
    3. Wiederholen Sie die Schritte 2a und 2b, um die Dateien "Rsabase.dll" und "Rsaenh.dll" zu "Rsabase.old" und "Rsaenh.old" umzubenennen.
  5. Installieren Sie Internet Explorer neu. Verwenden Sie dazu die Vorgehensweise für Ihre jeweilige Version von Internet Explorer:

    Microsoft Internet Explorer 6

    1. Downloaden und Installieren Sie Microsoft Internet Explorer 6 von der folgenden Microsoft-Website oder installieren Sie das Programm neu: Besuchen Sie hierzu die folgende Website von Microsoft:
      http://www.microsoft.com/windows/ie_intl/de/download/default.mspx
      Hinweis: Wenn das Dialogfeld Alle Komponenten erneut installieren? angezeigt wird, klicken Sie auf Alles erneut installieren und anschließend auf OK.
    2. Starten Sie den Computer neu, starten Sie Internet Explorer, klicken Sie danach im Menü ? auf Info und überprüfen Sie, dass im Feld Verschlüsselungsstärke der Wert 128-Bit angegeben wird.

Methode 3: Microsoft Windows XP

Reparieren Sie Internet Explorer oder Windows XP oder installieren Sie es erneut.

Weitere Informationen hierzu finden Sie finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:
318378 Neuinstallation bzw. Reparatur von Internet Explorer und Outlook Express in Windows XP
315341 Durchführen einer direkten Aktualisierung (Neuinstallation) von Windows XP

Weitere Informationen

Gehen Sie folgendermaßen vor, wenn Sie auf Ihrem Computer eine Verschlüsselungsstärke von 128-Bit wiederhergestellt haben und dennoch noch keine Webseiten auf SSL-gesicherten Websites anzeigen können:
  1. Klicken Sie im Menü Extras auf Internetoptionen und dann auf die Registerkarte Erweitert.
  2. Unter Sicherheit aktivieren Sie die Kontrollkästchen SSL2.0 verwenden und SSL3.0 verwenden (falls sie nicht bereits aktiviert sind).
  3. Klicken Sie auf OK.

Informationsquellen

Weitere Informationen dazu, wie Sie ein ähnliches Problem beheben können, finden Sie im folgenden Artikel der Microsoft Knowledge Base:
303807 Fehlermeldung "Die Seite kann nicht angezeigt werden" beim Versuch, eine Webseite auf einer sicheren Website einzusehen
Weitere Informationen zum Extrahieren komprimierter Windows-Dateien finden Sie im folgenden Artikel der Microsoft Knowledge Base:
129605 SO WIRD'S GEMACHT: Extrahieren komprimierter Windows-Originaldateien
Weitere Informationen darüber, wie Sie feststellen können, in welchem Ordner Windows installiert wurde, finden Sie in folgendem Artikel der Microsoft Knowledge Base:
305792 Bestimmen des Ordners, in dem Windows installiert ist

Eigenschaften

Artikel-ID: 261328 - Geändert am: Freitag, 7. Januar 2005 - Version: 8.1
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Internet Explorer 6.0, wenn verwendet mit:
    • Microsoft Windows XP Professional
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
  • Microsoft Internet Explorer 5.5, wenn verwendet mit:
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 95
  • Microsoft Internet Explorer 5.01, wenn verwendet mit:
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 95
  • Microsoft Internet Explorer 5.0, wenn verwendet mit:
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 95
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 4.0 128-Bit Edition
Keywords: 
kbenv kbui kbprb kbfaq KB261328
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com