A força da codificação apresentada no Internet Explorer é de 0 bits

Traduções de Artigos Traduções de Artigos
Artigo: 261328 - Ver produtos para os quais este artigo se aplica.
Este artigo foi publicado anteriormente em PT261328
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

No Microsoft Internet Explorer, poderá encontrar os seguintes comportamentos:
  • Quando clica em Acerca do Internet Explorer no menu Ajuda, o valor de Força da codificação é de 0 bit.
  • Não consegue ligar a e visualizar páginas Web em Web sites protegidos por SSL.

Causa

Este problema poderá ocorrer se os ficheiros Schannel.dll, Rsabase.dll ou Rsaenh.dll não existirem, estiverem danificados ou tiverem uma versão incorrecta.

Resolução

Este artigo poderá conter hiperligações para conteúdo em inglês (ainda não traduzido).

Para resolver este comportamento, utilize o método mais adequado para o sistema operativo em questão.

Método 1: Microsoft Windows Millennium Edition

Passo 1: Mudar o nome aos ficheiros Schannel.dll, Rsabase.dll e Rsaenh.dll

  1. Introduza a disquete de arranque do Windows Millennium Edition na unidade de disquetes e reinicie o computador.

    Para obter informações adicionais sobre como criar uma disquete de arranque do Windows Millennium Edition, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
    267287 How to create a startup disk in Windows Millennium Edition
  2. Quando aparecer o menu de arranque, utilize as teclas de seta para seleccionar Iniciar o computador com suporte para CD-ROM e prima ENTER.
  3. Anote a letra da unidade de CD-ROM.
  4. Na linha de comandos, escreva as seguintes linhas e prima ENTER após cada uma.

    Nota: C: é a unidade em que o Windows está instalado:
    C:
    cd windows\system
  5. Mude o nome dos ficheiros Schannel.dll, Rsabase.dll e Rsaenh.dll (se estiverem presentes) utilizando a extensão de nome de ficheiro .old. Para tal, escreva as seguintes linhas de comandos e prima ENTER após cada linha:
    ren schannel.dll schannel.old
    ren rsabase.dll rsabase.old
    ren rsaenh.dll rsaenh.old

Passo 2: Extrair novas cópias dos ficheiros Schannel.dll, Rsabase.dll e Rsaenh.dll

  1. Introduza o CD do Windows Millennium Edition na unidade de CD-ROM ou na unidade de DVD-ROM.
  2. Na linha de comandos, escreva as seguintes linhas e prima ENTER após cada uma:
    A:
    ext
  3. Quando lhe for pedido para escrever o caminho dos ficheiros CAB do Windows, escreva o seguinte comando e prima ENTER: unidade:\win9x.

    Nota: unidade é a letra da unidade de CD-ROM. Por exemplo, escreva:
    E:\win9x
    Nota: se tiver uma instalação de fabricante de equipamento original (OEM, original equipment manufacturer) do Windows, os ficheiros de instalação também poderão estar localizados na seguinte pasta:
    unidade:\Windows\Options\Install
    Nota: unidade é a unidade em que o Windows está instalado.

    Se estes ficheiros estiverem no computador, o CD do Windows não é necessário, uma vez que pode extrair os ficheiros da pasta apropriada existente na unidade de disco rígido. Por exemplo, escreva o seguinte comando e prima ENTER:
    C:\Windows\Options\Install
  4. Quando lhe for pedido para escrever os nomes dos ficheiros que pretende extrair, escreva o seguinte comando e prima ENTER:
    schannel.dll rsabase.dll rsaenh.dll
  5. Quando lhe for pedido para escrever o caminho, escreva o seguinte comando e prima ENTER:
    unidade:\Windows\System
    Nota: unidade é a unidade em que o Windows está instalado.
  6. Quando lhe for pedido para confirmar se pretende continuar, escreva Y e prima ENTER.
  7. Remova a disquete de arranque do Windows Millennium Edition da unidade de disquetes e reinicie o computador.

    Para obter informações adicionais sobre como extrair ficheiros com a ferramenta Utilitário de configuração do sistema, clique no seguinte número de artigo para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
    265371 Como extrair e substituir um ficheiro protegido no Windows Me

Passo 3: Verificar a versão do ficheiro Advapi32.dll

  1. Inicie o Explorador do Windows e localize o seguinte ficheiro:
    unidade:\Windows\System\Advapi32.dll
    Nota: unidade é a unidade em que o Windows está instalado.
  2. Clique com o botão direito do rato em Advapi32.dll e clique em Propriedades.
  3. Clique no separador Versão.
  4. Anote a versão do ficheiro Advapi32.dll. Se a versão deste ficheiro não for a 4.90.0.3000 ou superior, tem de repetir os passos 1 a 2 para extrair uma nova cópia deste ficheiro para a pasta unidade:\Windows\System.

Passo 4: Voltar a registar os ficheiros Schannel.dll, Rsabase.dll, Rsaenh.dll, Security.dll e Secur32.dll

  1. Nota: siga estes passos em separado para cada um dos ficheiros que pretende voltar a registar.

  2. Clique em Iniciar e clique em Executar.
  3. Na caixa Abrir, escreva um dos seguintes comandos (para o ficheiro que está a registar novamente) e clique em OK.
    unidade:\windows\system\regsvr32.exe c:\windows\system\schannel.dll

    unidade:\windows\system\regsvr32.exe c:\windows\system\rsabase.dll

    unidade:\windows\system\regsvr32.exe c:\windows\system\rsaenh.dll

    unidade:\windows\system\regsvr32.exe c:\windows\system\security.dll

    unidade:\windows\system\regsvr32.exe c:\windows\system\secur32.dll
    Nota: unidade é a unidade em que o Windows está instalado
  4. Clique em OK quando receber a mensagem "DllRegisterServer em nome do ficheiro teve êxito".

Passo 5: Verificar a força da codificação no Internet Explorer

Inicie o Internet Explorer e clique em Acerca do Internet Explorer, no menu Ajuda. Verifique se o valor Força da codificação é de 128 bits.

Método 2: Microsoft Windows 98, Microsoft Windows 98 Segunda Edição

  1. Clique em Iniciar, aponte para Definições, clique em Opções de pastas e clique no separador Ver.
  2. Na caixa Definições avançadas, clique em Mostrar todos os ficheiros, desmarque a caixa de verificação Ocultar extensões de ficheiros para tipos de ficheiro conhecidos (se estiver seleccionada) e clique em OK.
  3. Inicie o Explorador do Windows e localize a pasta unidade:\Windows\System.

    Nota: unidade é a unidade em que o Windows está instalado.
  4. Mude o nome dos ficheiros Schannel.dll, Rsabase.dll e Rsaenh.dll (se existirem) utilizando a extensão de nome de ficheiro .old. Para tal, siga estes passos:
    1. Clique com o botão direito do rato no ficheiro Schannel.dll e clique em Mudar o nome.
    2. Escreva schannel.old e prima a tecla ENTER.
    3. Repita os passos 4a a 4b para mudar o nome aos ficheiros Rsabase.dll e Rsaenh.dll para Rsabase.old e Rsaenh.old.
  5. Reinstale o Internet Explorer. Para tal, utilize o método mais adequado para a versão do Internet Explorer:

    Microsoft Internet Explorer 6

    1. Transfira e instale o Microsoft Internet Explorer 6 ou reinstale o Microsoft Internet Explorer 6. Para o fazer, visite o seguinte Web site da Microsoft:
      http://www.microsoft.com/windows/ie_intl/pt/download/default.mspx
      Nota: se for apresentada a caixa de diálogo Reinstalar todos os itens?, clique em Voltar a instalar todos os componentes e clique em OK.
    2. Reinicie o computador, inicie o Internet Explorer, clique em Acerca do Internet Explorer, no menu Ajuda, e verifique se a Força da codificação é de 128 bits.

Método 3: Microsoft Windows XP

Repare ou reinstale o Internet Explorer ou o Windows XP.

Para obter informações adicionais sobre como efectuar este procedimento, clique nos números de artigo que se seguem para visualizar os artigos na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
318378 Como reinstalar ou reparar o Internet Explorer e o Outlook Express no Windows XP
315341 Como efectuar uma actualização directa (reinstalação) do Windows XP

Mais Informação

Se restaurar a força da codificação de 128 bits no computador e, mesmo assim, não conseguir visualizar páginas Web em Web sites protegidos por SSL, siga estes passos:
  1. Clique em Opções da Internet, no menu Ferramentas, e clique no separador Avançadas.
  2. Em Segurança, seleccione as caixas de verificação Utilizar SSL2.0 e Utilizar SSL3.0 (se ainda não estiverem seleccionadas).
  3. Clique em OK.

Referências

Para obter informações adicionais sobre como resolver um problema semelhante, clique no seguinte número de artigo para visualizar o artigo na base de dados da Microsoft (KB, Microsoft Knowledge Base):
303807 'The page cannot be displayed' error message when you try to view Web page on a secure Web site
Para obter informações adicionais sobre como extrair ficheiros comprimidos do Windows, clique no seguinte número de artigo para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
129605 Como extrair ficheiros originais comprimidos do Windows
Para obter informações adicionais sobre como determinar a pasta onde o Windows está instalado, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
305792 Como determinar a pasta em que o Windows está instalado

Propriedades

Artigo: 261328 - Última revisão: 14 de dezembro de 2004 - Revisão: 7.3
A informação contida neste artigo aplica-se a:
  • Microsoft Internet Explorer 6.0 nas seguintes plataformas
    • Microsoft Windows XP Professional
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
  • Microsoft Internet Explorer 5.5 nas seguintes plataformas
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 95
  • Microsoft Internet Explorer 5.01 nas seguintes plataformas
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 95
  • Microsoft Internet Explorer 5.0 nas seguintes plataformas
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 95
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 4.0 128-Bit Edition
Palavras-chave: 
kbenv kbui kbprb kbfaq KB261328

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com