O nível de codificação aparece como 0 bit no Internet Explorer

Traduções deste artigo Traduções deste artigo
ID do artigo: 261328 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

No Microsoft Internet Explorer, você pode enfrentar os seguintes comportamentos:
  • Ao clicar em Sobre o Internet Explorer no menu Ajuda, o valor Nível de codificação é 0 bit.
  • Não é possível se conectar e visualizar as páginas da Web em sites seguros por SSL.

Causa

Esse comportamento pode ocorrer se os arquivos Schannel.dll, Rsabase.dll ou Rsaenh.dll estiverem faltando, danificados ou forem de versão incorreta.

Resolução

Para solucionar esse problema, use o método apropriado ao seu sistema operacional.

Método 1: Microsoft Windows Millennium Edition

Etapa 1: Renomear os arquivos Schannel.dll, Rsabase.dll e Rsaenh.dll

  1. Insira o disco de Inicialização do Windows Millennium Edition na unidade de disquete e reinicie o computador.

    Para obter informações adicionais sobre como criar um disco de inicialização do Windows Millennium Edition, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento da Microsoft:
    267287 Como criar um disco de inicialização no Windows Millennium Edition
  2. Quando o menu de Inicialização aparecer, use as teclas de SETAS para selecionar Iniciar computador com suporte do CD-ROM e pressione ENTER.
  3. Observe a letra da unidade de CD-ROM.
  4. No prompt de comando, digite as seguintes linhas e pressione ENTER após cada linha.

    Observação C: é a unidade na qual o Windows está instalado:
    C:
    cd windows\system
  5. Renomeie os arquivos Schannel.dll, Rsabase.dll e Rsaenh.dll (se existirem) usando a extensão de nome de arquivo .old. Para fazer isso, digite as seguintes linhas de comando e pressione ENTER após cada linha:
    ren schannel.dll schannel.old
    ren rsabase.dll rsabase.old
    ren rsaenh.dll rsaenh.old

Etapa 2: Extrair novas cópias dos arquivos Schannel.dll, Rsabase.dll e Rsaenh.dll

  1. Insira seu CD do Windows Millennium Edition na unidade de CD-ROM ou na unidade de DVD-ROM.
  2. No prompt de comando, digite as seguintes linhas e pressione ENTER após cada linha:
    A:
    ext
  3. Ao ser solicitado a digitar o caminho para os arquivos CAB do Windows, digite o seguinte comando e pressione ENTER:
    unidade:\win9x
    Observação unidade é a letra da sua unidade de CD-ROM. Por exemplo, digite:
    E:\win9x
    Observação Se você tiver uma instalação OEM (fabricante original do equipamento) do Windows, os arquivos de instalação também poderão estar localizados na seguinte pasta:
    unidade:\Windows\Options\Install
    Observação unidade é a unidade na qual o Windows está instalado.

    Se esses arquivos estiverem no computador, não será necessário o CD do Windows porque é possível extraí-los da pasta adequada no disco rígido. Por exemplo, digite o seguinte comando e pressione ENTER:
    C:\Windows\Options\Install
  4. Ao ser solicitado a digitar os nomes dos arquivos que deseja extrair, digite o seguinte comando e pressione ENTER:
    schannel.dll rsabase.dll rsaenh.dll
  5. Ao ser solicitado a digitar o caminho, digite o seguinte comando e pressione ENTER:
    unidade:\Windows\System
    Observação unidade é a unidade na qual o Windows está instalado.
  6. Quando solicitado a confirmar se isso está OK, digite Y e pressione ENTER.
  7. Remova o disco de inicialização do Windows Millennium Edition da unidade de disquete e reinicie o computador.

    Para obter informações adicionais sobre como extrair arquivos usando a ferramenta Utilitário de configuração do sistema, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento da Microsoft:
    265371 Como extrair e substituir um arquivo protegido no Windows Me

Etapa 3: Verificar a versão do arquivo Advapi32.dll

  1. Inicie o Windows Explorer e localize o seguinte arquivo:
    unidade:\Windows\System\Advapi32.dll
    Observação unidade é a unidade na qual o Windows está instalado.
  2. Clique com o botão direito do mouse em Advapi32.dll e clique em Propriedades.
  3. Clique na guia Versão.
  4. Anote a versão do arquivo Advapi32.dll. Se a versão desse arquivo não for a 4.90.0.3000 ou posterior, você deverá repetir as etapas 1 e 2 para extrair uma nova cópia desse arquivo para a pasta unidade:\Windows\ System.

Etapa 4: Registrar novamente os arquivos Schannel.dll, Rsabase.dll, Rsaenh.dll, Security.dll e Secur32.dll

Obsevação Execute estas etapas separadamente para cada arquivo que registrar.
  1. Clique em Iniciar e em Executar.
  2. Na caixa Abrir, digite um dos seguintes comandos (de acordo com o arquivo que está sendo registrado novamente), e clique em OK.
    unidade:\windows\system\regsvr32.exe c:\windows\system\schannel.dll

    unidade:\windows\system\regsvr32.exe c:\windows\system\rsabase.dll

    unidade:\windows\system\regsvr32.exe c:\windows\system\rsaenh.dll

    unidade:\windows\system\regsvr32.exe c:\windows\system\security.dll

    unidade:\windows\system\regsvr32.exe c:\windows\system\secur32.dll
    Observação unidade é a unidade na qual o Windows está instalado
  3. Clique em OK ao receber a mensagem "DllRegisterServer em nome do arquivo com êxito".

Etapa 5: Verificar o nível de codificação no Internet Explorer

Inicie o Internet Explorer e clique em Sobre o Internet Explorer no menu Ajuda. Verifique se o valor Nível de codificação é de 128 bits.

Método 2: Microsoft Windows 98, Microsoft Windows 98 Second Edition

  1. Clique em Iniciar, aponte para Configurações, clique em Opções de pasta e clique na guia Exibir.
  2. Na caixa Configurações avançadas, clique em Exibir todos os arquivos, desmarque a caixa de seleção Ocultar extensões de arquivo para tipos de arquivos conhecidos (se ela estiver marcada) e clique em OK.
  3. Inicie o Windows Explorer e localize a pasta unidade:\Windows\System.

    Observação unidade é a unidade na qual o Windows está instalado.
  4. Renomeie os arquivos Schannel.dll, Rsabase.dll e Rsaenh.dll (se existirem) usando a extensão de nome de arquivo .old. Para fazer isso, execute essas etapas:
    1. Clique com o botão direito do mouse no arquivo Schannel.dll e clique em Renomear.
    2. Digite schannel.old e pressione ENTER.
    3. Repita as etapas 2a e 2b para renomear os arquivos Rsabase.dll e Rsaenh.dll para Rsabase.old e Rsaenh.old.
  5. Reinstale o Internet Explorer. Para fazer isso, use o método apropriado para a sua versão do Internet Explorer:

    Microsoft Internet Explorer 6

    1. Baixe e instale o Microsoft Internet Explorer 6 ou reinstale o Microsoft Internet Explorer 6. Para fazer isso visite o seguinte site da Microsoft:
      http://www.microsoft.com/downloads/details.aspx?FamilyID=1e1550cb-5e5d-48f5-b02b-20b602228de6&isplaylang=pt-br
      Observação Se a caixa de diálogo Reinstalar todos os itens? aparecer, clique em Reinstalar todos os componentes e clique em OK.
    2. Reinicie o computador, inicie o Internet Explorer, clique em Sobre o Internet Explorer no menu Ajuda e verifique se o Nível de codificação é de 128 bits.

Método 3: Microsoft Windows XP

Repare ou reinstale o Internet Explorer ou o Windows XP.

Para obter informações adicionais sobre como fazer isso, clique nos números abaixo para ler os artigos na Base de Dados de Conhecimento da Microsoft:
318378 Como reinstalar ou reparar o Internet Explorer e o Outlook Express no Windows XP
315341 Como realizar uma atualização local (reinstalação) do Windows XP

Mais Informações

Se você restaurar seu computador para o nível de codificação de 128 bits e ainda não conseguir ver as páginas da Web em sites seguros por SSL, execute estas etapas:
  1. Clique em Opções da Internet no menu Ferramentas e clique na guia Avançado.
  2. Em Segurança, marque as caixas de seleção Usar SSL2.0 e Usar SSL3.0 (se elas ainda não estiverem marcadas).
  3. Clique em OK.

Referências

Para obter informações adicionais sobre como solucionar um problema semelhante, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento da Microsoft:
303807 Mensagem de erro "A página não pode ser exibida" ao tentar visualizar a página da Web em um site seguro
Para obter informações adicionais sobre como extrair arquivos do Windows compactados, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento da Microsoft:
129605 Como extrair arquivos originais compactados do Windows
Para obter informações adicionais sobre como determinar em que pasta o Windows está instalado, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento da Microsoft:
305792 Como determinar em qual pasta o Windows está instalado

Propriedades

ID do artigo: 261328 - Última revisão: terça-feira, 14 de dezembro de 2004 - Revisão: 8.3
A informação contida neste artigo aplica-se a:
  • Microsoft Internet Explorer 6.0 nas seguintes plataformas
    • Microsoft Windows XP Professional
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
  • Microsoft Internet Explorer 5.5 nas seguintes plataformas
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 95
  • Microsoft Internet Explorer 5.01 nas seguintes plataformas
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 95
  • Microsoft Internet Explorer 5.0 nas seguintes plataformas
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 95
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 4.0 Edição de 128 Bits
Palavras-chave: 
kbenv kbui kbprb kbfaq KB261328

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com