V programe Microsoft Internet Explorer sa úroveň šifrovania zobrazuje ako 0

Preklady článku Preklady článku
ID článku: 261328 - Zobraziť produkty, ktorých sa tento článok týka.
Rozbaliť všetko | Zbaliť všetko

Na tejto stránke

PRIZNAKY

V programe Microsoft Internet Explorer sa môžete stretnúť s nasledujúcim správaním:
  • Keď v ponuke Pomocník kliknite na položku Čo je Internet Explorer, tak v položke Zložitosť šifrovania je údaj 0.
  • nemôžete sa pripojiť na webové stránky a nie je možné ich zobraziť na zabezpečených lokalitách.

PRICINA

Takéto správanie nastane vtedy, ak chýbajú súbory Schannel.dll, Rsabase.dll alebo Rsaenh.dll, sú poškodené alebo je nesprávna verzia týchto súborov.

RIESENIE

Ak chcete tento problém odstrániť, postupujte podľa operačného systému.

Metóda 1: Microsoft Windows Millennium Edition

Krok 1: Premenovanie súborov Schannel.dll, Rsabase.dll a Rsaenh.dll

  1. Do disketovej mechaniky vložte zavádzaciu disketu operačného systému Microsoft Windows Millennium (Me) a potom reštartujte počítač. Informácie o vytvorení štartovacej diskety systému Windows Me nájdete v nasledujúcom článku databázy Microsoft Knowledge Base:

    267287 How to create a startup disk in Windows Millennium Edition
  2. Keď sa zobrazí ponuka systému Windows Millenium Po spustení, pomocou klávesy so šípkou prejdite na položku Spustiť počítač s podporou jednotky CD-ROM a potom kliknite na kláves Enter.
  3. Zaznamenajte si písmeno jednotky CD-ROM, napríklad E.
  4. Do príkazového riadka napíšte nasledujúce riadky a za každým stlačte kláves Enter:

    Poznámka: c: je jednotka, na ktorej je nainštalovaný operačný systém Windows.

    C:
    cd windows\system
  5. 5. Ak sú prítomné súbory Schannel.dll, Rsabase.dll a Rsaenh.dll, premenujte ich použitím prípony .old. Urobte nasledovné a zakaždým riadkom stlačte kláves Enter:
    ren schannel.dll schannel.old
    ren rsabase.dll rsabase.old
    ren rsaenh.dll rsaenh.old

Krok 2: Extrakcia nových kópií súborov Schannel.dll, Rsabase.dll, a Rsaenh.dll

  1. Do jednotky CD-ROM alebo DVD-ROM vložte inštalačný disk CD s operačným systémom Microsoft Windows Me.
  2. 2. Do príkazového riadka napíšte nasledujúce riadky a a za každým stlačte kláves Enter:
    A:
    ext
  3. Po výzve vložte cestu k súboru CAB systému Windows, napíšte jednotka:\win9x, kde jednotka je vaša mechanika CD-ROM, a potom stlačte kláves Enter. Napríklad napíšte:E:\win9x.

    Poznámka: Ak máte inštaláciu operačného systému Windows OEM, inštalačné súbory môžu byť umiestnené aj v nasledujúcom priečinku:
    jednotka:\Windows\Options\Install
    kde jednotka je jednotka, na ktorej je nainštalovaný operačný systém Windows.

    Ak sú tieto súbory na vašom počítači, nepotrebujete inštalačný disk CD, pretože ich môžete extrahovať z príslušného priečinka na vašom pevnom disku. Napríklad napíšte:
    C:\Windows\Options\Install
    a potom kliknite na kláves Enter.
  4. Po výzve na zadanie názvov súborov, ktoré chcete extrahovať, napíšte schannel.dll rsabase.dll rsaenh.dll a potom kliknite na kláves Enter.
  5. Po výzve na zadanie cesty napíšte jednotka:\Windows\System, kde jednotka je jednotka, na ktorej je nainštalovaný operačný systém Windows, a potom kliknite na kláves Enter.
  6. Po výzve na potvrdenie, či je to správne, napíšte Y (O) a stlačte kláves Enter.
  7. Odstráňte zavádzaciu disketu operačného systému Microsoft Windows Me z disketovej mechaniky a potom reštartujte počítač.

    For additional information about how to extract files with the System Configuration Utility tool, click the following article number to view the article in the Microsoft Knowledge Base:
    265371 How to extract and replace a protected file in Windows Me

Krok 3: Overenie verzie súboru Advapi32.dll

  1. Spustite program Prieskumníka a potom vyhľadajte nasledujúci súbor:
    jednotka:\Windows\System\Advapi32.dll

    kde jednotka je jednotka, na ktorej je nainštalovaný operačný systém Windows.
  2. Pravým tlačidlom myši kliknite na súbor Advapi32.dll a potom v kontextovej ponuke kliknite na položkuVlastnosti.
  3. Kliknite na kartu Verzia.
  4. Skontrolujte verziu súboru Advapi32.dll. Ak verzia súboru nie je 4.90.0.3000 alebo vyššia, musíte opakovať kroky 1 až 2, aby ste vyextrahovali nové kópie súborov do priečinka jednotka:\Windows\ System folder.

Krok 4: Opätovná registrácia súborov Schannel.dll, Rsabase.dll a Rsaenh.dll

  1. Poznámka: tieto kroky urobte zvlášť pre každý súbor, ktorý chcete znovu zaregistrovať.

  2. Kliknite na tlačidlo Štart a potom kliknite na položku Spustiť.
  3. Do poľa Otvoriť napíšte jeden z nasledujúcich príkazov (podľa toho, ktorý súbor chcete znovu zaregistrovať) a potom kliknite na tlačidlo OK.
    drive:\windows\system\regsvr32.exe c:\windows\system\schannel.dll

    drive:\windows\system\regsvr32.exe c:\windows\system\rsabase.dll

    drive:\windows\system\regsvr32.exe c:\windows\system\rsaenh.dll

    drive:\windows\system\regsvr32.exe c:\windows\system\security.dll

    drive:\windows\system\regsvr32.exe c:\windows\system\secur32.dll
  4. Ked sa zobrazí správa „Funkcia DllRegisterServer bola úspešná v (názov súboru)“, kliknite na tlačidlo OK.

Krok 5: Overenie úrovne šifrovania v programe Microsoft Explorer

Spustite program Microsoft Internet Explorer a potom v ponuke Pomocník kliknite na položku Čo je Microsoft Internet Explorer Overte, či je v položke Zložitosť šifrovania zadaná hodnota 128-bit.

Operačné systémy Microsoft Windows 95, Microsoft Windows 98, Microsoft Windows 98 Second Edition

  1. Kliknite na tlačidlo Štart, presuňte sa na položkuNastavenia, kliknite na položkuMožnosti priečinkaa potom kliknite na kartu Zobrazenie.
  2. V časti Rozšírené nastavenia kliknite na položku Zobraziť všetky súbory, zrušte začiarknutie políčka Skryť prípony registrovaných typov súborov a potom kliknite na tlačidlo OK.
  3. Spustite program Prieskumník, vyhľadajte priečinok jenotka:\Windows\System folder.

    Poznámnka: drive is the drive where Windows is installed.
  4. Premenujte súbory Schannel.dll, Rsabase.dll a Rsaenh.dll (ak sú prítomné) použitím prípony .old. Urobíte to nasledovne:
    1. Pravým tlačidlom myši kliknite na súbor Schannel.dll a potom kliknete na položku Premenovať.
    2. Napíšte schannel.olda kliknite na kláves Enter.
    3. Kroky 2a a 2b urobte aj pre súbory Rsabase.dll a Rsaenh.dll.
  5. Znovu nainštalujte program Microsoft Internet Explorer. Použite metódu podľa verzie programu Microsoft Internet Explorer:

    Microsoft Internet Explorer 6.0

    1. Prevezmite a nainštalujte Microsoft Internet Explorer 6.0 alebo reinštalujte program Microsoft Internet Explorer 6.0 z nasledujúcej webovej lokality (platí to iba pre anglickú a českú verziu programu Internet Explorer):
      http://www.microsoft.com/windows/ie/downloads/ie6/default.asp

      Ak máte slovenskú verziu operačného systému, prevezmite a nainštalujte program Internet Explorer 5.5 SP2 z nasledujúcej lokality:http://www.microsoft.com/windows/ie_intl/sk/download/default.aspPoznámka Ak sa zobrazí okno Preinštalovať všetky položky? , kliknite na položku Preinštalovať všetky položkya potom kliknite na tlačidlo OK.
    2. Reštartujte počítač. Spustite program Microsoft Internet Explorer a potom v ponuke Pomocník kliknite na položku Čo je Internet Explorer. Skontrolujte, či Zložitosť šifrovania je 128-bitov.

Metóda 3: Microsoft Windows XP

Oprava alebo reinštalácia programu Microsoft Internet Explorer alebo systému Microsoft Windows XP.

For additional information about how to do this, click the following article numbers to view the articles in the Microsoft Knowledge Base:
318378 How to reinstall or repair Internet Explorer and Outlook Express in Windows XP
315341 How to perform an in-place upgrade (reinstallation) of Windows XP

DALSIE INFORMACIE

Ak ani po obnovení úrovne šifrovania na 128-bitov sa stále nemôžete pripojiť na zabezpečené webové stránky, urobte nasledujúce:
  1. V ponuke Nástroje kliknite na položku Možnosti siete Internet a potom kliknite na kartu Spresnenie.
  2. V časti Zabezpečenie kliknutím začiarknite políčka Použiť protokol SSL 2.0 a Použiť protokol SSL 3.0 (ak už nie sú začiarknuté).
  3. 3. Kliknite na tlačidlo OK.

ODKAZY

For additional information about how to troubleshoot a similar issue, click the following article number to view the article in the Microsoft Knowledge Base:
303807 'The page cannot be displayed' error message when you try to view Web page on a secure Web site
For additional information about how to extract compressed Windows files, click the following article number to view the article in the Microsoft Knowledge Base:
129605 How to extract original compressed Windows files
For additional information about how to determine which folder Windows is installed in, click the following article number to view the article in the Microsoft Knowledge Base:
305792 How to determine which folder Windows is installed in

Vlastnosti

ID článku: 261328 - Posledná kontrola: 12. apríla 2005 - Revízia: 7.5
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Internet Explorer 6.0, pri použití s produktom:
    • Microsoft Windows XP Professional
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
  • Microsoft Internet Explorer 5.5, pri použití s produktom:
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 95
  • Microsoft Internet Explorer 5.01, pri použití s produktom:
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 95
  • Microsoft Internet Explorer 5.0, pri použití s produktom:
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 95
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 4.0 128-Bit Edition
Kľúčové slová: 
kbenv kbui kbprb kbfaq KB261328

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com