ID d'événement 9877 avec le code d'erreur « 0x80041606 » lorsque que vous utilisez Outlook en mode en ligne pour rechercher un mot clé dans Exchange Server 2010

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Symptômes

Envisagez le scénario suivant. Par défaut, Exchange recherche est activée pour une base de données de boîtes aux lettres dans un environnement Microsoft Exchange Server 2010. Vous utilisez Microsoft Outlook en mode en ligne pour rechercher une boîte aux lettres d'un mot clé ou une expression qui contient une seule lettre ou un chiffre unique. Dans ce scénario, le message d'erreur suivant s'affiche même s'il existe des correspondances pour le mot clé dans la boîte aux lettres :
Aucune correspondance trouvée pour"mot clé".

En outre, l'événement suivant est enregistré dans le journal d'Application :
Nom du journal : Application
Source : MSExchangeIS Mailbox Store
Date : Date
L'ID d'événement : 9877
Catégories de tâches : L'indexation du contenu
Niveau : erreur
Mots clés : classique
Utilisateur : n/a
Ordinateur : Ordinateur
Description :
Fonction d'indexation de contenu « CISearch::EcGetRowsetAndAccessor » a reçu un code d'erreur inattendu et inhabituel de MSSearch.
Base de données de boîtes aux lettres : Base de données de boîtes aux lettres
Code d'erreur : 0x80041606
REMARQUE : 0X80041606 = QUERY_E_TOOCOMPLEX

Cause

Ce problème se produit car Exchange recherche a une limite de recherche de préfixe codée en dur de 200 000 n?uds pour une recherche de caractère unique. Lors d'une recherche par préfixe dépasse cette limite, la recherche renvoie les QUERY_E_TOOCOMPLEX.Par conséquent, 0x80041606 est enregistré dans le cadre de l'événement ID 9877. Par défaut, toutes les recherches qui utilisent le mode en ligne d'Outlook dans un environnement Exchange 2010 sont préfixe. À l'aide de lettres ou chiffres unique entraîne le rechercher tous les nombres ou les mots qui commence avec le chiffre ou la lettre sur la base de données de boîte aux lettres entière. Si la limite par défaut de 200 000 n?uds est atteinte, la recherche renvoie l'erreur.

Remarque La méthode la plus courante pour atteindre la limite de 200 000 n?uds est de rechercher un mot ou une expression qui contient un chiffre ou une lettre. Il existe également des autres causes moins communes, telle que la saisie des recherches très complexes avec de nombreux relie, Ors et NOTs. En outre, des combinaisons complexes de plages de dates et termes de recherche, de nombreuses entrées dans le champ à et à partir des champs, ou une combinaison de tous ces éléments peut entraîner la limite est atteinte.

Résolution

Pour résoudre ce problème, installez le correctif cumulatif suivant :
2608646 Description du correctif cumulatif 6 pour Exchange Server 2010 Service Pack 1
Important Cette section, méthode ou tâche contient des étapes vous indiquant comment modifier le Registre. Toutefois, des problèmes graves peuvent survenir si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour une meilleure protection, sauvegardez le Registre avant de le modifier. Ensuite, vous pouvez restaurer le Registre si un problème survient. Pour plus d'informations sur la façon de sauvegarder et de restaurer le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
322756 Comment faire pour sauvegarder et restaurer le Registre dans Windows

Après avoir installé le correctif cumulatif de mise à jour, procédez comme suit pour définir le nombre maximal de n?uds de restriction de requête à 1 000 000 (décimal) :
  1. Vérifiez combien l'événement ID 9877 avec 0x80041606 les événements dans le journal des applications que vous avez reçues sur un serveur de boîtes aux lettres Exchange Server 2010 particulier au cours du dernier mois et que l'enregistrement du nombre.
  2. Cliquez sur Démarrer
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    bouton Démarrer
    , tapez regedit dans la zone Rechercher et appuyez sur ENTRÉE.
  3. Recherchez, puis cliquez sur la clé de Registre suivante :
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExchangeServer\v14\ExSearch
  4. Cliquez sur Edition, pointez sur Nouveau, puis cliquez sur clé.
  5. Tapez MaxRestrictionNodes, puis appuyez sur ENTRÉE.
  6. Sous MaxRestrictionNodes, cliquez sur Modifier, pointez sur Nouveau, puis cliquez sur Valeur DWORD.
  7. Tapez servirret appuyez sur ENTRÉE.
  8. L'entrée de Registre doit maintenant ressembler à ceci :

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExchangeServer\v14\ExSearch\MaxRestrictionNodes\Server
  9. Cliquez sur Modifier, puis cliquez sur Modifier.
  10. Dans la zone données de la valeur , tapez 1000000 (Décimale).
    Remarque La valeur par défaut de l'entrée MaxRestrictionNodes\Server est 200000 (décimal) avant d'apporter des modifications au Registre.
  11. Quittez l'Éditeur du Registre.
Notes
  • Une fois que vous redémarrez le service Microsoft Exchange Search Indexer, archiver l'application pour l'ID d'événement suivants :
    • L'ID d'événement 130 n'a pas pu convertir le MailboxDB Guid lire dans sous la clé de Registre MaxRestrictionNodes à un Guid
    • ID d'événement 131 n'a pas pu ouvrir la clé de Registre MaxRestrictionNodes
    • ID d'événement 132 Impossible de définir la propriété MaxRestrictionNodes dans l'indexeur
  • Si vous recevez un de ces événements, vous avez peut-être entré la clé de Registre ou de la valeur DWORD incorrectement. Ou bien, vous ne pouvez pas ont la nouvelle clé ou valeur DWORD correctement orthographié. Apportez les corrections nécessaires et redémarrez le Service Microsoft Exchange Search Indexer. Recherchez toutes les nouvelles instances d'événement ID 130, 131 et 132.
  • Vérifiez le journal d'Application hebdomadaire et mensuel qui dépend du nombre d'événement ID 9877 avec l'erreur 0x80041606 dans le journal d'Application.
  • Si vous recevez toujours un nombre important de ces événements, vous pouvez augmenter la valeur incrémentielle de 2000000 (décimal).
  • N'augmentez pas la valeur au-delà de 2000000 (décimal), car cela peut réduire les performances du serveur.
  • Si vous avez augmenté de la valeur de 2000000 (décimal) et que vous recevez toujours certains de ces événements hebdomadaires ou mensuelles, il s'agit du comportement attendu. Ce comportement peut être provoqué par les utilisateurs effectuant des recherches très complexes (voir la section « Symptômes » pour plus d'informations).

Statut

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Pour plus d'informations sur la recherche de Exchange, visitez le site Web Microsoft suivant :
Informations générales sur la recherche Exchange
Pour plus d'informations sur la façon de désactiver ou d'activer la recherche Exchange, visitez le site Web Microsoft suivant :
Informations générales sur la façon de désactiver ou d'activer la recherche Exchange
Pour plus d'informations sur l'entrée MaxRestrictionNodes , visitez le site Web Microsoft suivant :
Informations générales sur l'écriture de MaxRestrictionNodes

Propriétés

Numéro d'article: 2616127 - Dernière mise à jour: jeudi 28 août 2014 - Version: 4.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Exchange Server 2010 Service Pack 1 sur le système suivant
    • Microsoft Exchange Server 2010 Enterprise
    • Microsoft Exchange Server 2010 Standard
Mots-clés : 
kbqfe kbfix kbsurveynew kbexpertiseinter kbmt KB2616127 KbMtfr
Traduction automatique
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La version anglaise de cet article est la suivante: 2616127
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