Artikel-ID: 2616127 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Problembeschreibung

Betrachten Sie das folgende Szenario. Standardmäßig ist die Exchange-Suche für eine Postfachdatenbank in einer Umgebung mit Microsoft Exchange Server 2010 aktiviert. Sie verwenden Microsoft Outlook im Onlinemodus befindet, suchen Sie ein Postfach für ein Schlüsselwort oder einen Ausdruck, der einen einzelnen Buchstaben oder eine Ziffer enthält. In diesem Szenario wird die folgende Fehlermeldung angezeigt, auch wenn Übereinstimmungen für das Schlüsselwort im Postfach vorhanden sind:
Keine Übereinstimmungen gefunden für"Schlüsselwort".

Darüber hinaus wird das folgende Ereignis im Anwendungsprotokoll protokolliert:
Protokollname: Anwendung
Quelle: MSExchangeIS Mailbox Store
Datum: Datum
Ereignis-ID: 9877
Aufgabenkategorie: Content-Indexierung
Stufe: Fehler
Schlüsselwörter: Klassisch
Benutzer: n/a
Computer: Computer
Beschreibung
Content Indexing-Funktion 'CISearch::EcGetRowsetAndAccessor' hat einen ungewöhnliche und unerwartete Fehlercode von MSSearch.
Postfach-Datenbank: Postfach-Datenbank
Fehlercode: 0x80041606
HINWEIS: 0X80041606 = QUERY_E_TOOCOMPLEX

Ursache

Dieses Problem tritt auf, weil Exchange-Suche Präfix fest programmierte Suche maximal 200.000 Knoten für ein einzelnes Zeichen suchen kann. Wenn eine Präfixsuche diesen Grenzwert überschreitet, gibt die Suche QUERY_E_TOOCOMPLEX.Aus diesem Grund wird 0x80041606 als Teil der Ereignis-ID 9877 protokolliert. Standardmäßig sind alle suchen, die online-Modus von Outlook in einer Exchange 2010-Umgebung verwenden präfixsuchen. Über einzelne Ziffern oder Buchstaben führt das System den für alle Zahlen oder Wörter zu suchen, das beginnen mit der Ziffer oder einem Buchstaben über die gesamte Postfachdatenbank. Wenn das Standardlimit von 200.000 Knoten erreicht ist, gibt die Suche den Fehler zurück.

Hinweis Die häufigste Ursache für das Erreichen der 200.000 Knoten Grenze ist eine Suchanfrage, welche nur eine Ziffer oder einen Buchstaben enthält. Es gibt auch andere weniger häufige Ursachen wie sehr komplexe Suchvorgänge mit vielen und, Regionen in äußerster Randlage, Eingabe und reich. Darüber hinaus möglicherweise komplexe Kombinationen von Datumsbereiche und Suchbegriffe, viele Einträge im Feld an und von Feldern oder eine Kombination aus alles das Limit erreicht wird.

Lösung

Um dieses Problem zu beheben, installieren Sie das folgende Updaterollup:
2608646 Hinweise zum Updaterollup 6 für Exchange Server 2010 Servicepack 1
Wichtig: Dieser Abschnitt bzw. die Methode oder Aufgabe enthält Schritte, die erklären, wie Sie die Registrierung ändern. Allerdings können schwerwiegende Probleme auftreten, wenn Sie die Registrierung falsch ändern. Stellen Sie daher sicher, dass Sie die folgenden Schritte sorgfältig ausführen. Für zusätzlichen Schutz, sichern Sie die Registry, bevor Sie sie ändern. Anschließend können Sie die Registrierung wiederherstellen, falls ein Problem auftritt. Für weitere Informationen wie Sie der Registry sichern und wiederherstellen, klicken Sie auf die folgende Artikelnummer, um den Artikel in der Microsoft Knowledge Base anzuzeigen:
322756 Wie Sie die Registrierung in Windows sichern und wiederherstellen können?

Gehen folgendermaßen Sie vor, um die maximale Anzahl von Abfrageknoten für Softwareeinschränkung 1.000.000 (dezimal) fest, nach der Installation des Updaterollups:
  1. Überprüfen Sie wie viele Ereignis-ID 9877 mit 0x80041606-Ereignisse in das Anwendungsprotokoll auf einem bestimmten Exchange Server 2010-Postfach-Server erhalten haben, die im letzten Monat und notieren Sie die Nummer.
  2. Klicken Sie auf Start
    Bild minimierenBild vergrößern
    Schaltfläche "Start"
    , geben Sie Regedit in das Feld Suche starten ein, und drücken Sie die EINGABETASTE.
  3. Suchen Sie und klicken Sie dann auf den folgenden Registrierungsschlüssel:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExchangeServer\v14\ExSearch
  4. Klicken Sie auf Bearbeiten, zeigen Sie auf neu, und klicken Sie dann auf Schlüssel.
  5. Typ MaxRestrictionNodes, und drücken Sie dann die EINGABETASTE.
  6. Klicken Sie unter MAxRestrictionNodesauf Bearbeiten, zeigen Sie auf neu, und klicken Sie dann auf DWORD-Wert.
  7. Geben Sie ServeR, und drücken Sie dann die EINGABETASTE.
  8. Der Registrierungseintrag sollte nun folgendermaßen aussehen:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExchangeServer\v14\ExSearch\MaxRestrictionNodes\Server
  9. Klicken Sie auf Bearbeiten, und klicken Sie dann auf Ändern.
  10. Geben Sie im Feld Wertdaten1000000 (Dezimal).
    Hinweis Der Standardwert des Eintrags MaxRestrictionNodes\Server ist 200000 (dezimal), bevor Sie Änderungen vornehmen, in die Registrierung.
  11. Beenden Sie den Registrierungs-Editor.
Hinweise
  • Überprüfen Sie nach dem Neustart des Microsoft Exchange-suchindizierungsdiensts in der Anwendung für die folgenden Ereignis-IDs:
    • Ereigniskennung 130 Fehler beim Konvertieren des GUIDs MailboxDB lesen unter dem Registrierungsschlüssel MaxRestrictionNodes auf einer Guid
    • Fehler beim Öffnen des Registrierungsschlüssels MaxRestrictionNodes Ereigniskennung 131
    • Fehler beim Festlegen der MaxRestrictionNodes-Eigenschaft in der Indexer Ereigniskennung 132
  • Wenn Sie eines dieser Ereignisse empfangen, können Sie den Registrierungsschlüssel oder den DWORD-Wert falsch eingegeben haben. Oder Sie können nicht haben die neuen Schlüssel oder einen DWORD-Wert richtig geschrieben. Nehmen Sie die erforderlichen Korrekturen vor, und starten Sie Microsoft Exchange Search Indexer-Dienst. Suchen Sie nach neuen Instanzen der Ereignis-IDs, 130, 131 und 132.
  • Überprüfen Sie das Anwendungsprotokoll wöchentlich und monatlich die hängt der Anzahl der Ereignis-ID 9877 mit Fehler 0x80041606 in das Anwendungsprotokoll.
  • Wenn Sie immer noch eine bedeutende Anzahl dieser Ereignisse empfangen, können Sie den Wert inkrementell zu 2000000 (dezimal) erhöhen.
  • Erhöhen Sie den Wert über 2000000 (dezimal), nicht, da dies die Serverleistung beeinträchtigen kann.
  • Wenn Sie den Wert 2000000 (dezimal) erhöht haben und noch ein Paar dieser Ereignisse, wöchentlich oder monatlich erhalten, ist dies das erwartete Verhalten. Dieses Verhalten kann durch Benutzer sehr komplexe Suche (finden Sie im Abschnitt "Problembeschreibung" für Weitere Informationen) verursacht werden.

Status

Microsoft hat bestätigt, dass es sich um ein Problem bei den Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Weitere Informationen

Weitere Informationen zur Exchange-Suche finden Sie auf der folgenden Microsoft-Website:
Allgemeine Informationen über die Exchange-Suche
Weitere Informationen zum Deaktivieren oder aktivieren Sie die Exchange-Suche finden Sie auf der folgenden Microsoft-Website:
Allgemeine Informationen über die Exchange-Suche aktivieren oder deaktivieren
Weitere Informationen zu den Eintrag MaxRestrictionNodes finden Sie auf der folgenden Microsoft-Website:
Allgemeine Informationen über den MaxRestrictionNodes-Eintrag

Eigenschaften

Artikel-ID: 2616127 - Geändert am: Donnerstag, 28. August 2014 - Version: 4.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Exchange Server 2010 Service Pack 1, wenn verwendet mit:
    • Microsoft Exchange Server 2010 Enterprise
    • Microsoft Exchange Server 2010 Standard
Keywords: 
kbqfe kbfix kbsurveynew kbexpertiseinter kbmt KB2616127 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell übersetzt und wird dann möglicherweise mithilfe des Community Translation Framework (CTF) von Mitgliedern unserer Microsoft Community nachbearbeitet. Weitere Informationen zu CTF finden Sie unter http://support.microsoft.com/gp/machine-translation-corrections/de.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 2616127
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Kontaktieren Sie uns, um weitere Hilfe zu erhalten

Kontaktieren Sie uns, um weitere Hilfe zu erhalten
Wenden Sie sich an den Answer Desk, um professionelle Hilfe zu erhalten.