E-Mail-Nachrichten können nur vom Client RoleTailored in Microsoft Dynamics NAV 2009 in einer 3-Tier-Umgebung mit der anonymen Authentifizierung gesendet werden

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Artikel-ID: 2618652 - Produkte anzeigen, auf die sich dieser Artikel bezieht
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Problembeschreibung

Wenn Sie die SMTP-Mail-Codeunit (400) im RoleTailored-Client (RTC) in Microsoft Dynamics NAV 2009 in einer 3-Tier-Umgebung verwenden, können e-Mail-Nachrichten nur bei gesendet werden Anonymewie die Authentifizierung in der SMTP-Mail-Setup ausgewählt ist.
Die e-Mail-Nachrichten können jedoch mit einem beliebigen Typ der Authentifizierung in der klassischen Client gesendet werden.
HinweisWenn Sie der RTC, hostet die NAV-Service-Stufe (NST) auf dem Server ausführen, funktioniert die SMTP-Mail-Codeunit (400) mit einem beliebigen Typ der Authentifizierung.
Dieses Problem tritt in den folgenden Produkten:
  • Microsoft Dynamics NAV 2009 R2
  • Microsoft Dynamics NAV 2009 Servicepack 1 (SP1)

Ursache

Dieses Problem tritt auf, da die Identität des Clients in drei Tier-Umgebungen unterschiedlich ist. Daher auftreten die Authentifizierungsprobleme, in der Microsoft Exchange Server.

Lösung

Hotfix-Informationen

Ein unterstützter Hotfix ist jetzt von Microsoft verfügbar. Es ist jedoch lediglich das Problem zu beheben, das in diesem Artikel beschrieben wird. Wenden Sie es nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix möglicherweise weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir, dass Sie warten auf das nächste Servicepack für Microsoft Dynamics NAV 2009 oder die nächste Version von Microsoft Dynamics NAV, die diesen Hotfix enthält.

Hinweis In besonderen Fällen, die normalerweise für Support-Anrufe Wenn ein Support-Experte für Microsoft Dynamics und zugehörige Produkte storniert werden fallen Gebühren feststellt, dass ein bestimmtes Update Ihr Problem beheben kann. Die normalen Supportkosten gelten für zusätzliche Supportfragen und Probleme, die für das betreffende Update nicht qualifizieren.


Informationen zur Installation

Microsoft bietet Programmierbeispiele lediglich zur Veranschaulichung, ohne Gewährleistung, ausdrücklich oder konkludent. Dies umfasst, aber ist nicht beschränkt auf KONKLUDENTEN GEWÄHRLEISTUNGEN der Tauglichkeit oder Eignung für einen bestimmten Zweck. In diesem Artikel wird davon ausgegangen, dass Sie mit der Programmiersprache, die von Beispielen verwendeten und vertraut mit den Tools, die zum Erstellen und Debuggen von Prozeduren verwendet werden. Microsoft-Supporttechniker können der Erläuterung der Funktionalität bestimmter Prozeduren helfen werden, jedoch nicht verändern sie diese Beispiele zur eine erweiterte Funktionalität und Programmierungsbeispiele für Ihre spezifischen Anforderungen.

Hinweis Bevor Sie diesen Hotfix installieren, stellen Sie sicher, dass alle Microsoft Navision-Clientbenutzer vom System abgemeldet sind. Dazu gehören Microsoft Navision Application Services (NAS) Client-Benutzer. Sie sollten den nur-Client-Benutzer sein, der angemeldet ist, wenn Sie diesen Hotfix installieren.

Sie müssen über eine Entwicklerlizenz verfügen, um diesen Hotfix zu installieren, können.

Es wird empfohlen, dass das Benutzerkonto im Fenster Windows Anmeldungen oder im Fenster Datenbankanmeldungen den Rollen-ID "SUPER" zugewiesen werden Wenn das Benutzerkonto die Rollen-ID "SUPER" zugeordnet werden kann, müssen Sie sicherstellen, dass das Benutzerkonto die folgenden Berechtigungen verfügt:
  • Änderungsberechtigung für das Objekt, das Sie ändern.
  • Die Execute-Berechtigung für die System Object ID 5210 Objekt und für die System Object ID 9015 -Objekt.


Hinweis Sie haben keine Rechte für die Datenspeicher verfügen, es sei denn, es sind Datenreparaturen durchzuführen.

Änderungen am Code

Hinweis Codefixes immer Test in einer kontrollierten Umgebung vor der Anwendung der auf Ihre Produktionsumgebung.
Um dieses Problem zu beheben, ändern Sie den Code in der Codeunit "SMTP-Mail" (400). Nachdem Sie die Änderungen übernehmen, werden e-Mail-Nachrichten erstellt und vom Client anstelle des Servers gesendet. Daher werden die e-Mail-Nachrichten, die Identität des ausführenden Benutzers beibehalten.
Gehen Sie hierzu folgendermaßen vor:
  1. Bereitstellen und die Microsoft.Navision.Mail.dll-Assembly im Client registrieren. Führen Sie hierzu den folgenden Befehl ein:
    /tlb:Microsoft.Navision.Mail.tlb Regasm / codebase Microsoft.Navision.Mail.dll
  2. Ändern Sie den Code in der Codeunit "SMTP-Mail" (400) wie folgt:
    Vorhandener code
    ...
    PROCEDURE CreateMessage@.....
    BEGIN
    IF Recipients <> '' THEN
    CheckValidEmailAddresses(Recipients);
    CheckValidEmailAddresses(SenderAddress);
    SMTPMailSetup.GET;
    SMTPMailSetup.TESTFIELD("SMTP Server");
    IF ISCLEAR(Mail) THEN
    CREATE(Mail);
    Mail.FromName := SenderName;
    ...
    Neuer code
    ...
    PROCEDURE CreateMessage@.....
    BEGIN
    IF Recipients <> '' THEN
    CheckValidEmailAddresses(Recipients);
    CheckValidEmailAddresses(SenderAddress);
    SMTPMailSetup.GET;
    SMTPMailSetup.TESTFIELD("SMTP Server");
    IF ISCLEAR(Mail) THEN
    CREATE(Mail,TRUE,TRUE);
    Mail.FromName := SenderName;
    ...

Voraussetzungen

Sie müssen eine der folgenden Produkte für diesen Hotfix installiert haben:
  • Microsoft Dynamics NAV 2009 R2
  • Microsoft Dynamics NAV 2009 Servicepack 1
Sie müssen die folgenden Hotfixes installiert haben:
  • 2499881 Sie können nicht in Microsoft Dynamics NAV 2009 die TLS-Einstellungen für SMTP-Kommunikation konfigurieren.
  • 2345735 Sie können den Standardport für SMTP-Kommunikation in Microsoft Dynamics NAV nicht ändern
  • 2479702 E-Mail-Nachrichtentext ist falsch, wenn Sie eine e-Mail-Nachricht erstellen, indem Sie mithilfe der AppendBody-Methode in Microsoft Dynamics NAV 2009 Service Pack 1
  • 2280492 Anlagen werden erst freigegeben, wenn Microsoft Dynamics NAV-Client geschlossen wird, wenn Sie die SMTP-Mail-Codeunit (400) verwenden, um e-Mail-Nachrichten senden, die Anlagen
  • 2516144 Sie erhalten die fehlerhaften e-Mail-Nachrichten, wenn Sie eine bestimmte Version 7 verwenden die Microsoft.Navision.Mail.dll-Datei in Microsoft Dynamics NAV 2009 release

Informationen zur Deinstallation

Sie können nicht diesen Hotfix entfernen.

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten, die im Abschnitt "Gilt für" aufgeführt sind.
Hinweis Dies ist eine "Schnelle veröffentlichen" Artikel direkt in der Microsoft Support-Organisation erstellt. Die hierin enthaltenen Informationen als-ist die Antwort zu aufkommenden Problemen. Aufgrund der Geschwindigkeit in verfügbar zu machen die Materialien können typografische Fehler enthalten und können jederzeit ohne vorherige Ankündigung geändert werden. Finden Sie unter Nutzungsbedingungen für andere Überlegungen.

Eigenschaften

Artikel-ID: 2618652 - Geändert am: Donnerstag, 29. September 2011 - Version: 1.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Dynamics NAV 2009
Keywords: 
kbqfe kbmbsmigrate kbsurveynew kbmbscodefix kbmt KB2618652 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 2618652
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