Iniciar sessão com a Microsoft
Iniciar sessão ou criar uma conta.
Olá,
Selecione uma conta diferente.
Tem várias contas
Selecione a conta com a qual pretende iniciar sessão.

Introdução

Os Serviços de Domínio de Diretório Ativo (AD DS) atribuem identificadores de segurança únicos (SIDs) a utilizadores, computadores, grupos e fidedignidades que são criados em Diretório Ativo. Os SIDs consistem num prefixo de domínio concatenado com um identificador relativo monótono aumentando (RID). Cada domínio do Diretório Ativo é atribuído a um pool global de RID que consiste em mil milhões de RIDs. Para permitir que cada controlador de domínio Ative Directy crie novos diretores de segurança, cada controlador de domínio é atribuído a corrente e piscinas RID de espera do mestre RID. Quando o pool global RID para o domínio e para as piscinas locais em controladores de domínio individuais em um domínio é esgotado, utilizadores adicionais, computadores e grupos não podem mais ser criados no domínio. Para contornar esta questão, pode criar e migrar objetos e aplicações para um novo domínio. Este artigo descreve uma condição em que uma falha lógica pode resultar em muitos pedidos de piscina rid. Isto leva à exaustão global da piscina RID.

Sintomas

Em certas circunstâncias raras, os controladores de domínio ative Directy podem consumir inesperadamente uma grande quantidade de recursos RID. Este comportamento esgota a piscina global rid. Quando este problema ocorre, você experimenta uma ou mais das seguintes questões:

  • Os RIDs na piscina global rid estão continuamente a ser consumidos ao longo do tempo.

  • O número de RIDs que são consumidos no pool global rid é maior do que o esperado, tendo em conta o número de diretores de segurança que são intencionalmente criados durante a vida útil do domínio.

  • O teste DCDIAG RID Manager indica que uma pesquisa do atributo RidSetReferences falha. Além disso, recebe a seguinte mensagem de erro:

    Teste de início: RidManager Aviso: atribuir rIdSetReferências em falta CN=nome,OU=Controladores de Domínio,DC=nome,DC=nome,DC=nome,DC=nome Não consegui obter Rid set Referência :falhou com 8481: A pesquisa não conseguiu recuperar atributos da base de dados. ......................... nome falhado teste ridManager

O hotfix em KB 2618669 permite a capacidade de detetar e prevenir este comportamento nos controladores de domínio baseados no Windows Server 2008 R2.

Este comportamento está incluído nas versões RTM de 

  • Versões OS lançadas após Windows Server 2019

  • Windows Server 2019

  • Windows Server 2016

  • Windows Server 2012 R2

  • Windows Server 2012

Causa

Em certas circunstâncias raras, um controlador de domínio pode emitir pedidos recorrentes de RIDs do pool global RID a cada 30 segundos. Se os pedidos repetitivos para atualizações do pool RID forem autorizados a continuar por um período significativo de tempo, o pool global RID pode experimentar demasiado consumo de RID. Em casos extremos, a piscina global rid pode estar completamente esgotada.

Resolução

Para evitar demasiado consumo de RID na piscina global rid, recomendamos que tome as seguintes ações:

  • Instale a mais recente atualização mensal que é lançada após (setembro de 2016, KB3185278) em todos os controladores de domínio Do Windows Server 2008 R2 existentes.

  • Integre a atualização nos meios de instalação Do Windows Server 2008 R2. Ao fazê-lo, garante que os futuros controladores de domínio também terão esta atualização.

  • Implemente o papel de Diretório Ativo em versões mais recentes de SO que contenham esta funcionalidade no lançamento do RTM.

Informação de hotfixo

Um hotfix suportado está disponível na Microsoft. No entanto, este hotfix destina-se a corrigir apenas o problema descrito neste artigo. Aplique este hotfix apenas nos sistemas que estão a experimentar o problema descrito neste artigo. Este hotfix pode receber testes adicionais. Portanto, se não for severamente afetado por este problema, recomendamos que aguarde a próxima atualização de software que contenha este hotfix. Se o hotfix estiver disponível para download, existe uma secção de "Hotfix download disponível" no topo deste artigo da Knowledge Base. Se esta secção não aparecer, contacte o Serviço de Apoio ao Cliente da Microsoft para obter o hotfix. Nota Se ocorrerem problemas adicionais ou se for necessário algum problema, poderá ter de criar um pedido de serviço separado. Os custos habituais de apoio aplicar-se-ão a questões e questões de apoio adicionais que não se qualificam para este hotfix específico. Para obter uma lista completa dos números de telefone do Microsoft Customer Service e Support ou para criar um pedido de serviço separado, visite o seguinte Web site da Microsoft:

http://support.microsoft.com/contactus/?ws=support Nota O formulário "Hotfix download disponível" apresenta os idiomas para os quais o hotfix está disponível. Se não vê a sua língua, é porque não está disponível um hotfix para esse idioma.

Estado

A Microsoft confirmou que este problema ocorre nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informações

Para obter mais informações sobre terminologia de atualização de software, clique no seguinte número de artigo para ver o artigo na Base de Conhecimento da Microsoft:

824684 Descrição da terminologia padrão utilizada para descrever as atualizações de software da Microsoft

Precisa de mais ajuda?

Quer mais opções?

Explore os benefícios da subscrição, navegue em cursos de formação, saiba como proteger o seu dispositivo e muito mais.

As comunidades ajudam-no a colocar e a responder perguntas, a dar feedback e a ouvir especialistas com conhecimentos abrangentes.

Estas informações foram úteis?

Quão satisfeito está com a qualidade do idioma?
O que afetou a sua experiência?
Ao selecionar submeter, o seu feedback será utilizado para melhorar os produtos e serviços da Microsoft. O seu administrador de TI poderá recolher estes dados. Declaração de Privacidade.

Obrigado pelo seu feedback!

×