"Federation service identifier specified in the AD FS 2.0 server is already in use." error when you try to set up another federated domain in Office 365, Azure, or Windows Intune

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Article ID: 2618887 - View products that this article applies to.
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PROBLEM

In a Microsoft cloud service such as Office 365, Microsoft Azure, or Windows Intune, you can't set up a second federated domain on an Active Directory Federation Services (AD FS) server. When you use the Azure Active Directory Module for Windows PowerShell to run the new-MSOLFederatedDomain cmdlet or the convert-MSOLDomainToFederated cmdlet, you receive the following error message:
The federation service identifier specified in the Active Directory Federation Services 2.0 server is already in use. Please correct this value in the AD FS 2.0 Management console and run the command again.

CAUSE

The Azure Active Directory (Azure AD) authentication system requires a unique federation brand uniform resource identifier (URI) for each federated domain. By default, AD FS uses a global value for all federated trusts. When you try to federate a second domain in a scenario where a federated trust already exists, the request fails because the URI is already being used.

SOLUTION

To resolve the issue, you must use the -supportmultipledomain switch to add or convert every domain that's federated by the cloud service. This includes federated domains that already exist.

Step 1: Install Update Rollup 1 for AD FS 2.0

On each node of the AD FS 2.0 Federation Service farm, download and install Update Rollup 1 for AD FS 2.0. For more information about how to download and install Update Rollup 1 for AD FS 2.0, click the following article number to view the article in the Microsoft Knowledge Base:
2607496 Description of Update Rollup 1 for Active Directory Federation Services (AD FS) 2.0
Note This update requires a restart of the computer. If you do not restart the computer, you will experience the issue that's described in the following article in the Microsoft Knowledge Base:
2635357 "Sorry, but we're having trouble signing you in" and "8004789A" error when a federated user tries to sign in to Office 365, Azure, or Windows Intune

Step 2: Check that the update-MSOLFederatedDomain cmdlet can be run successfully against the AD FS environment

  1. Click Start, point to All Programs, point to Windows Azure Active Directory, right-click Windows Azure Active Directory Module for Windows PowerShell and select Run As Administrator.
  2. At the command prompt, run the following cmdlets in the order in which they are presented. Press Enter after each cmdlet.
    • Connect-MSOLService

      Note When you are prompted, enter your cloud service global administrator credentials.
    • Set-MSOLADFSContext -Computer <AD FS 2.0 server name>


      Note In this command, <AD FS 2.0 server name> is the computer name of a node in the AD FS Federation Service farm.
    • Update-MSOLFederatedDomain -DomainName <Federated Domain Name>


      Note In this command, <Federated Domain Name> is the name of the domain that's already federated with Azure AD for single sign-On (SSO).

      Leave the Command Prompt window open for later use.
  3. If the update-MSOLFederatedDomain cmdlet is successful and you do not receive error messages, go to step 3 to remove the federated trust from the AD FS server.

Step 3: Update the federated trust on the AD FS server


Warning The following steps should be planned carefully. Users for which SSO functionality is enabled in the federated domain will be unable to authenticate between the completion of steps C and D. If the update-MSOLFederatedDomain cmdlet test in step 2 was not completed successfully, step D of this procedure will not finish correctly. Federated users will be unable to authenticate until the update-MSOLFederatedDomain cmdlet can be run successfully.
  1. Log on to the console of the AD FS server, click Start, point to All Programs, point to Administrative Tools, and then click AD FS (2.0) Management.
  2. In the left navigation pane, click AD FS (2.0), click Trust Relationships, and then click Relying Party Trusts.
  3. In the pane on the right side, delete the Microsoft Office 365 Identity Platform entry.
  4. Re-create the deleted trust object by using the -supportmultipledomain switch. In the PowerShell window that's open from step 1C, run the following cmdlet, and then press Enter:
    Update-MSOLFederatedDomain -DomainName <Federated Domain Name> -supportmultipledomain


    Note In this command, <Federated Domain Name> is the name of the domain that's already federated with the cloud service for SSO.

Step 4: Use the -supportmultipledomain switch to add or convert additional federated domains

After you update the existing trust in step 2, use the -supportmultipledomain switch to add or convert additional federated domains. This switch informs the cmdlet to use a unique URI namespace for each domain that's federated by the cloud service. To do this, use one of the following cmdlet syntaxes:
  • New-MSOLFederatedDomain -domainname <domain name> -supportmultipledomain
  • Convert-MSOLDomainToFederated -domainname <domain name> -supportmultipledomain


    Note In this command, <domain name> represents the name of the domain that you are trying to federate.

WORKAROUND

Implement an AD FS Federation Service farm to federate every cloud service domain for which SSO features will be used. AD FS implementation guidance for Office 365 can be found at the following Microsoft websites:

MORE INFORMATION

Still need help? Go to the Office 365 Community website or the Azure Active Directory Forums website.

Properties

Article ID: 2618887 - Last Review: July 9, 2014 - Revision: 18.0
Applies to
  • Microsoft Azure
  • Microsoft Office 365
  • Windows Intune
  • CRM Online via Office 365 E Plans
  • Microsoft Azure Recovery Services
  • Office 365 Identity Management
Keywords: 
o365 o365e o365022013 o365m o365a KB2618887

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