Нельзя управлять и удалять объекты, которые были синхронизированы через программу синхронизации Active Directory Azure

Переводы статьи Переводы статьи
Код статьи: 2619062 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

ПРОБЛЕМА

Рассмотрим следующий сценарий. Необходимо вручную управлять или удалить объекты, которые были созданы с помощью синхронизации каталогов из Active Directory Azure (Azure AD). Например вы хотите удалить потерянные пользователя учетной записи, синхронизация Azure AD из ваших локальных служб Active Directory домена (AD DS). Однако нельзя удалить потерянные учетной через портал службы облако Microsoft Office 365, Azure или Windows Intune или с помощью Windows PowerShell.

ПРИЧИНА

Эта проблема может возникнуть в следующих случаях:
  • Причина 1: На предприятии AD DS больше не доступен. Таким образом не может управлять или удалить объект из среды на предприятии.
  • Причина 2: Объект были удалены из локального AD DS. Тем не менее объект не был удален из организации облачных служб. Это непредвиденное поведение.

РЕШЕНИЕ

Для 1 Причина: требуется управление объектами в Office 365, Azure или Windows Intune и больше не требуется использовать синхронизацию каталогов.
  1. Установка модуля Azure Active Directory для Windows PowerShell. Для получения дополнительных сведений перейдите к веб-узел Майкрософт:
  2. Подключиться к Azure AD с помощью Windows PowerShell. Дополнительную информацию о том, как сделать это посетите следующий веб-узел корпорации Майкрософт:
    Подключиться к Azure AD
  3. Отключите синхронизацию каталогов. Для этого введите следующий командлет и нажмите клавишу ВВОД:
    Set-MsolDirSyncEnabled –EnableDirSync $false
  4. Убедитесь, что синхронизация каталогов был полностью отключен с помощью Windows PowerShell. Чтобы сделать это, выполните следующий командлет периодически:
    (Get-MSOLCompanyInformation).DirectorySynchronizationEnabled
    Этот командлет возвращает True или False. Продолжить выполнение этого командлета периодически пока он возвращает значение False, а затем перейдите к следующему шагу.

    ПримечаниеМожет потребоваться 72 часов для отключения должна быть завершена. Время зависит от количества объектов, находящихся в вашей учетной записи облачной службы подписки.
  5. Попробуйте обновить объект с помощью Windows PowerShell или с помощью портала облачной службы.
Примечание
  • Шаг 4 может занять некоторое время для завершения. Имеется процесс в среде службы облаков, вычисляет значения атрибутов. Процесс должна быть завершена до объектов может быть изменено с помощью Windows PowerShell или с помощью службы портала thecloud.
Для причины 2: удаление объекта из локальное AD DS. Тем не менее объект не удален из вашей учетной записи облачной службы подписки.

Выполнить синхронизацию каталогов, следуя инструкциям, приведенным на веб-узел Майкрософт:
Синхронизация папки
  • Если распространяются некоторые обновления и удаления, но не синхронизации некоторых удалений облачного сервиса, выполните синхронизацию каталогов обычно, рекомендации по устранению неполадок.
  • Все обновления и удаления, не синхронизируются с облачного сервиса, обратитесь в службу поддержки.
ПримечаниеАльтернативным способом решения для этого сценария объекта можно вручную удалить облачного сервиса. Однако невозможно обновить объект в облачной службы. Дополнительные сведения о том, как решить эту проблему, обратитесь к следующей статье Microsoft Knowledge Base:
2709902Удаление объекта не синхронизируются в Azure AD при использовании средства синхронизации Active Directory Azure

ДОПОЛНИТЕЛЬНЫЕ СВЕДЕНИЯ

Чтобы повторно включить синхронизацию каталогов, выполните следующий командлет:
Set-MsolDirSyncEnabled -EnableDirSync $true
ПредупреждениеВажно тщательное планирование при повторном включении синхронизации каталогов. Если используется служба портала облака или Windows PowerShell для внесения изменений непосредственно на объекты, которые изначально были синхронизированы из локальных Доменных службах Active Directory, изменения будут переписаны на предприятии атрибуты и параметры, впервые что синхронизация происходит после включения синхронизации каталогов.

По-прежнему нужна помощь? Последовательно выберите пункты Сообщество Office 365веб-узел илиФорумы Azure Active Directory веб-сайт.

Свойства

Код статьи: 2619062 - Последний отзыв: 26 июня 2014 г. - Revision: 23.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft Azure
  • Microsoft Office 365
  • Microsoft Office 365 for enterprises (pre-upgrade)
  • Microsoft Office 365 for education  (pre-upgrade)
  • CRM Online via Office 365 E Plans
  • Microsoft Azure Recovery Services
  • Office 365 Identity Management
Ключевые слова: 
o365 o365a o365e o365062011 pre-upgrade o365022013 after upgrade o365m kbmt KB2619062 KbMtru
Переведено с помощью машинного перевода
ВНИМАНИЕ! Данная статья переведена с использованием программного обеспечения Майкрософт для машинного перевода и, возможно, отредактирована посредством технологии Community Translation Framework (CTF). Корпорация Майкрософт предлагает вам статьи, обработанные средствами машинного перевода, отредактированные членами сообщества Майкрософт и переведенные профессиональными переводчиками, чтобы вы могли ознакомиться со всеми статьями нашей базы знаний на нескольких языках. Статьи, переведенные с использованием средств машинного перевода и отредактированные сообществом, могут содержать смысловое, синтаксические и (или) грамматические ошибки. Корпорация Майкрософт не несет ответственности за любые неточности, ошибки или ущерб, вызванные неправильным переводом контента или его использованием нашими клиентами. Подробнее об CTF можно узнать по адресу http://support.microsoft.com/gp/machine-translation-corrections/ru.
Эта статья на английском языке: 2619062

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com