Azure Active Directory Eşitleme aracı aracılığıyla eşitlenen nesneler yönetemiyor veya kaldırılamıyor

Bu makalede, dizin eşitlemesi aracılığıyla oluşturulan nesneleri Microsoft Entra ID yönetememenize veya kaldıramamanıza neden olan bir sorun açıklanır. Bu sorun için farklı nedenlere göre iki çözüm sağlar.

Özgün ürün sürümü: Cloud Services (Web rolleri/Çalışan rolleri), Microsoft Entra ID, Microsoft Intune, Azure Backup Office 365 Kimlik Yönetimi
Özgün KB numarası: 2619062

Belirtiler

Dizin eşitlemesi aracılığıyla oluşturulan nesneleri el ile yönetmeyi veya kaldırmayı Microsoft Entra ID:

Örneğin, şirket içi Active Directory Etki Alanı Hizmetleri 'nizden (AD DS) Microsoft Entra ID eşitlenmiş yalnız bırakılmış bir kullanıcı hesabını kaldırmak istiyorsunuz.

Bu senaryoda, Office 365, Azure veya Microsoft Intune'da Microsoft bulut hizmeti portalını kullanarak ya da Windows PowerShell kullanarak yalnız bırakılmış kullanıcı hesabını kaldıramazsınız.

Neden

Aşağıdaki koşullardan biri veya daha fazlası doğruysa bu sorun oluşabilir:

  • Şirket içi AD DS artık kullanılamıyor. Bu nedenle, nesneyi şirket içi ortamdan yönetemez veya silemezsiniz.
  • Şirket içi AD DS'den bir nesneyi sildiyseniz. Ancak nesne bulut hizmeti kuruluşunuzdan silinmedi. Bu davranış beklenmeyen bir durumdur.

Çözüm

Şirket içi AD DS artık kullanılamıyor. Bu nedenle, nesneyi şirket içi ortamdan yönetemez veya silemezsiniz

Office 365, Azure veya Intune nesneleri yönetmek istiyorsunuz ve artık dizin eşitlemesini kullanmak istemiyorsunuz.

Not

Azure AD ve MSOnline PowerShell modülleri 30 Mart 2024 itibarıyla kullanım dışı bırakılmıştır. Daha fazla bilgi edinmek için kullanımdan kaldırma güncelleştirmesini okuyun. Bu tarihten sonra bu modüllere yönelik destek, Microsoft Graph PowerShell SDK'sına geçiş yardımı ve güvenlik düzeltmeleriyle sınırlıdır. Kullanım dışı bırakılan modüller Mart 30 2025'e kadar çalışmaya devam edecektir.

Microsoft Entra ID (eski adıyla Azure AD) ile etkileşime geçmek için Microsoft Graph PowerShell'e geçiş öneririz. Sık sorulan geçiş soruları için Bkz. Geçiş SSS. Not: MSOnline'ın 1.0.x sürümleri 30 Haziran 2024'den sonra kesintiye neden olabilir.

  1. Windows 10 çalıştırmıyorsanız Microsoft Online Services Oturum Açma Yardımcısı: BT Uzmanları için Microsoft Online Services Oturum Açma Yardımcısı RTW'nin 64 bit sürümünü yükleyin.

  2. Windows PowerShell için Microsoft Azure Active Directory modülünü yükleyin:

    1. Yükseltilmiş bir Windows PowerShell komut istemi açın (yönetici olarak Windows PowerShell çalıştırın).
    2. Install-Module MSOnline komutunu çalıştırın.
  3. Aşağıdaki komutu çalıştırarak dizin eşitlemesini devre dışı bırakın:

     Set-MsolDirSyncEnabled -EnableDirSync $false
    
  4. Windows PowerShell kullanarak dizin eşitlemesinin tamamen devre dışı bırakıldığını denetleyin. Bunu yapmak için aşağıdaki komutu düzenli aralıklarla çalıştırın:

     (Get-MSOLCompanyInformation).DirectorySynchronizationEnabled
    

    Bu komut Doğru veya Yanlış döndürür. Bu komutu False döndürene kadar düzenli aralıklarla çalıştırmaya devam edin ve sonraki adıma geçin.

    Devre dışı bırakma işleminin tamamlanması 72 saat sürebilir. Süre, bulut hizmeti abonelik hesabınızdaki nesnelerin sayısına bağlıdır.

  5. Windows PowerShell kullanarak veya bulut hizmeti portalını kullanarak bir nesneyi güncelleştirmeyi deneyin.

    4. adımın tamamlanması biraz zaman alabilir. Bulut hizmeti ortamında öznitelik değerlerini hesaplayan bir işlem vardır. Nesnelerin Windows PowerShell veya bulut hizmeti portalı kullanılarak değiştirilebilmesi için önce işlemin tamamlanması gerekir.

Bir nesneyi şirket içi AD DS'den silersiniz. Ancak, nesne bulut hizmeti abonelik hesabınızdan silinmez

Bu makaledeki adımları kullanarak dizin eşitlemesini zorla: Zamanlayıcıyı başlatma

  • Bazı güncelleştirmeler ve silmeler yayılıyorsa ancak bazı silme işlemleri bulut hizmetiyle eşitlenmemişse, tipik dizin eşitleme sorunlarını giderme yordamlarını izleyin.

  • Tüm güncelleştirmeler ve silmeler bulut hizmetiyle eşitlenmemişse Destek'e başvurun.

    Not

    Bu senaryo için alternatif bir çözüm olarak, bir nesne bulut hizmetinde el ile silinebilir. Ancak, nesne bulut hizmetinde güncelleştirilemez. Bu sorunun nasıl çözüleceğini öğrenmek için aşağıdaki Microsoft Bilgi Bankası makalesine bakın: Azure Active Directory Eşitleme aracı kullanılırken nesne silme işlemleri Microsoft Entra ID eşitlenmez.  

Daha fazla bilgi

Dizin eşitlemesini yeniden etkinleştirmek için aşağıdaki komutu çalıştırın:

Set-MsolDirSyncEnabled -EnableDirSync $true

Dizin eşitlemesini yeniden etkinleştirdiğinizde dikkatli bir şekilde planlama yapmak önemlidir. Başlangıçta şirket içi AD DS'den eşitlenen nesnelerde doğrudan değişiklik yapmak için bulut hizmeti portalını veya Windows PowerShell kullandıysanız, dizin eşitlemesi yeniden etkinleştirildikten sonra eşitleme ilk kez gerçekleştiğinde değişikliklerin üzerine şirket içi öznitelikler ve ayarlar yazılır.

Yardım için bize ulaşın

Sorularınız veya yardıma ihtiyacınız varsa bir destek isteği oluşturun veya Azure topluluk desteği isteyin. Ürün geri bildirimini Azure geri bildirim topluluğuna da gönderebilirsiniz.