Cómo solucionar problemas de cuentas de usuario eliminadas en Office 365

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PROBLEMA

Una cuenta de usuario de Office 365 se eliminó accidentalmente de Office 365 y tiene que restaurarse.

CAUSA

Pueden eliminarse las cuentas de usuario 365 de Office en cualquiera de las siguientes maneras:
  • Pueden eliminar manualmente las cuentas de usuario mediante el portal de Office 365.
  • Las cuentas de usuario pueden eliminarse manualmente o eliminar a través de una secuencia de comandos mediante Microsoft Azure Active Directory módulo para Windows PowerShell.
  • Pueden eliminar manualmente las cuentas de usuario mediante el centro de administración de Exchange en Exchange Online.
  • Pueden eliminarse las cuentas de usuario a través de una eliminación sincronizada si los cambios de filtrado de sincronización de directorio excluirán el objeto de usuario de Active Directory local del conjunto de sincronización de. (Los cambios de filtrado de sincronización de directorio también se conocen como ámbito).
  • Pueden eliminarse las cuentas de usuario a través de una eliminación sincronizada si se ha eliminado el objeto de usuario local del esquema de Active Directory local.

SOLUCIÓN

Antes de empezar a

Cuando se elimina un objeto de usuario, no inmediatamente y completamente eliminarlo de sistema de autenticación de Active Directory (AD Azure) de Azure. El objeto de usuario se coloca en estado eliminado y ya no aparece en la lista de usuario normal. Sin embargo, está presente en la base de datos de Azure AD y pueden recuperarse de una organización dentro de 30 días. Para determinar si un objeto de usuario es elegible para recuperarse de un estado eliminado, siga estos pasos:
  1. En el portal de Office 365, buscar las cuentas de usuario que se eliminaron a través del portal. Para ello, siga estos pasos:
    1. Iniciar sesión en el portal Office 365)https://portal.Office.com) con credenciales administrativas.
    2. Haga clic enadministración, haga clic enOffice 365y, a continuación, en el panel de navegación de la izquierda, haga clic enusuarios y grupos.
    3. Haga clic en usuarios eliminadosy, a continuación, busque el usuario que desea recuperar.
  2. Con Azure Active Directory módulo para Windows PowerShell, siga estos pasos:
    1. Haga clic en Inicio, seleccione Todos los programas, haga clic en Active Directory de Windows Azurey, a continuación, haga clic en Windows Azure Active Directory módulo para Windows PowerShell.
    2. Escriba los comandos siguientes en el orden en que aparecen. Asegúrese de presionar ENTRAR después de escribir cada comando.
      • $cred = get-credential
        Nota Cuando se le solicite, escriba sus credenciales de Office 365.
      • Connect-MSOLService -credential:$cred
      • Get-MsolUser ?ReturnDeletedUsers

Solución 1: Utilizar el portal de Office 365 o Azure Active Directory módulo para Windows PowerShell para recuperar una cuenta de usuario eliminada

Para recuperar una cuenta de usuario que se ha eliminado manualmente, utilice uno de los métodos siguientes:
  • Utilizar el portal de Office 365 para recuperar la cuenta de usuario. Para obtener más información acerca de cómo hacerlo, veaEliminar o restaurar los usuarios.
  • Utilizar Azure Active Directory módulo para Windows PowerShell para recuperar la cuenta de usuario. Para ello, escribauno de los siguientes comandos y presione ENTRAR:
    • Restore-MsolUser -ObjectId <Guid> -AutoReconcileProxyConflicts -NewUserPrincipalName <string>
    • Restore-MsolUser -UserPrincipalName <string> -AutoReconcileProxyConflicts -NewUserPrincipalName <string>


      En estos comandos, se utilizan las siguientes convenciones:
      • Los parámetros UserPrincipalName y ObjectID identifican de forma exclusiva el objeto de usuario para restaurar.
      • UtoReconcileProxyConflictsde unparámetro es opcional y se utiliza en escenarios en los que otro objeto de usuario se concede dirección de proxy del objeto de usuario de destino después de esa dirección se ha eliminado.
      • Opcionalmente, el parámetro NewUserPrincipalNamese utiliza en escenarios en los que otro objeto de usuario concedida nombre principal de usuario (UPN) del objeto de usuario de destino después de dicho UPN se ha eliminado.

Solución 2: Recuperar una cuenta de usuario que se ha eliminado porque la sincronización de directorios (ámbito) de los cambios de filtrado excluir el objeto de usuario de Active Directory local

Para recuperar las cuentas de usuario eliminada, asegúrese de que el filtrado de sincronización de directorios se establece de forma que el ámbito incluye los objetos que desea recuperar. Para obtener más información, visite el siguiente sitio Web de Microsoft:
Configurar el filtrado de sincronización de directorios

Solución 3: Recuperar una cuenta de usuario que se ha eliminado porque se eliminó el objeto de usuario local del esquema de Active Directory local

Para recuperar un elemento eliminado del esquema de Active Directory local, siga estos pasos:
  1. Intente restaurar el elemento eliminado de la Papelera de reciclaje de Active Directory. Para obtener más información acerca de cómo hacerlo, visite el siguiente sitio Web de Microsoft:
    Guía paso a paso de Papelera de reciclaje de Active Directory
    Notas
    • La Papelera de reciclaje de Active Directory sólo está disponible con el nivel funcional de Windows 2008 R2 o versiones posteriores.
    • De la Papelera de reciclaje de Active Directory ser útil en la recuperación de un elemento, debe estar habilitado antes de eliminar el elemento.
  2. Si Active Directory reciclaje bin no está disponible, o si el objeto en cuestión ya no está en la Papelera de reciclaje, intente recuperar los elementos eliminados mediante la herramienta AdRestore. Para ello, siga estos pasos:
    1. Instalar la herramienta AdRestore desde el siguiente sitio Web de Microsoft TechNet:
      http://technet.Microsoft.com/en-us/Sysinternals/bb963906.aspx
    2. Utilice AdRestore junto con un filtro de búsqueda para encontrar el objeto de usuario eliminado local.

      El siguiente es un ejemplo de cómo utilizar AdRestore para enumerar todos los objetos de usuario que tienen una cadena de "Usuario" en su nombre:
      C:\>adrestore.exe UserA
      AdRestore v1.1 by Mark Russinovich
      Sysinternals - www.sysinternals.com
      
      Enumerating domain deleted objects:
      cn: MailboxA
      DEL:3c45a0ae-ebc5-490d-a4b4-4b20d3e34a3f
      distinguishedName: CN=UserA\0ADEL:3c45a0ae-ebc5-490d-a4b4-4b20d3e34a3f,CN=Deleted Objects,DC=Domain,DC=com
      lastKnownParent: OU=OnPremises,DC=Domain,DC=com
      
      Found 1 item matching search criteria.
    3. Uso AdRestore junto con el r - cambiar para restaurar el objeto de usuario.

      El siguiente es un ejemplo de cómo utilizar AdRestore para restaurar el objeto de usuario:
      C:\>adrestore.exe Usera ?r
      AdRestore v1.1 by Mark Russinovich
      Sysinternals - www.sysinternals.com
      
      Enumerating domain deleted objects:
      cn: UserA
      DEL:3c45a0ae-ebc5-490d-a4b4-4b20d3e34a3f
      distinguishedName: CN=MailboxA\0ADEL:3c45a0ae-ebc5-490d-a4b4-4b20d3e34a3f,CN=Deleted Objects,DC=Domain,DC=com
      lastKnownParent: OU=OnPremises,DC=Domain,DC=com
      
      Do you want to restore this object (y/n)? y
      Restore succeeded.
      
      Found 1 item matching search criteria.
    4. Habilitar el objeto de usuario en Active Directory. Cuando se restaura el objeto, lo está al principio. Por lo tanto, debe habilitarlo. Si es necesario, en primer lugar restablecer contraseña del objeto de usuario y, a continuación, habilitar el objeto de usuario en usuarios y equipos de Active Directory Users.

      Para habilitar el objeto de usuario en usuarios y equipos de usuarios de Active Directory, siga estos pasos:
      1. En usuarios y equipos, haga clic en el usuario y, a continuación, haga clic en Restablecer contraseña.
      2. Escriba una nueva contraseña en el nueva contraseña y Confirmar contraseña cuadros y, a continuación, haga clic en Aceptar.
      3. Haga clic en el usuario, haga clic en Habilitar cuentay, a continuación, haga clic en Aceptar.

        Contraer esta imagenAmpliar esta imagen
        Captura de pantalla de habilitar cuenta en Active Directory

        Recibirá el siguiente mensaje de error. (Se espera que este mensaje de error.)
        Windows no puede habilitar <MailboxName>porque:
        No se puede actualizar la contraseña. El valor proporcionado para la nueva contraseña no cumple la longitud, complejidad o requisitos de historial del dominio.</MailboxName>
        Después de recibir este mensaje de error, restablecer la contraseña del usuario en usuarios y equipos de usuarios de Active Directory.
    5. Configurar el nombre de inicio de sesión de usuario. No se configuró el nombre de inicio de sesión de usuario (también conocido como el nombre principal de usuario, o UPN) del objeto de usuario restaurado. Debe actualizar el nombre de inicio de sesión de usuario, especialmente si el usuario es una cuenta federada.

      Para configurar el nombre de inicio de sesión de usuario, siga estos pasos:
      1. En usuarios y equipos, haga clic en el usuario y, a continuación, haga clic en Propiedades.
      2. Haga clic en cuenta, escriba un nombre en el cuadro nombre de inicio de sesión de usuario y, a continuación, haga clic en Aceptar.
Por último, si no puede recuperar la cuenta de usuario eliminada a través de la Papelera de reciclaje de Active Directory o mediante la herramienta AdRestore, realizar una restauración autoritativa de los objetos de usuario eliminada en Active Directory.

Advertencia Asegúrese de que sólo los objetos de usuario que desea restaurar están marcados como autoritativo. Los objetos de Active Directory que están marcados como autorizados en el proceso de restauración pueden causar muchos problemas de servicio de Active Directory.

Para obtener más información acerca de cómo realizar una restauración autoritativa de objetos de Active Directory, visite el sitio Web de Microsoft siguiente:
Realizar una restauración autoritativa de objetos de Active Directory

AdvertenciaLos objetos que se restauran con resolución 3 que no tenga los atributos del servicio (Exchange Online, Lync Online, y así sucesivamente) vuelve a llenar automáticamente después de la acción de restauración. Utilizar las herramientas de administración de servicio apropiado para volver a llenar los atributos de objeto local antes de que el siguiente intervalo de sincronización de directorios propaga a la acción de restaurar el directorio de la nube.

Por ejemplo, para un objeto que antes era habilitados para correo en Exchange Online, es aconsejable usar los cmdlets de Windows PowerShell para volver a llenar los atributos de Exchange en línea. En el ejemplo siguiente, el objeto de Usuario1 se vuelve a llenar con los atributos de Exchange Online para el arrendatario de contoso.onmicrosoft.com:
Enable-RemoteMailbox -Identity User1 -RemoteRoutingAddress user1@contoso.mail.onmicrosoft.com
Si las siguientes condiciones se cumplen, no funcionará la solución 3:
  • Restaurar el objeto mediante el uso de la Papelera de reciclaje de Active Directory no es una opción disponible.
  • Restaurar el objeto con la herramienta AdRestore no es una opción disponible.
  • Active Directory restaurar autorizado, no es una opción disponible.
En esta situación, póngase en contacto con el soporte técnico de Office 365 para obtener ayuda.

MÁS INFORMACIÓN

Los cambios que se realizan en un dominio o a un objeto de usuario de Office 365 después de que se elimina una cuenta de usuario y antes de que el usuario se recuperó la cuenta pueden afectar el usuario experimentan después de la recuperación. Después de la eliminación del usuario y antes de recuperación por el usuario, pueden ocurrir los siguientes eventos:
  • Se crea un nuevo usuario que utiliza un valor de ID de usuario único que se ha asignado anteriormente al usuario eliminado.
  • Se crea un nuevo usuario que utiliza un valor de dirección de correo electrónico exclusivo asignado al usuario eliminado anteriormente.
Cuando se producen estos conflictos, atributos en conflicto deben actualizarse para eliminar el conflicto para poder completar la recuperación por el usuario. Si se produce un conflicto durante la recuperación del usuario, el usuario experimentará alguno de los síntomas siguientes cuando se intenta la recuperación de un usuario:
  • Windows PowerShell devuelve uno de los siguientes mensajes de error:

    Mensaje de error 1
    MsolUser de restauración: No se puede restaurar la cuenta de usuario especificada debido al siguiente error: Error de tipo UserPrincipalName
    Mensaje de error 2
    MsolUser de restauración: No se puede restaurar la cuenta de usuario especificada debido al siguiente error: Error de tipo proxyAddress
    Para restaurar los usuarios que están en este estado, puede corregir el conflicto con los parámetros siguientes al ejecutar el MSOLUser de restauración cmdlet:
    • AutoReconcileProxyConflicts
    • NewUserPrincipalName
    Nota Cuando se utiliza el AutoReconcileProxyConflicts parámetro, en cualquier conflicto de direcciones de correo electrónico se quitan del usuario eliminado antes de continuar con el proceso de recuperación.
  • El portal de Office 365 muestra los mensajes de error equivalente en forma de los Estados de error de Windows PowerShell que se han mencionado anteriormente. Por ejemplo, verá lo siguiente:

    Contraer esta imagenAmpliar esta imagen
    Captura de pantalla de la página de conflictos de nombre de usuario


    Para restaurar los usuarios que están en este estado, complete el formulario y asegúrese de que especifica cómo desea corregir el conflicto.

¿Sigue necesitando ayuda? Vaya a la Comunidad de Office 365 .

Propiedades

Id. de artículo: 2619308 - Última revisión: martes, 15 de julio de 2014 - Versión: 19.0
La información de este artículo se refiere a:
  • Microsoft Office 365
  • Office 365 User and Domain Management
Palabras clave: 
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Traducción automática
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Haga clic aquí para ver el artículo original (en inglés): 2619308

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