Risoluzione dei problemi relativi agli account utente eliminati in Office 365

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PROBLEMA

Un account utente di Office 365 viene eliminato accidentalmente da Office 365 e deve essere ripristinato.

CAUSA

Account utente 365 Office possono essere eliminati in uno dei seguenti modi:
  • ╚ possibile eliminare manualmente gli account utente tramite il portale di Office 365.
  • Gli account utente possono essere eliminati manualmente o eliminati tramite uno script utilizzando Microsoft Azure Active Directory Module per Windows PowerShell.
  • ╚ possibile eliminare manualmente gli account utente utilizzando il centro di amministrazione di Exchange in Exchange Online.
  • Se le modifiche filtro di sincronizzazione directory escludere l'oggetto utente di Active Directory locale dal set di sincronizzazione, gli account utente possono essere eliminati tramite un'eliminazione sincronizzata. (Modifiche filtro di sincronizzazione directory sono noti anche come ambito).
  • Se l'oggetto di utente locale Ŕ stato eliminato dallo schema di Active Directory locale, gli account utente possono essere eliminati tramite un'eliminazione sincronizzata.

SOLUZIONE

Prima di iniziare

Quando viene eliminato un oggetto utente, viene completamente e non immediatamente rimosso dal sistema di autenticazione Azure Active Directory (AD Azure). L'oggetto utente viene inserito in uno stato eliminato e non viene pi¨ visualizzato nell'elenco utente ordinario. Tuttavia, Ŕ presente nel database di Active Directory Azure e possono essere recuperata per un'organizzazione entro 30 giorni. Per determinare se un oggetto utente Ŕ idoneo a essere ripristinato da uno stato eliminato, attenersi alla seguente procedura:
  1. Nel portale Office 365, cercare gli account utente che sono stati eliminati tramite il portale. A tale scopo, attenersi alla seguente procedura:
    1. Accedi al (portale Office 365https://Portal.Office.com) utilizzando le credenziali amministrative.
    2. Fare clic suamministrazione, fare clic suOffice 365e quindi nel riquadro di spostamento a sinistra, fare clic suutenti e gruppi.
    3. Fare clic su utenti eliminatie quindi verificare che l'utente che si desidera ripristinare.
  2. Utilizzo di Azure Active Directory Module per Windows PowerShell, attenersi alla seguente procedura:
    1. Fare clic su Start, scegliere Tutti i programmi, fare clic su Active Directory di Windows Azuree quindi fare clic su Windows Azure Active Directory Module per Windows PowerShell.
    2. Digitare i seguenti comandi nell'ordine in cui sono presentate. Assicurarsi di premere INVIO dopo ciascun comando.
      • $cred = get-credential
        Nota. Quando viene richiesto, immettere le credenziali di Office 365.
      • Connect-MSOLService -credential:$cred
      • Get-MsolUser ?ReturnDeletedUsers

Risoluzione 1: Utilizzare il portale Office 365 o Azure Active Directory Module per Windows PowerShell per ripristinare un account utente eliminato

Per ripristinare un account utente che Ŕ stato eliminato manualmente, utilizzare uno dei seguenti metodi:
  • Per ripristinare l'account utente, utilizzare il portale Office 365. Per ulteriori informazioni, vedereEliminare o ripristinare gli utenti.
  • Per ripristinare l'account utente, utilizzare la Azure Active Directory Module per Windows PowerShell. A tale scopo, digitareuno dei seguenti comandi e quindi premere INVIO:
    • Restore-MsolUser -ObjectId <Guid> -AutoReconcileProxyConflicts -NewUserPrincipalName <string>
    • Restore-MsolUser -UserPrincipalName <string> -AutoReconcileProxyConflicts -NewUserPrincipalName <string>


      In questi comandi vengono utilizzate le convenzioni seguenti:
      • I parametri UserPrincipalName e ObjectID identificano in modo univoco l'oggetto utente da ripristinare.
      • Il parametro diutoReconcileProxyConflictsAŔ facoltativo e viene utilizzato in scenari in cui viene concesso un altro oggetto utente indirizzo proxy dell'oggetto utente di destinazione, dopo tale indirizzo Ŕ stato eliminato.
      • Il parametro NewUserPrincipalNameviene utilizzato eventualmente in scenari in cui viene concesso un altro oggetto utente nome dell'entitÓ dell'oggetto utente di destinazione utente (UPN), dopo tale UPN Ŕ stato eliminato.

Soluzione 2: Ripristinare un account utente che Ŕ stato eliminato perchÚ il filtro delle modifiche (ambite) la sincronizzazione delle directory escludere l'oggetto utente di Active Directory locale

Per ripristinare gli account utente eliminato, assicurarsi che il filtro di sincronizzazione directory Ŕ impostato in modo che l'ambito include gli oggetti che si desidera ripristinare. Per ulteriori informazioni, vedere il seguente sito Web Microsoft:
Configurare il filtro per la sincronizzazione delle directory

Risoluzione 3: Ripristinare un account utente che Ŕ stato eliminato perchÚ Ŕ stato eliminato l'oggetto di utente locale dallo schema di Active Directory locale

Per recuperare un elemento eliminato dallo schema di Active Directory locale, attenersi alla seguente procedura:
  1. Provare a ripristinare l'elemento eliminato dal Cestino di Active Directory. Per ulteriori informazioni su come eseguire questa operazione, visitare il seguente sito Web Microsoft:
    Guida dettagliata alla collocazione di riciclare Active Directory
    Note
    • Il Cestino di Active Directory Ŕ disponibile solo con il livello di funzionalitÓ di Windows 2008 R2 o versioni successive.
    • Per il Cestino di Active Directory essere utile nel recupero di un elemento, deve essere attivato prima che l'elemento viene eliminato.
  2. Se il Cestino di Active Directory bin non Ŕ disponibile o se l'oggetto in questione non Ŕ pi¨ nel Cestino, provare a recuperare l'elemento eliminato con lo strumento AdRestore. A tale scopo, attenersi alla seguente procedura:
    1. Installare lo strumento di AdRestore dal sito Web Microsoft TechNet seguente:
      http://technet.microsoft.com/en-us/Sysinternals/bb963906.aspx
    2. Utilizzare AdRestore con un filtro di ricerca per individuare l'oggetto di utente locale eliminato.

      Di seguito Ŕ riportato un esempio di utilizzo di AdRestore per enumerare tutti gli oggetti utente che dispone di una stringa "Utente" nel nome:
      C:\>adrestore.exe UserA
      AdRestore v1.1 by Mark Russinovich
      Sysinternals - www.sysinternals.com
      
      Enumerating domain deleted objects:
      cn: MailboxA
      DEL:3c45a0ae-ebc5-490d-a4b4-4b20d3e34a3f
      distinguishedName: CN=UserA\0ADEL:3c45a0ae-ebc5-490d-a4b4-4b20d3e34a3f,CN=Deleted Objects,DC=Domain,DC=com
      lastKnownParent: OU=OnPremises,DC=Domain,DC=com
      
      Found 1 item matching search criteria.
    3. Utilizzo AdRestore con r - passare per ripristinare l'oggetto utente.

      Di seguito Ŕ riportato un esempio di utilizzo di AdRestore per ripristinare l'oggetto utente:
      C:\>adrestore.exe Usera ?r
      AdRestore v1.1 by Mark Russinovich
      Sysinternals - www.sysinternals.com
      
      Enumerating domain deleted objects:
      cn: UserA
      DEL:3c45a0ae-ebc5-490d-a4b4-4b20d3e34a3f
      distinguishedName: CN=MailboxA\0ADEL:3c45a0ae-ebc5-490d-a4b4-4b20d3e34a3f,CN=Deleted Objects,DC=Domain,DC=com
      lastKnownParent: OU=OnPremises,DC=Domain,DC=com
      
      Do you want to restore this object (y/n)? y
      Restore succeeded.
      
      Found 1 item matching search criteria.
    4. Attivare l'oggetto utente in Active Directory. Quando l'oggetto Ŕ stato ripristinato, viene disattivato all'inizio. Pertanto, Ŕ necessario attivarlo. Se necessario, prima di reimpostare password utente dell'oggetto e quindi attivare l'oggetto utente in Active Directory Users and Computers.

      Per attivare l'oggetto utente in Active Directory Users and Computers, attenersi alla seguente procedura:
      1. Pulsante destro del mouse dell'utente in Active Directory Users e computer e quindi Reimposta Password.
      2. Immettere una nuova password nella nuova password e Conferma password caselle, quindi fare clic su OK.
      3. Pulsante destro del mouse dell'utente, fare clic su Abilita Accounte fare clic su OK.

        Riduci l'immagineEspandi l'immagine
        Schermata dell'attivazione di account in Active Directory

        Viene visualizzato il seguente messaggio di errore. (╚ previsto che questo messaggio di errore).
        Impossibile abilitare l'oggetto <MailboxName>perchÚ:
        Impossibile aggiornare la password. Il valore fornito per la nuova password non soddisfa i requisiti della cronologia del dominio, lunghezza e complessitÓ.</MailboxName>
        Dopo aver ricevuto questo messaggio di errore, Ŕ necessario reimpostare la password dell'utente in Active Directory Users and Computers.
    5. Configurare il nome di accesso utente. Il nome di accesso utente (noto anche come il nome dell'entitÓ utente, o UPN) non Ŕ impostato dall'oggetto utente ripristinato. ╚ necessario aggiornare il nome di accesso dell'utente, soprattutto se l'utente Ŕ un account federato.

      Per configurare il nome di accesso utente, attenersi alla seguente procedura:
      1. In Active Directory Users e computer, pulsante destro del mouse dell'utente e quindi fare clic su proprietÓ.
      2. Fare clic su Account, immettere un nome nella casella nome accesso utente e quindi fare clic su OK.
Infine, se non Ŕ possibile ripristinare l'account utente eliminato tramite il Cestino di Active Directory oppure utilizzando lo strumento AdRestore, Ŕ possibile eseguire un ripristino autorevole degli oggetti utente eliminato in Active Directory.

Avviso. Assicurarsi che solo gli oggetti utente che si desidera ripristinare sono contrassegnati come autorevoli. Oggetti di Active Directory che sono contrassegnati come autorevoli del processo di ripristino possono causare molti problemi relativi al servizio Active Directory.

Per ulteriori informazioni su come eseguire un ripristino autorevole degli oggetti di Active Directory, visitare il seguente sito Web Microsoft:
Un ripristino autorevole degli oggetti Active Directory

AvvisoGli oggetti ripristinati utilizzando Risoluzione 3 potrebbero non disporre di tutti gli attributi del servizio (Exchange Online, Lync Online, e cosý via) inseriti automaticamente dopo l'operazione di ripristino. Utilizzare gli strumenti di gestione del servizio appropriato per ripopolare gli attributi dell'oggetto locale prima che il successivo intervallo di sincronizzazione directory propaga l'azione Ripristina la directory di cloud.

Ad esempio, per un oggetto che Ŕ stato precedentemente abilitati alla posta elettronica di Exchange Online, Ŕ possibile utilizzare i cmdlet di Windows PowerShell per ripopolare gli attributi di Exchange Online. Nell'esempio seguente, l'oggetto User1 viene ricompilato con gli attributi di Exchange Online per affittuario contoso.onmicrosoft.com:
Enable-RemoteMailbox -Identity User1 -RemoteRoutingAddress user1@contoso.mail.onmicrosoft.com
Se le seguenti condizioni sono vere, non funzionerÓ risoluzione 3:
  • Il ripristino dell'oggetto utilizzando il Cestino di Active Directory non Ŕ un'opzione disponibile.
  • Il ripristino dell'oggetto con lo strumento AdRestore non Ŕ un'opzione disponibile.
  • Ripristino autorevole di Active Directory non Ŕ un'opzione disponibile.
In questo caso, contattare il supporto di Office 365 Guida.

ULTERIORI INFORMAZIONI

Le modifiche apportate a un dominio o in un oggetto utente di Office 365 dopo che un account utente viene eliminato e prima che l'utente viene recuperato l'account possono influenzare l'utente si verificano dopo il ripristino. Dopo l'eliminazione dell'utente e prima di ripristino dell'utente, possono verificarsi i seguenti eventi:
  • Viene creato un nuovo utente che utilizza un valore di ID utente univoco in precedenza Ŕ stato assegnato all'utente eliminato.
  • Viene creato un nuovo utente che utilizza un valore di indirizzo di posta elettronica univoco che Ŕ stato precedentemente assegnato all'utente eliminato.
Quando si verificano tali conflitti, gli attributi in conflitto devono essere aggiornati per rimuovere il conflitto prima di poter completare il ripristino dell'utente. Se si verifica un conflitto durante il ripristino dell'utente, si verifica uno dei seguenti sintomi durante il tentativo di ripristino di un utente:
  • Windows PowerShell restituisce uno dei seguenti messaggi di errore:

    Messaggio di errore 1
    Ripristino-MsolUser: L'account utente specificato non pu˛ essere ripristinato a causa del seguente errore: errore tipo UserPrincipalName
    Messaggio di errore 2
    Ripristino-MsolUser: L'account utente specificato non pu˛ essere ripristinato a causa del seguente errore: tipo di errore proxyAddress
    Per ripristinare gli utenti che sono in questo stato, Ŕ possibile correggere il conflitto utilizzando i seguenti parametri quando si esegue il Ripristino-MSOLUser cmdlet:
    • AutoReconcileProxyConflicts
    • NewUserPrincipalName
    Nota. Quando si utilizza il AutoReconcileProxyConflicts parametro ogni incoerenza tra gli indirizzi di posta elettronica vengono rimossi dall'utente eliminato prima di continuare con il processo di ripristino.
  • Il portale Office 365 Mostra i messaggi di errore equivalente in forma di stati di errore di Windows PowerShell citate in precedenza. Ad esempio, verrÓ visualizzato quanto segue:

    Riduci l'immagineEspandi l'immagine
    Schermata della pagina conflitto di nome utente


    Per ripristinare gli utenti che sono in questo stato, completare il modulo e specificare come si desidera risolvere il conflitto.

Ulteriore assistenza? Vai al Community di Office 365 .

ProprietÓ

Identificativo articolo: 2619308 - Ultima modifica: martedý 15 luglio 2014 - Revisione: 18.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Office 365
  • Office 365 User and Domain Management
Chiavi:á
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