Risoluzione dei problemi relativi agli account utente eliminati in Office 365

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In questo articolo viene descritto Microsoft Office 365, anteprima di Microsoft Office 365 e precedente l'aggiornamento Microsoft Office 365. Informazioni su Office 365 anteprima in questo articolo, compresi i collegamenti, viene fornita e sono soggette a modifiche senza preavviso.

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PROBLEMA

Un account utente di Office 365 viene eliminato accidentalmente da Office 365 e deve essere ripristinato.

CAUSA

Office 365 può essere eliminati in uno dei seguenti modi:
  • È possibile eliminare manualmente gli account utente mediante il portale Office 365.
  • Gli account utente possono essere eliminati manualmente o eliminati tramite uno script utilizzando Windows Azure Active Directory Module per Windows PowerShell.
  • È possibile eliminare manualmente gli account utente tramite Pannello di controllo di Exchange in Exchange Online.
  • Gli account utente possono essere eliminati tramite un'eliminazione sincronizzata se modifiche filtro di sincronizzazione directory escludere l'oggetto utente di Active Directory locale dal set di sincronizzazione. (Modifiche filtro di sincronizzazione directory sono noti anche come ambito).
  • Gli account utente possono essere eliminati tramite un'eliminazione sincronizzata se l'oggetto di utente locale è stato eliminato dallo schema di Active Directory locale.

SOLUZIONE

Prima di iniziare

Quando viene eliminato un oggetto utente, viene completamente e non immediatamente rimosso dal sistema di autenticazione di Windows Azure Active Directory (Active Directory di Windows Azure). L'oggetto utente viene inserito in uno stato eliminato e non viene più visualizzato nell'elenco utente ordinario. Tuttavia, è presente nel database di Active Directory di Windows Azure e può essere recuperata per un'organizzazione entro 30 giorni. Per determinare se un oggetto utente è idoneo a essere ripristinato da uno stato eliminato, attenersi alla seguente procedura:
  1. Nel portale Office 365, cercare gli account utente che sono stati eliminati tramite il portale. A tale scopo, attenersi alla seguente procedura:
    1. Accedi al (portale Office 365https://Portal.microsoftonline.com) utilizzando le credenziali amministrative.
    2. Effettuare una delle seguenti operazioni:
      • In Office 365 e nell'anteprima di Office 365, fare clic su Admin, fare clic su Office 365, quindi nel riquadro di spostamento a sinistra Utenti e gruppi.
      • Nel precedente l'aggiornamento Office 365, fare clic su Admine quindi nel riquadro di spostamento a sinistra sottoGestione, fare clic su Utenti.
    3. Effettuare una delle seguenti operazioni:
      • In Office 365 e nell'anteprima di Office 365, fare clic suUtenti eliminati, quindi cercare l'utente che si desidera ripristinare.
      • Nel precedente l'aggiornamento Office 365, nella pagina utenti, fare clic suEliminato, quindi cercare l'utente che si desidera ripristinare.
  2. Utilizzo di Windows Azure Active Directory Module per Windows PowerShell, attenersi alla seguente procedura:
    1. Fare clic Inizio, fare clic su Tutti i programmi, fare clic su Active Directory di Windows Azuree quindi fare clic su Modulo di Active Directory di Windows Azure per Windows PowerShell.
    2. Digitare i seguenti comandi nell'ordine in cui vengono presentati. Assicurarsi di premere INVIO dopo ogni comando.
      • $cred = get-credential
        Nota. Quando viene richiesto, immettere le credenziali di Office 365.
      • Connect-MSOLService -credential:$cred
      • Get-MsolUser ?ReturnDeletedUsers

Risoluzione 1: Utilizzare il portale Office 365 oppure il Windows Azure Active Directory Module per Windows PowerShell per ripristinare un account utente eliminato

Per ripristinare un account utente è stato eliminato manualmente, utilizzare uno dei seguenti metodi:
  • Per ripristinare l'account utente, utilizzare il portale Office 365. Per ulteriori informazioni, visitare uno dei seguenti siti Web Microsoft:
    • In Office 365 e anteprima di Office 365:Eliminare o ripristinare gli utenti
    • Nel precedente l'aggiornamento Office 365:
  • Per ripristinare l'account utente, utilizzare il Windows Azure Active Directory Module per Windows PowerShell. A tale scopo, digitare uno dei seguenti comandi e quindi premere INVIO:
    • Restore-MsolUser -ObjectId <Guid> -AutoReconcileProxyConflicts -NewUserPrincipalName <string>
    • Restore-MsolUser -UserPrincipalName <string> -AutoReconcileProxyConflicts -NewUserPrincipalName <string>


      In questi comandi vengono utilizzate le seguenti convenzioni:
      • I parametri UserPrincipalName e ObjectID identificano in modo univoco l'oggetto utente da ripristinare.
      • Il parametro diutoReconcileProxyConflictsAè facoltativo e viene utilizzato in scenari in cui un altro oggetto utente viene concesso indirizzo proxy dell'oggetto utente di destinazione dopo l'eliminazione di tale indirizzo.
      • Il parametro NewUserPrincipalNameviene eventualmente utilizzato in scenari in cui viene concesso un altro oggetto utente nome principale utente dell'oggetto di destinazione utente (UPN), dopo l'eliminazione di tale UPN.

Soluzione 2: Ripristinare un account utente è stato eliminato perché la sincronizzazione delle directory filtro delle modifiche (ambite) escludere l'oggetto utente di Active Directory locale

Per ripristinare gli account utente eliminato, assicurarsi che il filtro di sincronizzazione directory è impostato in modo che l'ambito include gli oggetti che si desidera ripristinare. Per ulteriori informazioni, visitare il seguente sito Web Microsoft:
Configurare il filtro per la sincronizzazione delle Directory

Soluzione 3: Ripristinare un account utente è stato eliminato perché l'oggetto di utente locale è stato eliminato dallo schema di Active Directory locale

Per recuperare un elemento eliminato dallo schema di Active Directory locale, attenersi alla seguente procedura:
  1. Provare a ripristinare elementi eliminati dal Cestino di Active Directory. Per ulteriori informazioni, visitare il seguente sito Web Microsoft:
    Active Directory Recycle Bin Guida
    Note
    • Il Cestino di Active Directory è disponibile solo con il livello di funzionalità di Windows 2008 R2 o versioni successive.
    • Per il Cestino di Active Directory essere utile nel recupero di un elemento, deve essere attivato prima dell'eliminazione dell'elemento.
  2. Se il Cestino di Active Directory bin non è disponibile o se l'oggetto in questione non è più nel Cestino, provare a recuperare elementi eliminati utilizzando lo strumento AdRestore. A tale scopo, attenersi alla seguente procedura:
    1. Installare lo strumento di AdRestore dal sito Web Microsoft TechNet seguente:
      http://technet.microsoft.com/en-us/sysinternals/bb963906.aspx
    2. Utilizzo di AdRestore con un filtro di ricerca per individuare l'oggetto di utente locale eliminato.

      Di seguito è riportato un esempio di utilizzo di AdRestore per enumerare tutti gli oggetti utente che dispongono di una stringa "Utente" nel nome:
      C:\>adrestore.exe UserA
      AdRestore v1.1 by Mark Russinovich
      Sysinternals - www.sysinternals.com
      
      Enumerating domain deleted objects:
      cn: MailboxA
      DEL:3c45a0ae-ebc5-490d-a4b4-4b20d3e34a3f
      distinguishedName: CN=UserA\0ADEL:3c45a0ae-ebc5-490d-a4b4-4b20d3e34a3f,CN=Deleted Objects,DC=Domain,DC=com
      lastKnownParent: OU=OnPremises,DC=Domain,DC=com
      
      Found 1 item matching search criteria.
    3. Utilizzo AdRestore con r - passare per ripristinare l'oggetto utente.

      Di seguito è riportato un esempio di utilizzo di AdRestore per ripristinare l'oggetto utente:
      C:\>adrestore.exe Usera ?r
      AdRestore v1.1 by Mark Russinovich
      Sysinternals - www.sysinternals.com
      
      Enumerating domain deleted objects:
      cn: UserA
      DEL:3c45a0ae-ebc5-490d-a4b4-4b20d3e34a3f
      distinguishedName: CN=MailboxA\0ADEL:3c45a0ae-ebc5-490d-a4b4-4b20d3e34a3f,CN=Deleted Objects,DC=Domain,DC=com
      lastKnownParent: OU=OnPremises,DC=Domain,DC=com
      
      Do you want to restore this object (y/n)? y
      Restore succeeded.
      
      Found 1 item matching search criteria.
    4. Attivare l'oggetto utente in Active Directory. Quando l'oggetto è stato ripristinato, viene disattivato all'inizio. Pertanto, è necessario attivarlo. Se è necessario, prima di reimpostare password dell'oggetto utente e quindi attivare l'oggetto utente in Active Directory Users and Computers.

      Per attivare l'oggetto utente in Active Directory Users and Computers, attenersi alla seguente procedura:
      1. In Active Directory Users and Computers, destro e quindi fare clic su Reimpostare la Password.
      2. Immettere una nuova password nel Nuova password e Conferma password caselle, quindi fare clic su OK.
      3. Pulsante destro del mouse dell'utente, fare clic su Attiva Account, quindi fare clic su OK.

        Riduci l'immagineEspandi l'immagine

        Viene visualizzato il seguente messaggio di errore. (È previsto che questo messaggio di errore).
        Impossibile abilitare l'oggetto <MailboxName>perché:
        Impossibile aggiornare la password. Il valore fornito per la nuova password non soddisfa i requisiti della cronologia del dominio, lunghezza e complessità.</MailboxName>
        Dopo aver ricevuto questo messaggio di errore, è necessario reimpostare la password dell'utente in Active Directory Users and Computers.
    5. Configurare il nome di accesso utente. Il nome di accesso utente (noto anche come il nome dell'entità utente, o UPN) non viene impostato dall'oggetto utente ripristinato. È necessario aggiornare il nome di accesso utente, soprattutto se l'utente è un account federato.

      Per configurare il nome di accesso utente, attenersi alla seguente procedura:
      1. In Active Directory Users and Computers, destro e quindi fare clic su Proprietà.
      2. Fare clic su Account, immettere un nome nella casella nome di accesso utente e quindi fare clic su OK.
Infine, se non è possibile ripristinare l'account utente eliminato tramite il Cestino di Active Directory oppure utilizzando lo strumento AdRestore, è possibile eseguire un ripristino autorevole degli oggetti utente eliminato in Active Directory.

Avviso. Assicurarsi che solo gli oggetti utente che si desidera ripristinare sono contrassegnati come autorevoli. Oggetti di Active Directory che sono contrassegnati come autorevoli del processo di ripristino possono causare molti problemi relativi al servizio Active Directory.

Per ulteriori informazioni su come eseguire un ripristino autorevole degli oggetti di Active Directory, visitare il seguente sito Web Microsoft:
Eseguire un ripristino autorevole degli oggetti Active Directory

AvvisoGli oggetti ripristinati utilizzando risoluzione 3 potrebbero non disporre di tutti gli attributi del servizio (Exchange Online, Lync Online, e così via) inseriti automaticamente dopo l'operazione di ripristino. Utilizzare gli strumenti di gestione del servizio appropriato per ripopolare gli attributi dell'oggetto locale prima che il successivo intervallo di sincronizzazione directory propaga l'azione Ripristina la directory di cloud.

Ad esempio, per un oggetto che è stato precedentemente abilitati alla posta elettronica di Exchange Online, è possibile utilizzare i cmdlet di Windows PowerShell per ripopolare gli attributi di Exchange Online. Nell'esempio seguente, l'oggetto User1 viene ricompilato con gli attributi di Exchange Online per affittuario contoso.onmicrosoft.com:
Enable-RemoteMailbox -Identity User1 -RemoteRoutingAddress user1@contoso.mail.onmicrosoft.com
Se le seguenti condizioni sono vere, non funzionerà risoluzione 3:
  • Il ripristino dell'oggetto utilizzando il Cestino di Active Directory non è un'opzione disponibile.
  • Il ripristino dell'oggetto con lo strumento AdRestore non è un'opzione disponibile.
  • Ripristino autorevole di Active Directory non è un'opzione disponibile.
In questo caso, contattare il supporto di Office 365 Guida.

ULTERIORI INFORMAZIONI

Le modifiche apportate a un dominio o a un oggetto utente di Office 365 dopo che un account utente viene eliminato e prima che l'utente viene recuperato l'account possono influenzare l'utente si verificano dopo il recupero. Dopo l'eliminazione dell'utente e prima di ripristino gestito dall'utente, possono verificarsi i seguenti eventi:
  • Viene creato un nuovo utente che utilizza un valore di ID utente univoco in precedenza è stato assegnato all'utente eliminato.
  • Viene creato un nuovo utente che utilizza un valore di indirizzo di posta elettronica univoco in precedenza è stato assegnato all'utente eliminato.
Quando si verificano tali conflitti, è necessario aggiornare gli attributi in conflitto per rimuovere il conflitto prima di poter completare il ripristino gestito dall'utente. Se si verifica un conflitto durante il ripristino gestito dall'utente, si verifica uno dei seguenti sintomi durante il tentativo di ripristino di un utente:
  • Windows PowerShell restituisce uno dei seguenti messaggi di errore:

    Messaggio di errore 1
    Ripristino-MsolUser: L'account utente specificato non può essere ripristinato a causa del seguente errore: errore tipo UserPrincipalName
    Messaggio di errore 2
    Ripristino-MsolUser: L'account utente specificato non può essere ripristinato a causa del seguente errore: tipo di errore proxyAddress
    Per ripristinare gli utenti che sono in questo stato, è possibile risolvere il conflitto utilizzando i seguenti parametri quando si esegue il Ripristino-MSOLUser cmdlet:
    • AutoReconcileProxyConflicts
    • NewUserPrincipalName
    Nota. Quando si utilizza il AutoReconcileProxyConflicts parametro ogni incoerenza tra gli indirizzi di posta elettronica vengono rimossi dall'utente eliminato prima di continuare con il processo di ripristino.
  • Il portale Office 365 Mostra i messaggi di errore equivalente in forma di Windows PowerShell gli stati di errore indicato in precedenza. Ad esempio, verrà visualizzato quanto segue:

    Riduci l'immagineEspandi l'immagine


    Per ripristinare gli utenti che sono in questo stato, completare il modulo e specificare come si desidera risolvere il conflitto.

Proprietà

Identificativo articolo: 2619308 - Ultima modifica: martedì 5 marzo 2013 - Revisione: 7.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Office 365 for education  (pre-upgrade)
  • Microsoft Office 365 for enterprises (pre-upgrade)
  • Microsoft Office 365 for small businesses  (pre-upgrade)
  • Microsoft Office 365 Enterprise preview
  • Microsoft Office 365 Small Business Premium preview
  • Microsoft Office 365
Chiavi: 
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