PRB: Trust Provider Warning Message Appears When You Attempt to Download Components

Article translations Article translations
Article ID: 261941 - View products that this article applies to.
This article was previously published under Q261941
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

SUMMARY

When your component attempts to download a signed .cab file, you may receive the following warning message:
Security Warning

Do you want to install and run "CAB File"?

The publisher cannot be determined due to the problems below:

The Trust Provider is unknown or not configured properly.
If you click No, the download operation quits. If you click Yes, the installation proceeds normally.

CAUSE

This behavior occurs because the Imagehlp.dll file is damaged or missing.

RESOLUTION

To resolve this problem, replace the Imagehlp.dll file that is extracted from Internet Explorer .cab files in your system folder.

For additional information about extracting original files, click the article number below to view the article in the Microsoft Knowledge Base:
129605 How to Extract Original Compressed Windows Files
NOTE: You must put the Imagehlp.dll file in the C:\Windows\System folder for Windows 95 or Windows 98, or in the C:\Winnt\System32 folder for Windows NT.

Alternatively, if you are using Microsoft Internet Explorer 5 or later, you can use the Repair Tool to obtain the right version of Imagehelp.dll. To repair, go to Control Panel, run Add/Remove Programs, click Uninstall for Internet Explorer, and select the Repair option.

MORE INFORMATION

This problem is not expected to happen on computers running Windows 2000 because of the File System Protection feature.


For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
264570 INFO: WebCast Available: How Does Internet Component Download Work?


Properties

Article ID: 261941 - Last Review: February 28, 2014 - Revision: 2.0
APPLIES TO
  • Microsoft Internet Explorer 4.0 128-Bit Edition, when used with:
    • Microsoft Windows NT 4.0
    • Microsoft Windows 95
    • Microsoft Windows 98 Standard Edition
  • Microsoft Internet Explorer 4.01 Service Pack 2, when used with:
    • Microsoft Windows NT 4.0
    • Microsoft Windows 95
    • Microsoft Windows 98 Standard Edition
  • Microsoft Internet Explorer 4.01 Service Pack 1, when used with:
    • Microsoft Windows NT 4.0
    • Microsoft Windows 95
    • Microsoft Windows 98 Standard Edition
  • Microsoft Internet Explorer 4.01 Service Pack 2, when used with:
    • Microsoft Windows NT 4.0
    • Microsoft Windows 95
    • Microsoft Windows 98 Standard Edition
  • Microsoft Internet Explorer 5.0, when used with:
    • Microsoft Windows NT 4.0
    • Microsoft Windows 95
    • Microsoft Windows 98 Standard Edition
  • Microsoft Internet Explorer 5.01, when used with:
    • Microsoft Windows NT 4.0
    • Microsoft Windows 95
    • Microsoft Windows 98 Standard Edition
Keywords: 
kbnosurvey kbarchive kbdownload kbprb kbcode KB261941

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com