Erreur « Impossible de créer le DVD. Chaîne de classe non valide. » lors de la création d?un DVD à l?aide du composant Création de DVD Windows

Traductions disponibles Traductions disponibles
Numéro d'article: 2619822 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout
Réduire cette imageAgrandir cette image
Ce document est un article Pas à Pas.
Ce document est un article pas à pas.

Résumé

Dans certains cas, l?installation de pilotes DirectShow peut endommager les clés du Registre et entraîner l?affichage du message d?erreur « Impossible de créer le DVD. Chaîne de classe non valide. » lors de la création d?un DVD à l?aide du composant Création de DVD Windows. Pour résoudre ce problème, procédez comme suit :

Cause

Pratiquement toutes les applications multimédias installent leurs propres pilotes DirectShow. Compte tenu de la diversité des packages de pilotes disponibles sur Internet, il n?est pas rare que ces pilotes endommagent les clés de Registre de composants tels que DirectShow.

Résolution

Important : cette section, méthode ou tâche indique comment modifier le Registre. Sachez toutefois qu?une modification incorrecte du Registre peut entraîner des problèmes graves. Il est donc conseillé de procéder avec précaution. Pour plus de précautions, effectuez une copie de sauvegarde du Registre avant de le modifier. Vous pourrez ainsi le restaurer s?il y a le moindre problème. Pour plus d?informations sur l?exécution d?une copie de sauvegarde et la restauration du Registre, consultez l?article Sauvegarder le Registre. Dans ce cas précis, il est conseillé d?effectuer une copie de sauvegarde du Registre pour l?ensemble du dossier HKEY_CLASSES_ROOT.

  1. Cliquez sur Démarrer
    Réduire cette imageAgrandir cette image
    2621155
    et entrez cmd dans la zone de recherche.

    Réduire cette imageAgrandir cette image
    2624717

  2. Cliquez avec le bouton droit de la souris sur cmd et sélectionnez Exécuter en tant qu?administrateur.

    Réduire cette imageAgrandir cette image
    2624718

  3. Dans la fenêtre Invite de commandes, entrez les commandes suivantes :

    reg DELETE ?HKEY_CLASSES_ROOT\CLSID\{083863F1-70DE-11D0-BD40-00A0C911CE86}\Instance\? /v ?{79D28B7F-A6BD-49EF-8CEA-EA0E7791589E}? /f

    reg DELETE ?HKEY_CLASSES_ROOT\CLSID\{083863F1-70DE-11D0-BD40-00A0C911CE86}\Instance\? /v ?{138130AF-A79B-45D5-B4AA-87697457BA87}? /f
    Réduire cette imageAgrandir cette image
    2624719


    Remarque :
    en cas d?utilisation de Nero, si ce programme cesse de fonctionner lorsque vous supprimez ces clés, vous pourrez restaurer le Registre sur un état antérieur.
  4. Si un message d?erreur s?affiche pour vous informer que les clés n?existent pas sur votre ordinateur, vous pouvez essayer la solution suivante.

Solution 2 : Restauration du système

  1. Cliquez sur Démarrer
    Réduire cette imageAgrandir cette image
    2621156
    , puis saisissez restauration du système dans la zone de recherche. Appuyez ensuite sur la touche Entrée.

    Réduire cette imageAgrandir cette image
    2624720

  2. Cliquez sur Suivant dans la fenêtre Restaurer les fichiers et paramètres système.

    Réduire cette imageAgrandir cette image
    2624721

  3. Sélectionnez un point de restauration antérieur à l?installation du package de pilotes à l?origine de l?erreur. Cliquez ensuite sur le bouton Suivant.

    Réduire cette imageAgrandir cette image
    2624722


    Remarque : si vous souhaitez sélectionner un point de restauration différent de celui qui est recommandé, cochez la case Afficher d?autres points de restauration.
  4. Dans la fenêtre Confirmer le point de restauration, cliquez sur Terminer.

    Réduire cette imageAgrandir cette image
    2626718

  5. Vous pouvez, à présent, télécharger un autre package de pilotes et réessayer de créer un DVD avec le composant Création de DVD Windows.

Plus d'informations

Votre avis nous intéresse : n?hésitez pas à nous dire ce que vous pensez de cet article au moyen du champ de commentaires situé au bas du document. Cela nous permettra d?en améliorer le contenu. D?avance merci !

Propriétés

Numéro d'article: 2619822 - Dernière mise à jour: vendredi 20 septembre 2013 - Version: 2.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Windows 7 Entreprise
  • Windows 7 Édition Familiale Basique
  • Windows 7 Édition Familiale Premium
  • Windows 7 Professionnel
  • Windows 7 Édition Starter
  • Windows 7 Édition Integrale
Mots-clés : 
kbstepbystep kbhowto kbtshoot kbprb KB2619822
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com