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Síntomas

Imagine la siguiente situación:

  • Instale el servicio de rol Host de sesión de Escritorio remoto en un equipo que ejecute Windows Server 2008 R2.

  • Habilitar virtualización IP de escritorio remoto en el equipo.

  • Intenta iniciar una aplicación del Protocolo ligero de acceso a directorios (LDAP) o un servicio relacionado con LDAP en el equipo.

En este escenario, no puede iniciar la aplicación o el servicio y recibe el siguiente mensaje de error:

No se encontró la ruta de red


A continuación se muestran algunas aplicaciones relacionadas con LDAP de ejemplo que se ven afectadas por el problema: Usuarios y equipos de Active Directory complemento MMC complemento de dominio de Active Directory y confía en el complemento MMC de sitios y servicios

de Active Directory
COMPLEMENTO MMC ADSI Edit

MMC snap-in
Group Policy Management MMC snap-in
DHCP MMC snap-inLdp.exe
Microsoft System Center Configuration Manager
2007 Administration Console
Manager (AzMan)

Causa

El problema se produce debido a un problema de compatibilidad entre LDAP y virtualización IP de escritorio remoto.

El comportamiento codificado del módulo LDAP es usar un socket interno enlazado a la dirección IP 127.0.0.1. Sin embargo, la Virtualización IP de escritorio remoto vuelve a unen el socket a una IP virtualizada para la sesión o el programa. Este comportamiento provoca un error de conexión en el componente LDAP.

Resolución

Información de revisiones

Después de instalar la siguiente revisión y configurar una subclave del Registro, el módulo LDAP enlazará y conectará un socket interno a cualquier dirección de bucle atrás proporcionada en el Registro por un usuario. La dirección proporcionada debe ser una dirección de bucle atrás (la dirección comienza con 127) y no debe ser 127.0.0.1. Microsoft tiene disponible una revisión compatible. Sin embargo, esta revisión está destinada a corregir solo el problema que se describe en este artículo. Aplique esta revisión solo a los sistemas que están experimentando el problema descrito en este artículo. Esta revisión puede recibir pruebas adicionales. Por lo tanto, si no se ve gravemente afectado por este problema, le recomendamos que espere a la próxima actualización de software que contiene esta revisión.

Si la revisión está disponible para su descarga, hay una sección "Descarga de revisiones disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio de atención al cliente y el soporte técnico de Microsoft para obtener la revisión.

Nota Si se producen problemas adicionales o si se requiere alguna solución de problemas, es posible que tenga que crear una solicitud de servicio independiente. Los costos de soporte técnico habituales se aplicarán a preguntas y problemas de soporte técnico adicionales que no reúnen los requisitos para esta revisión específica. Para obtener una lista completa de los números de teléfono de soporte y servicio de atención al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio web de Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota El formulario "Descarga de revisiones disponible" muestra los idiomas para los que la revisión está disponible. Si no ve el idioma, se debe a que una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar esta revisión, debe ejecutar Windows Server 2008 R2 o Windows Server 2008 R2 Service Pack 1 (SP1). Para obtener más información sobre cómo obtener un Service Pack de Windows Server 2008 R2, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

976932 Información sobre Service Pack 1 para Windows 7 y para Windows Server 2008 R2

Información de Registro

Después de aplicar esta revisión, debe crear una clave del Registro.

Para que nosotros creemos la clave del Registro, vaya a la sección"Corregirla para mí". Si prefiere crear la clave del Registro usted mismo, vaya a la sección"Permítanme corregirla yomismo".

Solucionarlo en mi lugar



Para solucionar este problema automáticamente, haga clic en el botón o vínculo Solucionarlo. A continuación, haga clic en Ejecutar en el cuadro de diálogo Descargar archivo y siga los pasos del Asistente para corregirlo.




Notas

  • Descargue e instale la revisión en el artículo anterior de Knowledge Base (KB) antes de ejecutar la solución Corregirla.

  • Debe reiniciar todas las aplicaciones que usan el módulo LDAP después de aplicar esta revisión.

  • Este asistente podría estar solo en inglés. Sin embargo, la solución automática también funciona con versiones de Windows en otros idiomas.

  • Si no está utilizando el equipo que tiene el problema, puede guardar la solución Fix it en una unidad flash o en un CD para posteriormente ejecutarlas en el equipo donde está el problema.


A continuación, vaya a la sección "¿Sesolucionó este problema?".



Solucionarlo por mí mismo

Para ello, siga estos pasos:

  1. Haga clic en botón inicio , escriba regedit en el cuadro Buscar programas y archivos y, después, presione ENTRAR.

    UAC Si se le solicita una contraseña de administrador, escriba la contraseña. Si se le solicita confirmación, proporcione la confirmación.

  2. Busque la siguiente subclave del Registro y haga clic en ella:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\ldap\

  3. En el menú Edición, seleccione Nuevo y haga clic en Valor de cadena.

  4. Escriba IPv4LoopbackAlternative y presione ENTRAR.

  5. Haga clic con el botón derecho en IPv4LoopbackAlternative y, a continuación, haga clic en Modificar.

  6. En el cuadro Datos de valor, escriba 127.0.0.2 y, a continuación, haga clic en Aceptar.

  7. Salga del Editor del Registro.


Nota Le recomendamos que use 127.0.0.2 en el campo Datos de valor, pero cualquier cosa del rango de 127.0.0.2 a 127.255.255.254 (ambos inclusive) es aceptable.

Requisito de reinicio

Debe reiniciar todas las aplicaciones que usan el módulo LDAP después de aplicar esta revisión.

Información de la sustitución de revisión

Esta revisión no reemplaza una revisión publicada anteriormente.

Información de archivo

La versión global de esta revisión instala archivos que tienen los atributos que se enumeran en las siguientes tablas. Las fechas y horas de estos archivos se muestran según la Hora universal coordinada (UTC). Las fechas y horas de estos archivos se muestran en el equipo local en horario local con la configuración actual del horario de verano (DST). Además, las fechas y horas pueden cambiar cuando realiza determinadas operaciones en los archivos.

Notas de información de archivos de Windows Server 2008 R2

Las revisiones importantes de Windows 7 y las revisiones de Windows Server 2008 R2 se incluyen en los mismos paquetes. Sin embargo, las revisiones de la página Solicitud de revisión figuran para ambos sistemas operativos. Para solicitar la revisión que se aplica a uno o a ambos sistemas operativos, seleccione la revisión que aparece enumerada bajo "Windows 7/Windows Server 2008 R2" en la página. Consulte siempre la sección "La información de este artículo se refiere a" en los artículos para determinar el sistema operativo al que se aplica cada revisión.

  • Los archivos que se aplican a un producto, un hito (RTM, SPn) y una rama de servicio (LDR, GDR) específicos se pueden identificar examinando los números de versión de archivo como se muestra en la tabla siguiente:

    Versión

    Producto

    Hito

    Tipo de servicio

    6.1.760
    0.21xxx

    Windows Server 2008 R2

    RTM

    LDR

    6.1.760
    1.21xxx

    Windows Server 2008 R2

    SP1

    LDR

  • Las ramas de servicio GDR contienen solo correcciones de amplia distribución para solucionar problemas críticos extendidos. Los tipos de servicio LDR contienen revisiones, además de las correcciones de amplia distribución.

  • Los archivos MANIFEST (.manifest) que están instalados para cada entorno se muestran por separado en la sección "Información de archivo adicional para Windows Server 2008 R2". Los archivos MANIFEST y los archivos del catálogo de seguridad asociados (.cat) son muy importantes para mantener el estado de los componentes actualizados. Los archivos de catálogo de seguridad, para los cuales no están enumerados los atributos, se firman con una firma digital de Microsoft.

Para todas las versiones compatibles basadas en x64 de Windows Server 2008 R2

Nombre de archivo

Versión del archivo

Tamaño del archivo

Fecha

Hora

Plataforma

Wldap32.dll

6.1.7600.21057

312,832

18-Sep-2011

1:45

Plataforma x64

Wldap32.dll

6.1.7601.21822

312,832

18-Sep-2011

03:05

Plataforma x64

Wldap32.dll

6.1.7600.21057

269,312

18-Sep-2011

1:07

x86

Wldap32.dll

6.1.7601.21822

270,336

18-Sep-2011

02:41


¿Esta información le ha ayudado a resolver el problema?

  • Compruebe si se ha solucionado el problema. Si se ha solucionado, ya ha terminado con esta sección. En caso contrario, puede ponerse en contacto con el soporte técnico.

  • Valoramos sus comentarios. Para enviar comentarios o informar de cualquier problema con esta solución, deje un comentario en el blog "Solucionarlo paramí"o envíenos un correo electrónico.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "Se aplica a".

Más información

Para obtener más información sobre cómo configurar la configuración de virtualización IP de escritorio remoto, visite el siguiente sitio web de Microsoft:

Cómo configurar virtualización IP de escritorio remotoPara obtener más información sobre la terminología de actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

824684 Descripción de la terminología estándar que se usa para describir las actualizaciones de software de Microsoft

Información adicional de archivos

Información de archivo adicional para Windows Server 2008 R2

Archivos adicionales para todas las versiones compatibles basadas en x64 de Windows Server 2008 R2

Nombre de archivo

Amd64_5305f7a1f95355c3ec741daec9cd5a2b_31bf3856ad364e35_6.1.7601.21822_none_8cb2d34be02cf135.manifest

Versión de archivo

No aplicable

Tamaño de archivo

703

Fecha (UTC)

18-Sep-2011

Hora (UTC)

06:02

Plataforma

No aplicable

Nombre de archivo

Amd64_b60b5cbf24fec97a49d44e4683828ccd_31bf3856ad364e35_6.1.7601.21822_none_39b0d1b5e246b7e7.manifest

Versión de archivo

No aplicable

Tamaño de archivo

1,046

Fecha (UTC)

18-Sep-2011

Hora (UTC)

06:02

Plataforma

No aplicable

Nombre de archivo

Amd64_c3d06b01daf73185259bfc94cdb45eef_31bf3856ad364e35_6.1.7600.21057_none_cd3d7ea01052b4cc.manifest

Versión de archivo

No aplicable

Tamaño de archivo

703

Fecha (UTC)

18-Sep-2011

Hora (UTC)

06:02

Plataforma

No aplicable

Nombre de archivo

Amd64_c767e639018f581b698cd2c5693fbc0f_31bf3856ad364e35_6.1.7600.21057_none_2ad3a4985c7e1c4e.manifest

Versión de archivo

No aplicable

Tamaño de archivo

1,046

Fecha (UTC)

18-Sep-2011

Hora (UTC)

06:02

Plataforma

No aplicable

Nombre de archivo

Amd64_microsoft-windows-ldap-client_31bf3856ad364e35_6.1.7600.21057_none_4fdd280189205e2c.manifest

Versión de archivo

No aplicable

Tamaño de archivo

13,962

Fecha (UTC)

18-Sep-2011

Hora (UTC)

02:16

Plataforma

No aplicable

Nombre de archivo

Amd64_microsoft-windows-ldap-client_31bf3856ad364e35_6.1.7601.21822_none_51df1d1d8632c177.manifest

Versión de archivo

No aplicable

Tamaño de archivo

13,962

Fecha (UTC)

18-Sep-2011

Hora (UTC)

04:22

Plataforma

No aplicable

Nombre de archivo

Update.mum

Versión de archivo

No aplicable

Tamaño de archivo

3,215

Fecha (UTC)

18-Sep-2011

Hora (UTC)

06:02

Plataforma

No aplicable

Nombre de archivo

X86_microsoft-windows-ldap-client_31bf3856ad364e35_6.1.7600.21057_none_f3be8c7dd0c2ecf6.manifest

Versión de archivo

No aplicable

Tamaño de archivo

13,956

Fecha (UTC)

18-Sep-2011

Hora (UTC)

01:42

Plataforma

No aplicable

Nombre de archivo

X86_microsoft-windows-ldap-client_31bf3856ad364e35_6.1.7601.21822_none_f5c08199cdd55041.manifest

Versión de archivo

No aplicable

Tamaño de archivo

13,956

Fecha (UTC)

18-Sep-2011

Hora (UTC)

03:12

Plataforma

No aplicable

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