Non Ŕ possibile visualizzare un elenco di cartelle pubbliche nell'organizzazione di Exchange con il database delle cassette postali 2007 Exchange Server e Exchange Server 2010

Traduzione articoli Traduzione articoli
Identificativo articolo: 2621350 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

Sintomi

Se l'organizzazione ospita Microsoft Exchange Server 2007 e Microsoft Exchange Server 2010 database delle cassette postali, Ŕ possibile visualizzare un elenco di cartelle pubbliche nell'organizzazione di Exchange dalla Console di gestione di Exchange 2007 (EMC) o Exchange 2007 Management Shell (EMS).

Considerare i seguenti scenari.

Scenario 1

Viene visualizzato un messaggio di errore analogo al seguente quando si tenta di visualizzare un elenco di cartelle pubbliche utilizzando EMS in Exchange Server 2007:
C:\Windows\systen32>Get?PublicFolder
Ripristinare Get "non esiste alcun ripristinare esistente che corrisponde all'identitÓ seguente: '\'. Assicurarsi che specificato l'identitÓ di ripristinare corretta e avere le autorizzazioni necessarie per visualizzare ripristinare.
In linea: 1 carattere: 17
+ Get ripristinare
+ CategoryInfo: NotSpecified: [Get-ripristinare] (0:Int32) Mapi
OperationException
+ FullyQualifiedErrorId: A01373CB.Microsoft.Exchange.Management.MapiTasks.GetPublicFolder


Scenario 2

Quando si tenta di visualizzare un elenco di cartelle pubbliche utilizzando la Console di gestione di cartella (PFMC) pubblica in Exchange Server 2007, non le cartelle vengono visualizzati.

Inoltre, viene visualizzato un messaggio di errore analogo al seguente quando si tenta di creare una cartella pubblica:

Completamento
Impossibile completare la procedura guidata. Fare clic su Fine per chiudere la procedura guidata.
Tempo trascorso: 00: 00: 00
Riepilogo: 1 elementi. 0 riusciti, 1 non riuscito.

Errore:
Impossibile eseguire l'operazione non esiste alcun database delle cartelle pubbliche disponibili sul server 'nomeserver'.

Comando di Exchange Management Shell tentato:
Nuovo ripristinare 'TestFolder' - nome--percorso ' \'-Server 'Nomeserver'
Tempo trascorso: 00: 00: 00

Cause

Questo problema pu˛ verificarsi se il database di cassette postali 2007 Exchange Server e Exchange Server 2010 cassetta postale presente nell'organizzazione.

Workaround

Per aggirare questo problema, utilizzare uno dei seguenti per gestire le cartelle pubbliche:
  • Exchange Server 2010 Management Shell
  • Exchange Server 2010 Public Folder Management Console
  • Strumento Exfolders.exe

Informazioni

In Exchange Server 2010, i database non sono collegati a un oggetto server cassette postali. Pertanto, l'attributo LegacyExchangeDN non specifica il server di cassette postali in cui Ŕ ospitato il database.

Nel 2010 Exchange Server, database delle cassette postali sono collegati a un server Accesso Client (CAS). Una CA non Ŕ un oggetto Supervisore sistema a meno che non viene installato anche il ruolo del Server cassette postali. Il problema descritto nella sezione "Sintomi" si verifica se l'oggetto Supervisore sistema non esiste.

Una cassetta postale Supervisore sistema Ŕ necessario per recuperare un elenco di cartelle pubbliche. Exchange Server 2007 questi passaggi per selezionare una cassetta postale Supervisore sistema:
  1. Exchange Server 2007 seleziona un database delle cassette postali.
  2. Exchange Server 2007 Ottiene l'attributo LegacyExchangeDN del database delle cassette postali selezionato. Ad esempio, Exchange Server 2007 Ottiene il valore dell'attributo LegacyExchangeDN seguente:

    /o = prima organizzazione/ou = (gruppo amministrativo di Exchangenome_gruppo) / cn = Configuration/cn = Servers/cn =E14HUBCAS/CN =Microsoft Private MDB
  3. Exchange Server 2007 rimuove il "CN =Database delle cassette postali"parte dell'indirizzo. Quindi l'indirizzo simile al seguente:

    /o = prima organizzazione/ou = (gruppo amministrativo di Exchangenome_gruppo) / cn = Configuration/cn = Servers/cn =E14HUBCAS
  4. Exchange Server 2007 aggiunge "CN = Microsoft System Supervisore" al valore LegacyExchangeDN. Dopo il valore viene aggiunto, il valore dell'attributo LegacyExchangeDN analogo al seguente:

    /o = prima organizzazione/ou = (gruppo amministrativo di Exchangenome_gruppo) / cn = Configuration/cn = Servers/cn =E14HUBCAS/ CN = Supervisore sistema di Microsoft
  5. Exchange Server 2007 tenta di accedere all'archivio pubblico utilizzando il valore nel passaggio 4.
  6. L'archivio tenta di individuare l'oggetto Supervisore sistema.
Questo processo funziona correttamente in Exchange Server 2007 e viene restituito un elenco delle cartelle pubbliche. Tuttavia, il processo non riesce se Ŕ selezionato un database Exchange Server 2010 nel passaggio 1 il valore dell'attributo LegacyExchangeDN specifica dove Ŕ ospitato il database delle cassette postali.

Riferimenti

Per ulteriori informazioni sullo strumento ExFolders, visitare il seguente sito Web di TechNet:
http://Gallery.technet.microsoft.com/Office/Exchange-2010-SP1-ExFolders-e6bfd405

ProprietÓ

Identificativo articolo: 2621350 - Ultima modifica: lunedý 15 ottobre 2012 - Revisione: 1.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Exchange Server 2007 Standard Edition
  • Microsoft Exchange Server 2007 Enterprise Edition
  • Microsoft Exchange Server 2010 Standard
  • Microsoft Exchange Server 2010 Enterprise
Chiavi:á
kbsurveynew kbtshoot kbprb kbmt KB2621350 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 2621350
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com