SharePoint 2010: Metadata field values not saved on imported sites

Article ID: 2622517 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

Consider the following scenario:

You have a site that contains lists with columns that are connected to a Managed Metadata term store.
You export that site and import it as a new site.  When you add a new document to the list in the new site and specify a value for the Managed Metadata column, that value is not retained.  Instead the column remains blank.



CAUSE

This issue happens when any of the below is true:

  • The site was exported without user security information.
  • The site was imported without user security information.
  • A template name was specified when creating the new site before import.
  • For example: New-SPSite-Url <New SiteUrl> -owneralias <alias> -Template "STS#0"

RESOLUTION

Ensure to include user security information in export and import operation AND do not specify a template when creating the import site.

In other words, use code like:
 

Export-SPWeb -Identity <Existing WebUrl> -Path <Backup FilePath> -IncludeUserSecurity

$MySite = New-SPSite -Url <New SiteUrl> -owneralias <alias>

$MyWeb = $MySite.RootWeb

Import-SPWeb $MyWeb -Path <Backup FilePath> -IncludeUserSecurity

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2622517 - Last Review: October 7, 2011 - Revision: 4.0
APPLIES TO
  • Microsoft SharePoint Server 2010
  • Microsoft SharePoint Server 2010 Service Pack 1
Keywords: 
KB2622517

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com