Procédures pour résoudre les problèmes de blocage de l'ordinateur lors de la détection matérielle

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Ancien nº de publication de cet article : F262381
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Sommaire

Symptômes

Lorsque vous essayez d'installer Windows 98 ou Windows Millennium Edition, le programme d'installation peut cesser de répondre (ou se bloquer) au cours du processus de détection matérielle. Lors de cette phase, le programme d'installation détermine quels composants matériels sont installés sur votre ordinateur. Vous devez alors redémarrer votre ordinateur une ou deux fois de suite, selon le type de matériel de votre ordinateur. Vous pouvez identifier cette phase d'installation grâce à l'écran " configuration du matériel ". Les méthodes de résolution suivantes sont décrites dans cet article :

Cause

Divers problèmes matériels peuvent provoquer le blocage de votre ordinateur. Si vous essayez d'effectuer une mise à niveau, ce problème peut se produire car il existe des conflits avec les paramètres matériels précédents. Si vous essayez d'installer une version complète de Windows 98 ou de Windows Millenium Edition, ce problème peut être provoqué par un matériel incompatible, un matériel qui se trouve dans un emplacement de bus inapproprié sur la carte mère ou par les paramètres BIOS.

Résolution

Pour résoudre ce problème, adoptez l'une des méthodes de résolution suivantes :

Redémarrez votre ordinateur

Vous pouvez peut-être contourner ce problème en redémarrant votre ordinateur. Éteignez votre ordinateur, puis rallumez-le. Si le programme d'installation de Windows 98 ne fonctionne pas, essayez l'une des méthodes suivantes.


Redémarrez en mode sans échec et utilisez le fichier Msconfig.exe

Redémarrez votre ordinateur, appuyez sur la touche CTRL et maintenez-la enfoncée jusqu'à ce que le démarrage initial sur auto-test soit terminé, puis sélectionnez le mode sans échec à partir du menu Démarrer. Pour plus d'informations sur le démarrage de Windows 98, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
  • 178548 Le message 'Démarrage de Windows 98' ne s'affiche pas lors du démarrage
Une fois votre ordinateur redémarré en mode sans échec, minimisez les conflits qui peuvent empêcher votre ordinateur d'achever l'installation à l'aide de l'outil Utilitaire de configuration système (Msconfig.exe).

Pour démarrer et utiliser l'outil Informations système :
  1. Cliquez sur Démarrer, pointez sur Programmes, pointez sur Accessoires, pointez sur Outils système, puis cliquez sur Informations système.
  2. Dans le menu Outils, cliquez sur Utilitaire de configuration du système.
  3. Dans l'onglet Général, cliquez sur Démarrage sélectif, puis désactivez les cases à cocher suivantes :
    • Exécuter le fichier Config.sys
    • Exécuter le fichier Autoexec.bat
    • Exécuter le fichier Winstart.bat (si disponible)
    • Exécuter le fichier System.ini
    • Exécuter le fichier Win.ini
    • Charger les rubriques du groupe Démarrage

  4. Cliquez sur OK, puis redémarrez l'ordinateur lorsque vous y êtes invité.
Si le programme d'installation est achevé, procédez comme suit pour rétablir le mode de démarrage normal sur votre ordinateur. Si votre ordinateur ne répond toujours pas (ou se bloque), procédez comme indiqué dans la section " Vérifier la configuration matérielle ".
  1. Exécutez l'utilitaire de configuration système, sélectionnez l'un des éléments du démarrage sélectif, cliquez sur OK, puis suivez les instructions affichées à l'écran pour redémarrer votre ordinateur et tester les blocages ou les comportements anormaux.
  2. Continuez jusqu'à ce que tous les éléments du démarrage sélectif soient sélectionnés. Si vous sélectionnez un élément et que votre ordinateur se bloque ou se comporte de façon anormale, cliquez sur OK, puis redémarrez votre ordinateur. Continuez jusqu'à ce que vous ayez trouvé le paramètre à l'origine du problème.
  3. Si vous pouvez redémarrer votre ordinateur avec succès lorsque tous les éléments sont sélectionnés, exécutez l'outil Utilitaire de configuration système, activez la case à cocher Démarrage normal, cliquez sur OK, puis redémarrez votre ordinateur.
Pour plus d'informations sur l'utilisation du fichier Msconfig.exe, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
  • 192926 Procédure de dépannage par démarrage minimal pour Windows 98

Résolution avancée des problèmes à l'aide du fichier Msconfig.exe

Redémarrez votre ordinateur, appuyez sur la touche CTRL et maintenez-la enfoncée jusqu'à ce que le démarrage initial sur auto-test soit terminé, puis sélectionnez le mode sans échec à partir du menu Démarrer. Pour plus d'informations sur le démarrage de Windows 98, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
  • 178548 Le message 'Démarrage de Windows 98' ne s'affiche pas lors du démarrage
Une fois votre ordinateur redémarré en mode sans échec, minimisez les conflits qui peuvent empêcher votre ordinateur d'achever l'installation à l'aide de l'outil Utilitaire de configuration système (Msconfig.exe).

Pour démarrer et utiliser l'outil Informations système :
  1. Dans la barre d'outils, cliquez sur Démarrer, pointez sur Programmes, sur Accessoires, sur Outils système, puis cliquez sur Informations système.
  2. Dans le menu Outils, cliquez sur Utilitaire de configuration du système.
  3. Dans l'onglet Général, cliquez sur le bouton Avancés.
  4. Sélectionnez l'option Forcer l'accès du disque en mode compatible.
  5. En bas de la liste des Paramètres avancés de dépannage , cliquez sur OK, puis encore une fois sur OK.
  6. Redémarrez l'ordinateur lorsque vous y êtes invité.
Si le programme d'installation s'exécute complètement, le problème provenait d'une incompatibilité entre le contrôleur du disque dur et le programme d'installation. Pour activer l'accès au disque 32 bits sur votre Bureau, procédez comme suit :
  1. Dans la barre d'outils, cliquez sur Démarrer, pointez sur Programmes, sur Accessoires, sur Outils système, puis cliquez sur Informations système.
  2. Dans le menu Outils, cliquez sur Utilitaire de configuration du système.
  3. Dans l'onglet Général, cliquez sur le bouton Avancés.
  4. Sélectionnez l'option Forcer l'accès du disque en mode compatible.
  5. Dans Paramètres avancés de dépannage, cliquez sur OK.
  6. Redémarrez l'ordinateur lorsque vous y êtes invité.

Vérifiez la configuration matérielle

Pour vérifier la configuration matérielle de votre ordinateur, redémarrez-le en mode sans échec et utilisez le Gestionnaire de périphériques pour dépanner les matériels installés. Pour cela, procédez comme suit :
  1. Cliquez sur Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration et double-cliquez sur Système.
  2. Dans l'onglet Gestionnaire de périphériques, désactivez tous les périphériques des branches suivantes :
    • Cartes graphiques
    • Contrôleurs de disquette
    • Contrôleurs de disque dur
    • Clavier
    • Cartes réseau
    • Socket PCMCIA
    • Ports
    • Contrôleurs SCSI
    • Contrôleurs son, vidéo et jeu
    • Souris

    Pour désactiver un périphérique dans le Gestionnaire de périphériques, procédez comme suit.

    REMARQUE : Lorsque vous avez une souris série et que vous désactivez les ports COM, si Windows indique à BIOS que les ports COM sont désactivés, la fonctionnalité souris ne sera disponible que lorsque vous aurez réactivé les ports COM dans BIOS.

    1. Double-cliquez sur la branche qui contient le périphérique de votre choix, cliquez sur ce périphérique, puis cliquez sur Propriétés.
    2. Dans l'onglet Général, activez la case à cocher Désactiver dans ce profil matériel, puis cliquez sur OK.
    3. Redémarrez votre ordinateur.
    REMARQUE : Lorsque vous désactivez la souris puis redémarrez votre ordinateur, le message suivant peut s'afficher :
    Windows n'a détecté aucune souris reliée à cet ordinateur. Vous pouvez brancher une souris série en toute sécurité.
    Pour activer la souris, utilisez l'une des commandes de clavier suivantes :

    1. Appuyez sur CTRL+Échap pour activer le menu Démarrer.
    2. Utilisez la flèche du haut pour sélectionner Paramètres, appuyez sur la flèche droite pour sélectionner le Panneau de configuration, puis appuyez sur ENTRÉE.
    3. Appuyez sur la flèche du bas et celle de gauche pour sélectionner Système, puis appuyez sur ENTRÉE.
    4. Appuyez sur la flèche de droite pour sélectionner l'onglet Gestionnaire de périphériques, appuyez deux fois sur TABULATION, puis appuyez sur la flèche du bas pour sélectionner le périphérique répertorié dans la branche Souris développée.
    5. Appuyez sur TABULATION pour sélectionner Propriétés, appuyez sur ENTRÉE, puis sur TABULATION pour sélectionner Activer le périphérique, puis appuyez sur ENTRÉE.
    6. Cliquez sur OK, puis sur OUI pour redémarrer votre ordinateur.
    7. Si la souris ne fonctionne toujours pas après l'étape E, appuyez sur TABULATION, puis sur ENTRÉE. Appuyez sur ENTRÉE lorsque vous êtes invité à redémarrer votre ordinateur.
  3. Pour désactiver un périphérique dans le Gestionnaire de périphériques, procédez comme suit. Si l'installation se poursuit, activez les périphériques que vous avez désactivés lors de l'étape 2, puis vérifiez qu'il n'y a aucun conflit de périphériques. Activez les périphériques dans l'ordre suivant :
    • Ports COM
    • Contrôleurs de disque dur
    • Contrôleurs de disquette
    • Tous les autres périphériques

    Pour activer un périphérique et vérifier s'il existe des conflits, procédez comme suit :

    1. Double-cliquez sur la branche qui contient le périphérique de votre choix, cliquez sur ce périphérique, puis cliquez sur Propriétés.
    2. Dans l'onglet Général, désactivez la case à cocher Désactiver dans ce profil matériel.
    3. Dans l'onglet Ressources, vérifiez qu'il n'y a pas de conflits répertoriés dans la zone Liste de périphériques en conflit. Notez que l'onglet Ressources ne s'affiche pas pour chaque périphérique.
    4. Cliquez sur OK puis redémarrez votre ordinateur.

Vérifiez les fichiers journaux

Une autre méthode de dépannage qui peut aider à déterminer l'origine du problème consiste à examiner les fichiers journaux du programme d'installation. Trois fichiers sont créés lors de l'installation :
  • Detlog.txt. Ce fichier répertorie le début du test de détection et le résultat de ce test. Il s'agit d'un fichier caché qui se trouve dans le dossier racine du disque C.
  • Detcrash.log. Ce fichier enregistre quelles étapes de détection ont été achevées avec succès pour que le programme d'installation ne se rebloque pas lors de la même étape. Il s'agit d'un fichier caché créé uniquement lorsque l'étape de détection est à l'origine du blocage de l'ordinateur. Ce fichier se trouve dans le dossier racine du disque C.
  • Setuplog.txt. Ce fichier enregistre ce qui se passe lors de l'installation, aussi bien les réussites que les problèmes. Il est utilisé par la Récupération sans incident pour savoir où recommencer l'installation. Ce fichier se trouve dans le dossier racine du disque C.

Installez dans un nouveau dossier

Si le problème persiste, installez Windows dans un nouveau dossier destiné aux tests uniquement. Vous pouvez utiliser la commande suivante du programme d'installation pour résoudre les problèmes concernant un module spécifique :
setup /p b
Le commutateur /p entraîne un dysfonctionnement du programme d'installation qui envoie directement une ou plusieurs chaînes au Gestionnaire de périphériques (Sysdetmg.dll). Le programme d'installation n'interprète pas le contenu de la chaîne. La chaîne peut contenir une ou plusieurs options de détection.

Le commutateur b active le mode Demander confirmation avant. On vous demande votre confirmation avant qu'un module de détection ne soit activé afin que vous puissiez parcourir manuellement chaque module de détection et décider de l'ignorer ou non. Le mode par défaut est désactivé.

Pour plus d'informations sur l'installation de Windows 98 dans un nouveau dossier, reportez-vous à l'article suivant de la Base de connaissances Microsoft :
193902 Procédure d'installation de Windows 98 dans un nouveau dossier

Vérifiez s'il existe des problèmes avec le système BIOS

Dans certaines cartes mères, Windows 98 ou Windows Millenium Edition peut ne pas être capable d'achever avec succès le processus de détection Plug and Play. Ce problème peut être provoqué par une interprétation incorrecte des données stockées dans le système BIOS de l'ordinateur. Si vous avez essayé les méthodes précédentes et que votre ordinateur cesse de répondre lors de la détection matérielle, contactez le fabricant de votre ordinateur pour savoir si vous avez besoin d'une mise à jour avant d'installer Windows 98 sur votre ordinateur.

Mise à niveau de Windows 3.1

Si vous effectuez une mise à niveau à partir de Microsoft Windows 3.1, il se peut que votre fichier groupe (.grp) Windows 3.1 soit endommagé. Si votre fichier groupe est endommagé, utilisez l'outil Convertisseur de groupes pour recréer les groupes. Pour cela, procédez comme suit :
  1. Laissez votre ordinateur éteint pendant au moins 10 secondes, puis remettez-le sous tension.
  2. Cliquez sur Démarrer, sur Exécuter, puis tapez grpconv.exe dans la zone Ouvrir. Cliquez sur OK.

Utilisation d'IntraNetWare de Novell version 2.2

Si vous effectuez une mise à niveau à partir de Vérifier la configuration matérielle de Microsoft Windows 95 avec IntraNetWare de Novell version 2.2 (que l'on appelle également Client32) pour le logiciel Windows 95 installé, contactez Novell pour obtenir un fichier Nwsipx32.dll à jour.

Les produits tiers mentionnés dans le présent article proviennent de fournisseurs indépendants de Microsoft ; nous n'accordons aucune garantie, implicite ou autre, en ce qui concerne le fonctionnement ou la fiabilité de ces produits.

Plus d'informations

Pour plus d'informations sur la résolution des problèmes concernant le matériel, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
133240 Résolution de conflits de périphériques à l'aide du Gestionnaire de périphériques

Propriétés

Numéro d'article: 262381 - Dernière mise à jour: mardi 28 décembre 2004 - Version: 2.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows 98 Deuxième Édition
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows Millennium Edition
Mots-clés : 
kbenv kbhardware kbhw kbprb kbsetup kbtshoot kbwinme win98 win98se KB262381
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