Como solucionar problemas com a paralização do computador durante a detecção de hardware

Traduções deste artigo Traduções deste artigo
ID do artigo: 262381 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Ao tentar instalar o Windows 98 ou Windows Millennium Edition (Me), a Instalação pode parar de responder (paralisar) durante o processo de detecção de hardware. Durante essa fase, a Instalação determina quais componentes de hardware estão instalados em seu computador. Essa fase pede para você reiniciar o computador uma ou duas vezes, dependendo do tipo de hardware em seu computador. Você pode identificar essa fase da Instalação pela tela "Instalação do Hardware".

Causa

Seu computador pode parar de responder devido a vários problemas de hardware. Se você estiver tentando atualizar, isso poderá ocorrer devido a conflitos com configurações de hardware anteriores. Se você estiver tentando instalar um versão completa do Windows 98 ou Windows Me, isso poderá ocorrer devido a um hardware incompatível, localizado em um slot de barramento errado na placa-mãe, ou em configurações do BIOS (Basic Input/Output System).

Resolução

Observação Como há diversas versões do Microsoft Windows, as seguintes etapas podem ser diferentes no seu computador. Se este for o caso, consulte a documentação do produto para concluir estas etapas.

Para resolver esse problema, use um dos seguintes métodos:

Reiniciar o computador

Você poderá resolver esse problema reiniciando o computador. Desligue seu computador e depois ligue-o novamente. Se a Instalação do Windows 98 não continuar, experimente o seguinte método.


Reiniciar no Modo de segurança e usar o Msconfig.exe

Reinicie o seu computador, mantenha a tecla CTRL pressionada após o computador concluir o POST (Power On Self Test), e então selecione Modo de Segurança no menu Iniciar. Para obter informações adicionais sobre a inicialização do Windows 98, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
178548 Não aparece a mensagem "Inicializando o Windows 98" ao iniciar
Depois de o computador reiniciar no modo de Segurança, use a ferramenta Utilitário de Configuração do Sistema (Msconfig.exe) para dimimuir os conflitos que podem fazer com que seu computador não conclua a Instalação.

Para iniciar e usar a ferramenta Informações do sistema:
  1. Clique em Iniciar, aponte para Programas, para Acessórios, para Ferramentas do sistema e clique em Informações do sistema.
  2. No menu Ferramentas, clique em Utilitário de configuração do sistema.
  3. Na guia Geral, clique em Inicialização seletiva e desmarque as seguintes caixas de seleção:
    • Processar o arquivo Config.sys
    • Processar o arquivo Autoexec.bat
    • Processar o arquivo Winstart.bat (caso esteja disponível)
    • Processar o arquivo System.ini
    • Processar o arquivo Win.ini
    • Carregar itens do grupo de Inicialização:

  4. Clique em OK e reinicie o computador quando solicitado.
Se a Instalação for concluída, use as seguintes etapas para fazer com que seu computador volte ao modo de inicialização normal. Se o computador continuar não respondendo, use as etapas na seção "Verificar a configuração de hardware".
  1. Execute o Utilitário de configuração do sistema, selecione um item da inicialização seletiva, clique em OK, e então execute as instruções na tela para reiniciar o computador e testar a paralisação ou o comportamento incomum.
  2. Continue esse processo até que todos os itens de inicialização seletiva estejam selecionados. Se você selecionar um item e seu computador parar de responder ou se comportar de maneira diferente, clique na guia do item correspondente, desmarque metade das caixas de seleção, clique em OK, e em seguida reinicie o computador. Continue esse processo até localizar a configuração que está causando o problema.
  3. Se você conseguir reiniciar o computador quando todos os itens estiverem selecionados, execute o Utilitário de configuração do sistema, marque a caixa seleção Inicialização normal, clique em OK, e em seguida execute as etapas na tela para reiniciar o computador.
Para obter mais informações sobre o uso do Msconfig.exe, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
192926 Como realizar a solução de problemas com inicialização simples para o Windows 98

Solução de problemas Avançado com o Msconfig.exe

Reinicie o computador, mantenha a tecla CTRL pressionada após o computador concluir o POST (Power On Self Test), e então escolha o Modo de segurança no menu Iniciar. Para obter informações adicionais sobre a Inicialização do Windows 98, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
178548 Não aparece a mensagem "Inicializando o Windows 98" ao iniciar
Depois que seu computador reiniciar no modo de Segurança, use a ferramenta Utilitário de Configuração do Sistema (Msconfig.exe) para dimimuir os conflitos que podem fazer com que seu computador não conclua a Instalação.

Para iniciar e usar a ferramenta Informações do sistema:
  1. Na barra de ferramentas, clique em Iniciar, aponte para Programas, em seguida para Acessórios, Ferramentas do sistema, e em seguida clique na ferramenta Informações do sistema.
  2. No menu Ferramentas, clique em Utilitário de configuração do sistema.
  3. Na guia Geral, clique no botão Avançado.
  4. Selecione a opção Forçar modo de compatibilidade a disco.
  5. Na parte inferior das configurações Solução de problemas avançada, clique em OK, e novamente em OK.
  6. Reinicie o computador quando for solicitado.
Se a Instalação estiver concluída, esse comportamento foi causado por uma incompatibilidade entre o controlador de disco rígido e o programa de Instalação. Para ativar o acesso ao disco de 32 bits em sua área de trabalho, execute estas etapas:
  1. Na barra de ferramentas, clique em Iniciar, aponte para Programas, em seguida para Acessórios, Ferramentas do sistema, e em seguida clique na ferramenta Informações do sistema.
  2. No menu Ferramentas, clique em Utilitário de configuração do sistema.
  3. Na guia Geral, clique no botão Avançado.
  4. Selecione a opção Forçar modo de compatibilidade a disco.
  5. Nas configurações Solução de problemas avançada, clique em OK.
  6. Reinicie o computador quando for solicitado.

Verificar a configuração de hardware

Para verificar a configuração de hardware no computador, reinicie-o no Modo de segurança e use o Gerenciador de dispositivo para solucionar o problema do hardware instalado. Para fazer isso:
  1. Clique em Iniciar, aponte para Configurações, clique em Painel de controle e clique duas vezes em Sistema.
  2. Na guia Gerenciador de dispositivo, desabilite todos os dispositivos nas seguintes ramificações:
    • Adaptadores de vídeo
    • Controladores de disquete
    • Controladores de disco rígido
    • Teclado
    • Adaptadores de rede
    • Soquete PCMCIA
    • Portas
    • Controladores SCSI
    • Controladores de som, vídeo e jogo
    • Mouse

    Para desativar um dispositivo no Gerenciador de dispositivo, use as seguintes etapas.

    OBSERVAÇÃO: Se você tiver um mouse de série e desativar as portas COM, se o Windows gravar no BIOS que as portas COM estão desativadas, não haverá funcionalidade em seu mouse até que você reative as portas COM no BIOS.

    1. Clique duas vezes na ramificação que apresenta o dispositivo que você deseja, clique nele, e em seguida em Propriedades.
    2. Na guia Geral, marque a caixa de seleção Desativar neste perfil de hardware, e clique em OK.
    3. Reinicie o computador.
    OBSERVAÇÃO: Ao desativar o mouse e reiniciar o computador, você pode receber a seguinte mensagem de erro:
    O Windows não detectou um mouse ligado em seu computador. Agora você pode ligar com segurança um mouse de série.
    Para ativar o mouse, use os seguintes comandos do teclado:

    1. Pressione CTL+ESC para ativar o menu Iniciar.
    2. Pressione SETA PARA CIMA até selecionar Configurações, pressione SETA PARA A DIREITA para selecionar Painel de Controle, e em seguida pressione ENTER.
    3. Pressione SETA PARA BAIXO e SETA PARA A ESQUERDA até selecionar Sistema, e em seguida pressione ENTER.
    4. Pressione SETA PARA A DIREITA para selecionar a guia Gerenciador de dispositivo, pressione TAB, TAB, e depois pressione SETA PARA BAIXO para selecionar o dispositivo listado na ramificação expandida Mouse.
    5. Pressione TAB para selecionar Propriedades, pressione ENTER, TAB para selecionar Ativar dispositivo, e então pressione ENTER.
    6. Clique em OK, e em seguida clique em Sim para reiniciar o computador.
    7. Se o mouse ainda não funcionar depois da etapa E, pressione TAB e depois ENTER. Pressione ENTER quando for solicitado para reiniciar o computador.
  3. Se a Instalação continuar, ative os dispositivos na etapa 2 após a Instalação estar concluída e verifique se nenhum dispositivo está em conflito. Ative os dispositivos na seguinte ordem:
    • Portas COM
    • Controladores de disco rígido
    • Controladores de disquete
    • Todos os demais dispositivos

    Para ativar um dispositivo e verificar se existe conflito, execute estas etapas:

    1. Clique duas vezes na ramificação que apresenta o dispositivo que você deseja, clique nele, e em seguida em Propriedades.
    2. Na guia Geral, desmarque a caixa de seleção Desativar neste perfil de hardware.
    3. Na guia Recursos, verifique se não há conflitos listados na caixa Lista de dispositivos em conflito. Note que a guia Recursos não aparece para todos os dispositivos.
    4. Clique em OK e reinicie o computador.

Verificar arquivos de log

Outro método que pode ajudar a determinar a causa do problema é examinar a Instalação dos arquivos de log. São criados três arquivos durante a Instalação:
  • Detlog.txt. Este arquivo de log lista o início do teste de detecção. Esse é um arquivo oculto na pasta raiz do drive C.
  • Detcrash.log. Este arquivo grava quais etapas de detecção foram concluídos de modo que a Instalação não pare de responder na mesma etapa novamente. Esse é um arquivo oculto criado somente se a etapa de detecção fizer com que o computador pare de responder. Esse arquivo está localizado na pasta raiz do drive C.
  • Setuplog.txt. Este arquivo grava o que acontece durante a Instalação, incluindo êxitos e problemas. É usado pela Recuperação segura para determinar onde a Instalação deve ser resumida. Esse arquivo está localizado na pasta raiz do drive C.

Instalar em uma nova pasta

Se o problema persistir, instale o Windows em uma nova pasta para testes. Você pode usar o seguinte comando de Instalação para solucionar problemas de um módulo específico:
setup /p b
A alternação /p faz com que a Instalação passe uma(s) seqüência(s) diretamente ao Gerenciador de detecção (Sysdetmg.dll). A Instalação não interpreta o conteúdo da seqüência. A seqüência pode conter uma ou mais opções de detecção.

A alternação b ativa o modo Solicitar antes. A solicitação é feita antes de um módulo de detecção ser chamado de modo que você possa passar por cada um manualmente e decidir se deseja ignorá-lo. O padrão é desativado.

Para obter informações adicionais sobre a instalação do Windows 98 em uma nova pasta, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
193902 Como instalar o Windows 98 em uma nova pasta

Verificar problemas do sistema BIOS

Em certas placas-mãe, o Windows 98 ou o Windows Me podem não conseguir concluir o processo de detecção do Plug and Play. Esse problema pode ser causado por uma interpretação incorreta de dados armazenados no BIOS do computador. Se você tentou executar as etapas nos métodos anteriores e seu computador ainda pára de responder durante a detecção de hardware, entre em contato com o fabricante para verificar se é necessária uma atualização antes de instalar o Windows 98 em seu computador.

Atualização no Windows 3.1

Se você está atualizando a partir do Microsoft Windows 3.1, você poderá ter um arquivo .grp (group) do Windows 3.1 danificado. Se você tiver um arquivo .grp danificado, use a ferramenta Group Converter para recriar os grupos. Para fazer isso, execute as seguintes etapas:
  1. Desligue seu computador por pelo menos dez segundos e depois ligue-o novamente.
  2. Clique em Iniciar, clique em Executar, digite grpconv.exe na caixa Abrir e clique em OK.

Usando o Cliente Novell IntraNetWare Client versão 2.2

Se você estiver atualizando pelo Microsoft Windows 95 com o Cliente Novell IntraNetWare Client 2.2 para o software do Windows 95 (também conhecido como Cliente32) instalado, contate a Novell para obter um arquivo Nwsipx32.dll atualizado.

Os produtos de terceiros mencionados neste artigo são fabricados por empresas que são independentes da Microsoft. A Microsoft não oferece garantia, implícita ou não, em relação ao desempenho ou à confiabilidade destes produtos.

Mais Informações

Para obter mais informações sobre como solucionar problemas do hardware quando a Instalação estiver concluída, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
133240 Como solucionar problemas com conflitos de dispositivo usando o Gerenciador de dispositivos

Propriedades

ID do artigo: 262381 - Última revisão: sexta-feira, 20 de outubro de 2006 - Revisão: 2.3
A informação contida neste artigo aplica-se a:
  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98 Standard Edition
Palavras-chave: 
kbenv kbhardware kbprb kbsetup kbtshoot KB262381

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com