Article ID: 2629790 - Last Review: January 25, 2012 - Revision: 1.0

The Exchange IMAP4 service may stop responding on an Exchange Server 2007 Client Access server when users access mailboxes that are hosted on Exchange Server 2003 servers

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SYMPTOMS

Consider the following scenario:
  • You have a mixed Microsoft Exchange Server 2007 and Microsoft Exchange Server 2003 environment.
  • You have Exchange Server 2007 Service Pack 3 Update Rollup 2, 3, 4 or 5 installed on Exchange Server 2007 servers. 
  • You use an Exchange Server 2007 Client Access server to proxy requests for Exchange Server 2003 mailbox servers.
  • Users try to access the mailboxes that are hosted on the Exchange Server 2003 servers by using Internet Message Access Protocol 4 (IMAP4) clients.
In this scenario, the Microsoft Exchange IMAP4 service on the Exchange Server 2007 Client Access server may stop responding. Additionally, the IMAP4 clients cannot connect to the mailboxes until you restart the Exchange IMAP4 service.

CAUSE

This issue occurs because of a deadlock when the Client Access server manages and releases the IMAP4 session and the proxy session.


RESOLUTION

To resolve this issue, install the following update rollup:
2608656  (http://support.microsoft.com/kb/2608656/ ) Description of Update Rollup 6 for Exchange Server 2007 Service Pack 3

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Exchange Server 2007 Service Pack 3, when used with:
    • Microsoft Exchange Server 2007 Enterprise Edition
    • Microsoft Exchange Server 2007 Standard Edition
Keywords: 
kbqfe kbfix kbsurveynew kbexpertiseinter KB2629790