Article ID: 2632331 - Last Review: November 3, 2011 - Revision: 3.0

FAST Search for SharePoint 2010: "The search request was unable to connect to the Search Service"

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Symptoms

Searching from a SharePoint Fast Search Center intermittently fails with the following error:


“The search request was unable to connect to the Search Service”


Also, after increasing the diagnostic logging level for "SharePoint Server Search", additional errors may be found in the SharePoint ULS logs.
 
Procedure:
  1. Increase Logging: SharePoint Central Administration -> Monitoring -> Configure diagnostic logging -> Select "SharePoint Server Search" and change level to "Verbose". 
  2. Reproduce issue by searching until the error "The search request was unable to connect to the Search Service" occurs.
  3. Check the SharePoint ULS logs and Application event log for the following errors:
 
From ULS Logs:

12:59:37.47 OWSTIMER.EXE (0x1238) 0x1DA8 SharePoint Foundation Claims Authentication fsq7 High Request for security token failed with exception: System.ServiceModel.ServiceActivationException: The requested service 'http://localhost:32843/SecurityTokenServiceApplication/securitytoken.svc/actas' could not be activated. 

From Application Event Logs:

Log Name: Application
Source: System.ServiceModel 3.0.0.0
Date: <EventDate>
Event ID: 3  
Task Category: WebHost
Level: Error
Keywords: Classic
User: <SearchAccount>
Computer: <ServerName> 
Description:
WebHost failed to process a request.
Sender Information: System.ServiceModel.ServiceHostingEnvironment+HostingManager/17653682
Exception: System.ServiceModel.ServiceActivationException: The service '/SecurityTokenServiceApplication/securitytoken.svc' cannot be activated due to an exception during compilation. The exception message is: Exception has been thrown by the target of an invocation.. ---> System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.InvalidOperationException: The farm is unavailable.
at Microsoft.SharePoint.Administration.Claims.SPSecurityTokenServiceManager.get_Local()
at Microsoft.SharePoint.IdentityModel.SPSecurityTokenServiceConfiguration..ctor()
--- End of inner exception stack trace ---
at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandle& ctor, Boolean& bNeedSecurityCheck)
at System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean fillCache)
at System.RuntimeType.CreateInstanceImpl(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean fillCache)
at System.Activator.CreateInstance(Type type, Boolean nonPublic)
at System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
at System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
at Microsoft.IdentityModel.Protocols.WSTrust.WSTrustServiceHostFactory.CreateSecurityTokenServiceConfiguration(String constructorString)
at Microsoft.IdentityModel.Protocols.WSTrust.WSTrustServ


Log Name: Application
Source: Microsoft-SharePoint Products-SharePoint Foundation
Date:  <EventDate>
Event ID: 8306
Task Category: Claims Authentication
Level: Error
Keywords:      
User: <SearchAccount>
Computer: <ServerName>
Description:
An exception occurred when trying to issue security token: The requested service, 'http://localhost:32843/SecurityTokenServiceApplication/securitytoken.svc/actas' could not be activated. See the server's diagnostic trace logs for more information.

Cause

This problem can occur if the application pool for the SecurityTokenServiceApplication is set to use 32-bit support in IIS. When the SecurityTokenServiceApplication utilizes the 32-bit code path, the connection cannot be activated.  


Resolution

This problem can be resolved by disabling 32-bit support for the SecurityTokenServiceApplication application pool.

Procedure:
  1. Open IIS Manager from the SharePoint Front End Server.
  2. Access the "Application Pools" section.
  3. Right click the "SecurityTokenServiceApplicationPool" and choose "Advanced Settings"
  4. Change "Enable 32-Bit Applications" to False.
  5. Save the changes and close the advanced settings.
  6. Reset IIS with by running "IISRESET" from an administrative command prompt.

More Information

Configure diagnostic logging settings (SharePoint Server 2010)  
http://technet.microsoft.com/en-us/library/ee748656.aspx (http://technet.microsoft.com/en-us/library/ee748656.aspx)
 
  
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use (http://go.microsoft.com/fwlink/?LinkId=151500) for other considerations.

APPLIES TO
  • Microsoft FAST Search Server 2010 for SharePoint
  • Microsoft SharePoint Server 2010
Keywords: 
KB2632331