Rdpshell.exe-Prozess verliert Speicher in Windows Server 2008 R2, beim Verschieben einer veröffentlichten RemoteApp Anwendung Fenster auf der Clientseite

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Problembeschreibung

Betrachten Sie das folgende Szenario:
  • Veröffentlichen Sie eine RemoteApp-Anwendung auf einem Remotedesktopserver, auf denen Windows Server 2008 R2 ausgeführt wird.
  • Ein Benutzer beginnt, die veröffentlichte RemoteApp-Anwendung auf einem Clientcomputer.
  • Der Benutzer verschiebt die veröffentlichten RemoteApp Anwendung Fenster auf einen anderen auf dem Bildschirm Speicherort auf dem Clientcomputer.
In diesem Szenario hält die Speicherauslastung des Prozesses Rdpshell.exe in der gleichen Sitzung auf dem remote desktop Server erhöhen. Schließlich wird der verfügbare Speicher auf dem remote desktop-Server vollständig ausgeschöpft. In diesem Fall beenden Sie alle gerade ausgeführten Anwendungen und Dienste auf dem remote desktop Server arbeiten. Um dieses Problem zu beheben, muss der Benutzer schließen Sie alle seine RemoteApp-Anwendungen auf dem Server, und warten Sie mindestens eine Minute für die Sitzung beendet.

Hinweis Wenn Sie die Speicherauslastung des Prozesses Rdpshell.exe überwachen, finden Sie, dass der Wert seiner Privater Arbeitssatz -Leistungsindikator zunimmt.

Ursache

Dieses Problem tritt auf, weil einige belegten Speicher im Prozess Rdpshell.exe nicht ordnungsgemäß freigegeben wird.

Lösung

Hotfix-Informationen

Ein unterstützter Hotfix ist von Microsoft erhältlich. Dieser Hotfix behebt jedoch nur das Problem, welches in diesem Artikel beschrieben wird. Wenden Sie diesen Hotfix nur auf Systemen an, bei denen das in diesem Artikel beschriebene Problem auftritt. Dieser Hotfix wird möglicherweise weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir, dass für das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download zur Verfügung steht, wird es im oberen Bereich dieses Artikels einen Link "Hotfix donwload" geben. Wenn dieser Abschnitt nicht angezeigt wird, wenden Sie sich an den Microsoft Customer Service und Support, um den Hotfix zu erhalten.

Hinweis Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich sind, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die üblichen Support-Kosten gelten für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste von Microsoft Customer Service und Support-Telefonnummern oder eine separate Serviceanfrage erstellen finden Sie in der folgenden Microsoft-Website:
http://support.Microsoft.com/contactus/?WS=Support
Hinweis Das Formular "Hotfixdownload available" zeigt die Sprachen an, in denen der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, liegt es daran, dass kein Hotfix für diese Sprache verfügbar ist.

Erforderliche Komponenten

Um diesen Hotfix zu installieren, muss eines der folgenden Betriebssysteme laufen:
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Servicepack 1 (SP1)
Weitere Informationen dazu, wie Sie eine Windows 7 oder Windows Server 2008 R2 Servicepack erhalten finden Sie im folgenden Artikel der Microsoft Knowledge Base:
976932Informationen zum Servicepack 1 für Windows 7 und Windows Server 2008 R2

Registrierungsinformationen

Um den Hotfix in diesem Paket verwenden zu können, müssen Sie keine Änderungen an der Registrierung vornehmen.

Ist ein Neustart erforderlich?

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix anwenden.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine zuvor veröffentlichten Hotfix.

Dateiinformationen

Die internationale Version dieses Hotfixes installiert Dateien mit den Attributen, die in den folgenden Tabellen aufgeführt sind. Die Datumsangaben und Uhrzeiten für diese Dateien werden in Coordinated Universal Time (UTC) aufgeführt. Die Datums- und Uhrzeitangaben für diese Dateien auf dem lokalen Computer werden in Ihrer lokalen Zeit zusammen mit Berücksichtigung der aktuellen Daylight Saving Time (DST) angezeigt. Darüber hinaus können die Datums- und Uhrzeitangaben ändern, wenn Sie bestimmte Operationen auf die Dateien anwenden.
Hinweise zu den Dateiinformationen für Windows Server 2008 R2
Wichtig Windows 7-Updates und Windows Server 2008 R2-Hotfixes sind im selben Paket enthalten. Allerdings werden Updates auf der Seite Hotfix Anforderung unter beiden Betriebssystemen aufgelistet. Um das Hotfix-Paket anzufordern, das auf eine oder beide Betriebssysteme angewendet wird, wählen Sie den Hotfix, der auf der Seite unter "Windows 7/Windows Server 2008 R2" aufgelistet ist. Bezieht sich immer auf den Abschnitt "Beziehen sich auf" in Artikel, um das aktuelle Betriebssystem bestimmen, dem jeden Hotfix gilt.
  • Die Dateien, die für ein bestimmtes Produkt, SR_Level (RTM, SP geltenn), und Servicebereiche (LDR, GDR) identifiziert werden kann, indem Sie die Versionsnummern der Datei untersuchen, wie in der folgenden Tabelle dargestellt.
    Tabelle minimierenTabelle vergrößern
    VersionProduktSR_LevelServicebereich
    6.1.760 0 . 16xxxWindows Server 2008 R2RTMGDR
    6.1.760 0 . 21xxxWindows Server 2008 R2RTMLDR
    6.1.760 1 . 17xxxWindows Server 2008 R2SP1GDR
    6.1.760 1 . 21xxxWindows Server 2008 R2SP1LDR
  • Die MANIFESTEN-Dateien (. manifest) und MUM-Dateien (.mum), die installiert werden für jede Umgebung sind separat aufgeführt im Abschnitt "Weitere Dateiinformationen für Windows Server 2008 R2". MUM- und MANIFEST-Dateien sowie die zugehörigen Sicherheitskatalogdateien (.cat) Dateien sind äußerst wichtig, den Status der aktualisierten Komponenten verwalten. Die Sicherheitskatalogdateien, für die die Attribute nicht aufgelistet sind, sind mit einer digitalen Microsoft-Signatur signiert.
Für alle unterstützten X 64-basierten Versionen von Windows Server 2008 R2
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Rdpinit.exe6.1.7601.21864178,68822-Nov-201106: 23x64
Rdpinit.MOFNicht zutreffend1.19705-Nov-201002: 01Nicht zutreffend
Rdpshell.exe6.1.7601.21864300,03222-Nov-201106: 23x64
Rdpshell.MOFNicht zutreffend1.20005-Nov-201002: 01Nicht zutreffend
Tserrredir.dll6.1.7601.1751413.31220-Nov-201013: 27x64
Rdpinit.exe6.1.7601.21864178,68822-Nov-201106: 23x64
Rdpinit.MOFNicht zutreffend1.19710-Jun-200920: 44Nicht zutreffend
Rdpshell.exe6.1.7601.21864300,03222-Nov-201106: 23x64
Rdpshell.MOFNicht zutreffend1.20010-Jun-200920: 44Nicht zutreffend
TerminalServices-Remoteapplications-Clientsku-ppdlic.xrm-msNicht zutreffend3.06722-Nov-201106: 42Nicht zutreffend
Tserrredir.dll6.1.7600.1638513.31214-Jul-200901: 41x64
Rdpinit.exe6.1.7601.21864162,30422-Nov-201105: 23X 86
Rdpinit.MOFNicht zutreffend1.19705-Nov-201002: 01Nicht zutreffend
Rdpshell.exe6.1.7601.21864261,63222-Nov-201105: 23X 86
Rdpshell.MOFNicht zutreffend1.20005-Nov-201002: 01Nicht zutreffend

Abhilfe

Um dieses Problem zu umgehen, melden Sie sich die Remotedesktopdienste-Sitzung die betroffenen Rdpshell.exe-Prozess verwendet wird, und klicken Sie dann erstellen Sie eine neue Sitzung.

Hinweis Um schnelle Neuverbindung zu vermeiden, können Sie erstellen eine neue Sitzung 20 Sekunden, nachdem Sie die betroffenen Remotedesktopdienste-Sitzung abgemeldet.

Status

Microsoft hat bestätigt, dass dieses Problem auf die im Abschnitt "Gilt für" aufgeführten Microsoft-Produkten zutrifft.

Weitere Informationen

Weitere Informationen zur Terminologie für Softwareupdates finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684Beschreibung der Standardterminologie, die zum Beschreiben von Microsoft-Softwareupdates verwendet wird

Weitere Dateiinformationen

Weitere Dateiinformationen für Windows Server 2008 R2

Weitere Dateien für alle unterstützten X 64-basierten Versionen von Windows Server 2008 R2
Tabelle minimierenTabelle vergrößern
DateinameAmd64_7dcb346eab4e3614579d1272522b57d7_31bf3856ad364e35_6.1.7601.21864_none_1f6cd03f68634548.Manifest
DateiversionNicht zutreffend
Dateigröße737
Datum (UTC)22-Nov-2011
Zeit (UTC)14: 57
PlattformNicht zutreffend
DateinameAmd64_d0971b1fd44738244381203d873d941b_31bf3856ad364e35_6.1.7601.21864_none_e0e4cde48005f6ac.Manifest
DateiversionNicht zutreffend
Dateigröße727
Datum (UTC)22-Nov-2011
Zeit (UTC)14: 57
PlattformNicht zutreffend
DateinameAmd64_ef15c4712d9eefb827a368c46cac8fad_31bf3856ad364e35_6.1.7601.21864_none_29956bf1e7c2bb36.Manifest
DateiversionNicht zutreffend
Dateigröße727
Datum (UTC)22-Nov-2011
Zeit (UTC)14: 57
PlattformNicht zutreffend
DateinameAmd64_microsoft-Windows-t..-remoteapplications_31bf3856ad364e35_6.1.7601.21864_none_a089d074cc474192.manifest
DateiversionNicht zutreffend
Dateigröße9,324
Datum (UTC)22-Nov-2011
Zeit (UTC)15: 40
PlattformNicht zutreffend
DateinameAmd64_microsoft-Windows-t..Lications-clientsku_31bf3856ad364e35_6.1.7601.21864_none_7d54b6c3760942f7.manifest
DateiversionNicht zutreffend
Dateigröße10,718
Datum (UTC)22-Nov-2011
Zeit (UTC)15: 40
PlattformNicht zutreffend
DateinameUpdate.mum
DateiversionNicht zutreffend
Dateigröße2,503
Datum (UTC)22-Nov-2011
Zeit (UTC)14: 57
PlattformNicht zutreffend
DateinameWow64_microsoft-Windows-t..-remoteapplications_31bf3856ad364e35_6.1.7601.21864_none_aade7ac700a8038d.manifest
DateiversionNicht zutreffend
Dateigröße6,618
Datum (UTC)22-Nov-2011
Zeit (UTC)05: 59
PlattformNicht zutreffend

Eigenschaften

Artikel-ID: 2636613 - Geändert am: Freitag, 4. Januar 2013 - Version: 2.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Datacenter
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseinter kbmt KB2636613 KbMtde
Maschinell übersetzter Artikel
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 2636613
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