Article ID: 263754 - Last Review: October 2, 2003 - Revision: 3.0

BUG: WinInet Application Stops Responding and Shows 100-Percent CPU Utilization

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SYMPTOMS

Under some conditions, a WinInet application may stop responding and show 100-percent CPU utilization. When you debug the offending application, you may see that the InternetReadFile API is causing the blocking and CPU-utilization problem.

This only happens when the server uses chunked encoding and abruptly closes a connection.

CAUSE

The problem is caused by a bug in the InternetReadFile API. Under some conditions, InternetReadFile fails to detect a connection closure and still tries to read data from the socket.

RESOLUTION

Because this problem only occurs when chunked encoding is used, you can disable chunked encoding to solve the problem. Because chunked encoding is not used with HTTP 1.0, you can work around this problem by using HTTP 1.0. To do so you must:
  1. Specify HTTP/1.0 in the HttpOpenRequest API.
  2. In Internet Explorer, from the Tools menu, click Internet Options, and then select the Advanced tab. Clear the Use HTTP 1.1 and Use HTTP 1.1 through proxy connections check boxes.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article.

REFERENCES

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
258425  (http://support.microsoft.com/kb/258425/EN-US/ ) Unable to Specify HTTP Version by Using HttpOpenRequest()
Hypertext Transfer Protocol -- HTTP/1.1 (http://www.rfc-editor.org/rfc/rfc2068.txt)



APPLIES TO
  • Microsoft Internet Explorer 4.0 128-Bit Edition
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.01
Keywords: 
kbbug KB263754
Retired KB ArticleRetired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.