Chyba: Aplikace WinInet reagovat a zobrazí využití PROCESORU 100 procent

ID článku: 263754 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Za určitých podmínek může aplikace WinInet přestat reagovat a zobrazit využití PROCESORU 100 procent. Při ladění problematický aplikace se může zobrazit, blokování a využití PROCESORU problém způsobuje API InternetReadFile.

Tato situace nastane pouze při server používá blokového kódování a náhle zavře připojení.

Příčina

Problém je způsobena chybou v InternetReadFile API. Za určitých podmínek InternetReadFile selže rozpoznat uzavření připojení a stále se pokusí číst data ze soketu.

Řešení

Protože k tomuto problému dochází pouze při použití blokového kódování, můžete zakázat blokového kódování problém vyřešit. Protože blokového kódování není použit s HTTP 1.0, můžete tento problém vyřešit pomocí HTTP 1.0. K tomu je nutné:
  1. Určete HTTP/1.0 v HttpOpenRequest API.
  2. V aplikaci Internet Explorer z nabídky Nástroje příkaz Možnosti Internetu a potom vyberte kartu Upřesnit vymazat políčka používat protokol HTTP 1.1 a použít HTTP 1.1 prostřednictvím připojení serveru proxy.

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o chybu v produktech společnosti uvedených na začátku tohoto článku.

Odkazy

Další informace naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
258425Nelze určit verze HTTP pomocí HttpOpenRequest()
Hypertext Transfer Protocol -- HTTP/1.1


Vlastnosti

ID článku: 263754 - Poslední aktualizace: 2. října 2003 - Revize: 3.0
Informace v tomto článku jsou určeny pro produkt:
  • 128bitová verze aplikace Microsoft Internet Explorer 4.0
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.01
Klíčová slova: 
kbmt kbbug KB263754 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:263754
Právní omezení pro obsah znalostní báze týkající se produktů, jejichž podpora byla ukončena
Tento článek byl napsán o produktech, pro které společnost Microsoft již neposkytuje nadále podporu. Článek je tedy nabízen v takovém stavu, v jakém je, a nebude již nadále aktualizován.

Dejte nám zpětnou vazbu