Artigo: 263754 - Última revisão: quinta-feira, 2 de Outubro de 2003 - Revisão: 3.0

Erro: A aplicação WinInet deixa de responder e mostra a utilização da CPU de 100 por cento

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Reduzir tudo

Sintomas

Em algumas circunstâncias, uma aplicação WinInet pode deixar de responder e mostrar a utilização da CPU de 100 por cento. Quando depura aplicações infractor, poderá ver que a API InternetReadFile está a causar o bloqueio e o problema de utilização da CPU.

Isto só acontece quando o servidor utiliza a codificação fragmentada e abruptamente fecha uma ligação.

Causa

O problema é causado por um erro na API InternetReadFile. Em algumas circunstâncias, InternetReadFile não conseguir detectar um encerramento de ligação e ainda tentar ler dados a partir do socket.

Resolução

Uma vez que este problema só ocorre quando a codificação fragmentada é utilizada, pode desactivar a codificação fragmentada para resolver o problema. Uma vez que a codificação fragmentada não é utilizado com o HTTP 1.0, pode contornar este problema utilizando o HTTP 1.0. Para fazer tem de:
  1. Especificar HTTP/1.0 HttpOpenRequest API.
  2. No Internet Explorer, no menu Ferramentas , clique em Opções da Internet e, em seguida, seleccione o separador ' Avançadas . limpar as caixas de verificação Utilizar HTTP 1.1 e Utilizar HTTP 1.1 através de ligações de proxy .

Ponto Da Situação

A Microsoft confirmou que este erro ocorre nos produtos da Microsoft listados no início deste artigo.

Referências

Para obter informações adicionais, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft:
258425  (http://support.microsoft.com/kb/258425/EN-US/ ) Não é possível especificar a versão de HTTP utilizando HttpOpenRequest()
Hypertext Transfer Protocol -- HTTP/1.1 (http://www.rfc-editor.org/rfc/rfc2068.txt)



A informação contida neste artigo aplica-se a:
  • Microsoft Internet Explorer 4.0 128-Bit Edition
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.01
Palavras-chave: 
kbmt kbbug KB263754 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 263754  (http://support.microsoft.com/kb/263754/en-us/ )
Retired KB ArticleExclusão de Responsabilidade para Conteúdo sem Suporte na KB
Este artigo foi escrito sobre produtos para os quais a Microsoft já não fornece suporte. Por conseguinte, este artigo é oferecido "tal como está" e deixará de ser actualizado.