Erro: O aplicativo de WinInet pára de responder e mostra a utilização de CPU de 100 por cento

ID do artigo: 263754 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Sintomas

Sob algumas condições, um aplicativo WinInet pode parar de responder e Mostrar CPU de 100 por cento. Quando você depurar o aplicativo problemático, você pode ver que a API InternetReadFile está causando o problema de utilização da CPU e bloqueio.

Isso ocorre somente quando o servidor usa a codificação em partes e abruptamente fecha uma conexão.

Causa

O problema é causado por um bug na API InternetReadFile. Sob algumas condições, InternetReadFile não conseguir detectar um fechamento de conexão e ainda tenta ler dados a partir do soquete.

Resolução

Como esse problema ocorre somente quando a codificação em partes é usado, você pode desativar a codificação em partes para resolver o problema. Como a codificação em partes não é usado com HTTP 1.0, você pode contornar esse problema usando HTTP 1.0. Para fazer isso, você deve:
  1. Especifica HTTP/1.0 em HttpOpenRequest API.
  2. No Internet Explorer, no menu Ferramentas , clique em Opções da Internet e selecione a guia Avançado limpar as caixas de seleção usar HTTP 1.1 e usar HTTP 1.1 através de conexões via proxy .

Situação

A Microsoft confirmou que esse é um problema nos produtos da Microsoft listados no começo deste artigo.

Referências

Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
258425Não é possível especificar versão HTTP por meio de HttpOpenRequest()
Hypertext Transfer Protocol -- HTTP/1.1


Propriedades

ID do artigo: 263754 - Última revisão: quinta-feira, 2 de outubro de 2003 - Revisão: 3.0
A informação contida neste artigo aplica-se a:
  • Microsoft Internet Explorer 4.0 Edição de 128 Bits
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.01
Palavras-chave: 
kbmt kbbug KB263754 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 263754
Aviso de Isenção de Responsabilidade sobre Conteúdo do KB Aposentado
Este artigo trata de produtos para os quais a Microsoft não mais oferece suporte. Por esta razão, este artigo é oferecido "como está" e não será mais atualizado.

Submeter comentários