Article ID: 2638878 - Last Review: March 26, 2012 - Revision: 2.0

Store.exe intermittently stops responding in an Exchange Server 2007 environment

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SYMPTOMS

The Microsoft Exchange Information Store service (Store.exe) intermittently stops responding in a Microsoft Exchange Server 2007 environment.

CAUSE

This issue occurs because the Store.exe process depends on the remote procedure call (RPC). The information store can use up to 500 threads to process RPC communications in an Exchange Server 2007 environment. However, there are only 100 threads in previous Exchange versions. Therefore, the antiquated RPC optimizations throttle threads when the information store tries to use all 500 threads.

RESOLUTION

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows
To have us fix this problem for you, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me



To fix this problem automatically, click the Fix it button or link. Then click Run in the File Download dialog box, and follow the steps in the Fix it wizard.


Fix this problem
Microsoft Fix it 50837


Notes
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

Then, go to the "Did this fix the problem?" section.



Let me fix it myself


To resolve this issue, delete the following registry entries, and then restart the Microsoft Exchange Information Store service:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\store.exe\RpcThreadPoolThrottle\ProrateFactor
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\store.exe\RpcThreadPoolThrottle\ProrateStart
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\store.exe\RpcThreadPoolThrottle\ProrateMax


Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support (http://support.microsoft.com/contactus) .
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me (http://blogs.technet.com/fixit4me/) " blog or send us an email (mailto:fixit4me@microsoft.com?Subject=KB) .

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Exchange Server 2007 Enterprise Edition
  • Microsoft Exchange Server 2007 Standard Edition
  • Microsoft Exchange Server 2007 Service Pack 1
  • Microsoft Exchange Server 2007 Service Pack 2
  • Microsoft Exchange Server 2007 Service Pack 3
Keywords: 
kbsurveynew kbprb kbtshoot kbexpertiseinter kbfixme kbmsifixme KB2638878