O desempenho do disco pode diminuir ao longo do tempo

Traduções de Artigos Traduções de Artigos
Artigo: 263939 - Ver produtos para os quais este artigo se aplica.
Este artigo foi publicado anteriormente em PT263939
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

O débito de entrada/saída (E/S) do disco pode diminuir ao longo do tempo devido ao tempo de que necessita depois de iniciado o computador. Depois de o débito ter diminuído, o desempenho original do disco não é recuperado até que o computador seja reiniciado.

É de realçar que a diminuição no desempenho é diferente da diminuição que ocorre quando um disco fica fragmentado. A diminuição do desempenho que é provocada pela fragmentação do disco não é recuperada quando o computador é reiniciado. Para além disso, esta diminuição no desempenho é observada com maior frequência em subsistemas de disco topo de gama que são constituídos por múltiplos eixos accionadores numa configuração RAID (Redundant Array of Inexpensive Disks).

Causa

Este problema ocorre porque o controlador Classpnp monitoriza os discos com vista a detectar sinais que possam indicar que estão com demasiada carga. As indicações internas deste tipo de carga incluem uma diversidade de erros que podem ser devolvidos por controladores de discos de nível inferior. Quando este erros ocorrem, o Classpnp desactiva progressivamente as funcionalidades de desempenho no disco para evitar gerar os erros. O algoritmo que é utilizado para decidir quando diminuir estas funcionalidades de desempenho não permite cenários que possam envolver condições de erro temporárias. Assim sendo, depois de acumular um determinado número de erros, o desempenho é diminuído deliberadamente e não é reposto para níveis normais até que o computador seja reiniciado. Isto poderá causar problemas em computadores que detectam muito poucos erros de disco mas permanecem online por longos períodos de tempo, por não existir uma opção que permite reactivar as funcionalidades de desempenho de uma forma dinâmica.

Resolução

Informações sobre Service Packs

Para resolver este problema, obtenha o Service Pack mais recente para o Windows 2000. Para obter informações adicionais, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
260910 Como obter o Service Pack mais recente do Windows 2000

Informações sobre a correcção

A Microsoft tem já disponível uma correcção, mas destina-se apenas a corrigir o problema descrito neste artigo. Aplique-a apenas em computadores que tenham este problema específico. Esta correcção poderá ser submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, a Microsoft recomenda que aguarde pelo próximo service pack do Windows 2000 que contenha esta correcção.

Para resolver este problema imediatamente, contacte o suporte técnico da Microsoft para obter a correcção. Para obter uma lista completa dos números de telefone do suporte técnico da Microsoft, bem como informações sobre os custos de suporte, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;PT;CNTACTMS
NOTA: Em casos especiais, os custos normalmente inerentes às chamadas de suporte poderão ser anulados, se um técnico de suporte da Microsoft determinar que uma actualização específica resolverá o problema. Os custos normais do suporte serão aplicados a problemas e questões de suporte adicionais, não incluídos na actualização específica em questão.

A versão inglesa desta correcção deve ter os seguintes atributos de ficheiro, ou posteriores:
   Data        Hora   Versão         Tamanho Ficheiro
   ------------------------------------------------------
   01-07-2002  17:44  5.0.2195.4809  27,952  Cdrom.sys
   11-16-2001  10:23  5.0.2195.4643  34,416  Classpnp.sys
   04-27-2002  13:10  5.0.2195.5690  29,744  Disk.sys
   09-11-2001  17:06  5.0.2195.4326  24,336  Scsikd.dll
   09-11-2001  17:06  5.0.2195.4326  11,632  Scsiprnt.sys
   01-11-2002  15:06  5.0.2195.4826  10,384  Sfloppy.sys
   02-21-2002  11:45  5.0.2195.4956  10,768  Tape.sys
				
O seguinte ficheiro está incluído no pacote mas não é instalado como parte do patch porque é apenas necessário para efeitos de depuração de kernel. Não constitui parte necessária da correcção e não necessita de ser instalado num sistema para que esse sistema funcione correctamente ou para que seja depurado.
   Data        Hora      Versão         Tamanho Ficheiro
   ---------------------------------------------------------
   09/11/2001  05:06 PM  5.0.2195.4326  24,336  Scsikd.dll
				

Como contornar

Para contornar este problema nos computadores que não têm esta correcção instalada, reinicie o computador.

Ponto Da Situação

A Microsoft confirmou que este problema ocorre nos produtos da Microsoft listados no início deste artigo. Este problema foi corrigido pela primeira vez no Microsoft Windows 2000 Service Pack 4.

Mais Informação

A lista de erros que pode resultar num desempenho desacelerado inclui os seguintes códigos de estado do bloco de pedidos SCSI (SRB, SCSI Request Block)(de realçar que estes códigos são, principalmente, do interesse dos programadores de controladores):
SRB_STATUS_COMMAND_TIMEOUT
SRB_STATUS_ABORTED
SRB_STATUS_TIMEOUT
SRB_STATUS_PHASE_SEQUENCE_FAILURE
SRB_STATUS_UNEXPECTED_BUS_FREE
SRB_STATUS_PARITY_ERROR
SRB_STATUS_ERROR
Quando o número de ocorrências de qualquer um dos erros descritos anteriormente atingir um total de quatro, o Classpnp desacelerará o desempenho limpando os seguintes sinalizadores
SRB_FLAGS_NO_QUEUE_FREEZE
SRB_FLAGS_QUEUE_ACTION_ENABLE
e definindo o seguinte sinalizador:
SRB_FLAGS_DISABLE_SYNCH_TRANSFER
Quando o número de erros acumulados atingir um total de oito, o Classpnp definirá o seguinte sinalizador:
SRB_FLAGS_DISABLE_DISCONNECT
A correcção para este problema altera o comportamento do Classpnp de forma a que reactive sucessivamente os sinalizadores de desempenho após um determinado número de E/S com êxito. Depois de completar com êxito 1 megabyte (MB) de E/S, o controlador recua para o nível inferior imediato de aceleração até que o computador volte ao estado original. O período de tempo que é necessário para regressar ao estado normal, por conseguinte, depende da quantidade de actividade em curso do disco. O caso típico consiste numa combinação de E/S efectuadas com êxito e sem êxito durante os períodos de transição (normal, diminuição e diminuição, normal), pelo que o computador alterna entre o modo desacelerado e em execução livre várias vezes antes de fixar quais são as funcionalidades que permitem obter o melhor desempenho.

Para obter informações adicionais sobre como obter uma correcção para o Windows 2000 Datacenter Server, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
265173 The Datacenter Program and Windows 2000 Datacenter Server Product
Para obter informações adicionais sobre como instalar várias correcções com um único reinício, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
296861Como instalar múltiplas actualizações ou correcções do Windows com apenas um reinício do computador
Para obter informações adicionais sobre como instalar o Windows 2000 e as correcções do Windows 2000 ao mesmo tempo, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
249149 Instalar o Microsoft Windows 2000 e as correcções do Windows 2000

Propriedades

Artigo: 263939 - Última revisão: 13 de abril de 2006 - Revisão: 4.0
A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Service Pack 1
  • Microsoft Windows 2000 Service Pack 2
  • Microsoft Windows 2000 Service Pack 2
  • Microsoft Windows 2000 Service Pack 1
Palavras-chave: 
kbbug kbfix kbwin2000presp4fix kbqfe kbenv kboswin2000fix kbwin2ksp4fix kbhotfixserver KB263939

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com