The Solution Activity Feeds cannot be deleted error when deleting the Microsoft Dynamics CRM Activity Feeds Solution

This article provides a resolution for the Solution Activity Feeds cannot be deleted error that occurs when you try to remove the Microsoft Dynamics CRM Activity Feeds Solution.

Applies to:   Microsoft Dynamics CRM 2011
Original KB number:   2639637

Symptoms

When you try to delete the Microsoft Dynamics CRM Activity Feeds Managed Solution (ActivityFeeds) solution from Microsoft Dynamics CRM 2011, an error is displayed. When selecting the Details link, the report indicates the following message:

The Solution Activity Feeds cannot be deleted. The following components are required by other components in the system.

Cause

Creating and deleting the Activity Feeds Configuration items triggers a solution-specific plugin that has managed dependencies on the entities where they are enabled.

Resolution

To fix this issue, follow these steps:

  1. Determine the version of the Activity Feeds solution that is currently installed in the system. This can be performed by completing the following steps:

    • In Microsoft Dynamics CRM, select Settings, and then select Solutions.
    • In the All Solutions grid, note the Version number column associated with the Activity Feeds Managed Solution.
  2. Ensure that the Managed SDK Message Processing Steps for Activity Feeds Managed Solution are disabled when manually trying to resolve the issue. See steps 2-4 in the More information section for details on enabling the appropriate Managed SDK Message Processing Steps.

  3. Navigate to Settings and select Activity Feeds Configuration.

  4. Using the version information gathered in step 1, complete one of the following tasks:

    • If the version of Activity Feeds is less than 1.0.3, select all of the Activity Feeds Configuration records and select Delete.
    • If the version of Activity Feeds is greater than 1.0.3, select all of the Activity Feeds Configuration records and select Disable.
  5. Select Publish All Customizations.

  6. After performing the steps, the Activity Feeds Managed Solution can be deleted.

More information

In an environment where the Managed SDK Message Processing Steps for the Activity Feeds Solution are disabled prior to deleting the Activity Feeds Configuration records, the dependency error may still occur. This will occur as the Activity Feeds Solution has SDK Message Processing Steps that need to be enabled to appropriately clean up entity dependencies on deletion of the Activity Feeds Configuration records.

To resolve this issue, follow the steps below:

  1. After the failed attempt to delete the Activity Feeds Managed Solution select the Details link, on the failure popup window. This report contains the Dependency Details that were the cause of the solution not getting deleted. After opening sort the contents by Type. Take note of each entity form that has a dependency on the Activity Feeds Managed Solution for later use.

  2. Navigate to Settings, select Customizations, select Customize the System and select SDK Message Processing Steps.

  3. Change the grid view to All and then sort by State column.

  4. Enable all Managed plugins that have ActivityFeeds.Plugins in the Name.

  5. Navigate to Settings, select Activity Feeds Configuration and then select New.

  6. Create a Post Configuration record for each of the entities noted in step 1.

    Note

    The Entity Name specified when creating the Post Configuration record must be the entity schema name. For example the User entity schema name is systemuser and Case entities schema name is incident. The schema name for any entity can be found in Settings > Customizations > Customize the System > Expand Entities, and choosing the entity from the list.

  7. Navigate to Settings, select Solutions and then select Publish All Customizations.

  8. Navigate to Settings, select Solutions, mark the ActivityFeeds solution and select Delete.

Note

The Activity Feeds Solution cannot be uninstalled in Microsoft Dynamics CRM Online or in Microsoft Dynamics CRM 2011 On Premise deployments utilizing Update Rollup 12 or greater.