Um ou mais objetos não sincronizar ao usar a ferramenta de sincronização de diretório ativo do Azure

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PROBLEMA

Um ou mais objetos de serviços de domínio Active Directory (AD DS) ou atributos não sincronizar paraMicrosoft Azure Active Directory (AD Azure) conforme o esperado. Quando executa a sincronização do Active Directory, um objeto não sincronizar e você enfrentar um dos seguintes sintomas:
  • Você recebe uma mensagem de erro afirmando que um atributo tem um valor duplicado.
  • Você recebe uma mensagem de erro afirmando que um ou mais atributos violam os requisitos de formatação, como o conjunto de caracteres ou de caracteres.
  • Você não recebe uma mensagem de erro e sincronização de diretório parece ser concluída. No entanto, alguns objetos ou atributos não são atualizados conforme o esperado.
Alguns exemplos da mensagem de erro pode ser exibida incluem o seguinte:
  • Um objeto sincronizado com o mesmo endereço de proxy já existe no diretório do Microsoft Online Services.
  • Não é possível atualizar este objeto porque o ID do usuário não foi encontrado.
  • Não é possível atualizar este objeto no Microsoft Online Services porque os seguintes atributos associados a este objeto tem valores que já esteja associados a outro objeto no diretório local.

CAUSA

Esse problema ocorre por um dos seguintes motivos:
  • O valor de domínio é usado pelos atributos do AD DS ainda não foi verificado.
  • Um ou mais atributos de objeto que requerem um valor exclusivo tem um valor de atributo duplicado (como o proxyAddresses atributo ou a UserPrincipalName o atributo) em uma conta de usuário.
  • Um ou mais atributos de objeto violam os requisitos de formatação que restringem os caracteres e o comprimento de caracteres de valores de atributo.
  • Um ou mais atributos de objeto correspondem a regras de exclusão para sincronização de diretórios.

    A tabela a seguir mostra a sincronização padrão regras de escopo:
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    Tipo de objetoNome do atributoCondição do atributo quando a sincronização falhar
    ContatoDisplayNameContém "MSOL"
    msExchHideFromAddressListsÉ definido como "True"
    Grupo de segurançaisCriticalSystemObjectÉ definido como "True"
    Grupos habilitados para email
    (lista de distribuição ou grupo de segurança)
    proxyAddresses

    e

    email
    Não possui "SMTP:" entrada de endereço

    e

    não está presente
    Contatos habilitados para emailproxyAddresses

    e

    email
    Não possui "SMTP:" entrada de endereço

    e

    não está presente
    iNetOrgPersonsAMAccountNameNão está presente
    isCriticalSystemObjectEstá presente
    UsuáriomailNickNameComeça com "SystemMailbox"
    mailNickNameComeça com "CAS_"

    e

    contém "{"
    sAMAccountNameComeça com "CAS_"

    e

    contém "}"
    sAMAccountNameÉ igual a "SUPPORT_388945a0"
    sAMAccountNameÉ igual a "MSOL_AD_Sync"
    sAMAccountNameNão está presente
    isCriticalSystemObjectÉ definido como "True"
  • O nome de usuário principal (UPN) foi alterado após a sincronização inicial e deve ser atualizado manualmente.
  • Endereços do Exchange Online SMTP Simple Mail Transfer Protocol () dos usuários sincronizados não estiverem devidamente preenchidos no esquema do Active Directory local.

SOLUÇÃO

Para resolver esse problema, use um dos seguintes métodos, conforme for apropriado para sua situação.

Resolução 1: Executar IdFix para verificar se há duplicatas, ausência de atributos e violações de regra

Use o Ferramenta de correção de erros de IdFix DirSyncpara localizar objetos e erros que impeçam a sincronização com o Azure AD.
  • Se você vir "Em branco" na coluna erro após executar IdFix, consulte o seguinte artigo da Base de Conhecimento Microsoft:
    2857349 "Em branco" é exibido na coluna erro para um ou mais objetos depois de executar a ferramenta de IdFix
  • Se você vir "Formato" na coluna erro depois de executar o IdFix, consulte o seguinte artigo da Base de Conhecimento Microsoft:
    2857351 "Formato" é exibido na coluna erro para um ou mais objetos depois de executar a ferramenta de IdFix
  • Se você vir "Caractere" na coluna erro depois de executar o IdFix, consulte o seguinte artigo da Base de Conhecimento Microsoft:
    2857352 "Caractere" é exibido na coluna erro para um ou mais objetos depois de executar a ferramenta de IdFix
  • Se você vir "Duplicata" na coluna erro depois de executar o IdFix, consulte o seguinte artigo da Base de Conhecimento Microsoft:
    2857385 "Duplicadas" é exibida na coluna erro para um ou mais objetos depois de executar a ferramenta de IdFix

Solução 2: Usar a ferramenta de OnRamp do Office 365

Para obter informações sobre atributos inválidos usando a ferramenta de OnRamp do Office 365, siga estas etapas:
  1. Em um computador associado a um domínio, vá para o seguinte site da Microsoft e siga as instruções na página:
    https://onramp.office365.com/OnRamp/
  2. No relatório, localize a seção usuários e grupos para exibir os detalhes dos problemas do atributo podem causar problemas de sincronização. A screen shot a seguir mostra um exemplo da seção verificações no ambiente do relatório:

    Recolher esta imagemExpandir esta imagem
    Captura de tela do relatório de verificações ambientais

Resolução 3: Use o diagnóstico do Microsoft Online Services e Toolkit de suporte de registro (MOSDAL)

Para obter informações sobre atributos inválidos usando o Toolkit de suporte MOSDAL, execute essas etapas:
  1. Baixe e instale o Toolkit de suporte MOSDAL da Microsoft Download Center:
    MOSDAL (Diagnóstico de Microsoft Online Services e log) suporte Toolkit
  2. Executar o Toolkit de suporte MOSDAL, selecione Single Sign On (SSO)e, em seguida, clique em Avançar.
  3. Quando você for solicitado para inserir suas credenciais, digite sua ID de usuário e, em seguida, clique em Avançar. Sua senha não serão salvas e é usada somente para simular uma tentativa de autenticação e registrar os resultados.
  4. Na tela de reproduzir o problema, clique em Avançar.
  5. Quando o relatório for concluído, localize o arquivo MOSDALREPORT.zip na biblioteca de Documents\MOSDAL. Os arquivos de relatórios que contêm informações sobre atributos inválidos estão localizados no seguinte arquivo:
    MOSDALREPORT\Admin_Applications\Directory_Synchronization_Tool\DirSyncObjects.XML
Determine conflitos de atributo são causados por objetos que não foram criados no Azure AD por meio da sincronização de diretório

Para determinar os conflitos de atributo que são causados por objetos de usuário que foram criados usando as ferramentas de gerenciamento (e que não foram criados no Azure AD por meio da sincronização de diretório), siga estas etapas:
  1. Determinar os atributos exclusivos das instalações conta de usuário do AD DS. Para fazer isso, em um computador que tenha as ferramentas de suporte do Windows instalado, execute estas etapas:
    1. Clique em Iniciar, Executar, tipo Ldp.exee, em seguida, clique em OK.
    2. Clique em Connection, clique em Conectar, digite o nome do computador de um controlador de domínio do AD DS e, em seguida, clique em OK.
    3. Clique em Connection, clique em vinculare, em seguida, clique em OK.
    4. Clique em Exibir, clique em Modo de exibição de árvore, selecione o domínio do AD DS na lista suspensa BaseDN e, em seguida, clique em OK.
    5. No painel de navegação, localize e clique duas vezes no objeto que não está sincronizando corretamente. O painel de detalhes no lado direito da janela lista todos os atributos de objeto. O exemplo a seguir mostra os atributos de objeto:

      Recolher esta imagemExpandir esta imagem
      Captura de tela dos atributos de objeto
    6. Registre os valores de atributo userPrincipalName e cada endereço SMTP no atributo proxyAddresses de múltiplos valores. Mais tarde, você terá esses valores.
      Recolher esta tabelaExpandir esta tabela
      Nome do atributo Exemplo Observações
      proxyAddresses (3) proxyAddresses: X500: / o = Exchange/ou = grupo administrativo do Exchange (FYDIBOHF23SPDLT) / cn = Recipients/cn = 1ae75fca0d3a4303802cea9ca50fcd4f-7628376; SMTP:7628376@Service.contoso.com; SMTP:7628376@contoso.com;
      • O número é exibido entre parênteses ao lado do rótulo de atributo indica o número de valores de endereço de proxy no atributo de valores múltiplos.
      • Cada valor de endereço de proxy distinta é indicada por um ponto e vírgula (;).
      • O valor de endereço de proxy SMTP principal é indicado por letras maiúsculas "SMTP:"
      userPrincipalName 7628376@contoso.com
      Observação Ldp.exe está incluído no Windows Server 2008 e no Windows Server 2003 Support Tools. As ferramentas de suporte do Windows Server 2003 estão incluídos na mídia de instalação do Windows Server 2003. Ou, para obter as ferramentas de suporte, visite o seguinte site da Microsoft:
      Ferramentas de suporte de 32 bits do Windows Server 2003 Service Pack 2
  2. Conectar-se ao AD Azure usando o Azure Active Directory módulo para Windows PowerShell. Para obter mais informações, vá paraGerenciar o AD Azure usando o Windows PowerShell.

    Deixe a janela do console aberto. Você precisará usá-lo na próxima etapa.
  3. Verifique se os atributos de duplicar userPrincipalName .

    Na conexão de console que você abriu na etapa 2, digite os seguintes comandos na ordem em que são apresentadas e, em seguida, pressione Enter após cada comando:
    • $userUPN = "<search UPN>"
      Observação Neste comando, o espaço reservado para "<search upn="">" representa o atributo UserPrincipalName que você anotou na etapa 1f.<b00> </b00> </search>
    • get-MSOLUser ?UserPrincipalName $userUPN | where {$_.LastDirSyncTime -eq $null} 
    Deixe a janela do console aberto. Você vai usá-lo novamente na próxima etapa.
  4. Verificar os atributos duplicados proxyAddresses . Na conexão de console que você abriu na etapa 2, digite os seguintes comandos na ordem em que são apresentadas e, em seguida, pressione Enter após cada comando:
    • $SessionExO = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri https://outlook.office365.com/powershell-liveid/ -Credential $Cred -Authentication Basic - AllowRedirection
    • Import-PSSession $sessionExO -prefix:Cloud 
  5. Para cada entrada de endereço de proxy que você anotou na etapa 1f, digite os seguintes comandos na ordem em que são apresentadas e, em seguida, pressione Enter após cada comando:
    • $proxyAddress = "<search proxyAddress>" 
      Observação Neste comando, o espaço reservado para "<search proxyaddress="">" representa o valor de um atributo proxyAddresses que você anotou na etapa 1f.<b00> </b00> </search>
    • get-cloudmailbox | where {[string] $str = ($_.EmailAddresses); $str.tolower().Contains($proxyAddress.tolower()) -eq $true} | foreach {get-MSOLUser -UserPrincipalName $_.MicrosoftOnlineServicesID | where {($_.LastDirSyncTime -eq $null)}} 
Itens que são devolvidos após executar os comandos na etapa 3 e 4 representam objetos de usuário que não foram criados por meio da sincronização de diretório e que têm atributos que entram em conflito com o objeto que não está sincronizando corretamente.

Resolução 4: Atributos de atualização AD DS remover duplicatas, violações de regras e exclusões de escopo

Identificar os atributos específicos que estão impedindo a sincronização com base nas seguintes informações:
  • Mensagens de e-mail administrativo
  • O relatório da saída da ferramenta de preparação de implantação do Office 365
  • Regras de escopo de sincronização de diretório e regras personalizadas padrão
Depois que um valor de atributo específico for identificado, use a ferramenta Active Directory Users and Computers para editar o valor do atributo. Para fazer isso, siga estes passos:
  1. Abra o Active Directory Users and Computers e, em seguida, selecione o nó raiz do domínio do AD DS.
  2. Clique em modo, e, em seguida, certifique-se de que o recursos avançados opção é selecionada.
  3. No painel de navegação à esquerda, localize o objeto de usuário, clique sobre ela e, em seguida, clique em Propriedades.
  4. Na guia Editor de objetos , localize o atributo desejado, clique em Editare, em seguida, edite o valor do atributo para o valor que você deseja.
  5. Clique em OK duas vezes.
Ou, você pode usar o Active Directory Service Interfaces (ADSI) Edit para atualizar atributos de objeto no AD DS. Você pode baixar e instalar o ADSI Edit como parte do Toolkit de servidor Windows. Para usar o ADSI Edit para editar atributos, siga estas etapas.

AvisoEste procedimento requer o ADSI Edit. Usando o ADSI Edit incorretamente pode causar sérios problemas que talvez exijam a reinstalação do sistema operacional. Microsoft não pode garantir que problemas resultantes do uso incorreto do ADSI Edit possam ser resolvidos. Use o ADSI Edit por seu próprio risco.
  1. Clique em Iniciar, Executar, tipo ADSIEdit. msce, em seguida, clique em OK.
  2. Clique com o botão ADSI Edit no painel de navegação, clique em Conectare, em seguida, clique em OK para carregar a partição de domínio.
  3. Localize o objeto de usuário, clique sobre ela e, em seguida, clique em Propriedades.
  4. No atributos lista, localize o atributo desejado, clique em Editare, em seguida, edite o valor do atributo para o valor que você deseja.
  5. Clique em OK duas vezes e, em seguida, sair ADSI Edit.

Resolução 5: Usar SMTP correspondentes para fazer com que um objeto de usuário local para a sincronização com um objeto de usuário existente

Para fazer isso, consulte o seguinte artigo do Microsoft Knowledge:
2641663 Como usar o SMTP correspondentes para coincidir com as contas de usuário a contas de usuário do Office 365 para sincronização de diretórios locais

Resolução 6: Atualizar manualmente uma conta de usuário UPN

Para atualizar uma UPN licenciado após a ocorrência de sincronização de diretório inicial da conta de usuário, siga estas etapas:
  1. Clique em Iniciar, clique em Todos os programas, clique em Active Directory do Windows Azuree, em seguida, clique em Windows Azure Active Directory módulo para Windows PowerShell.
  2. Execute os cmdlets a seguir no prompt do Windows PowerShell:
    1. $cred = get-credential
      Observação Quando você for solicitado, insira suas credenciais de administrador.
    2. Connect-MSOLService
    3. Set-MsolUserPrincipalName -UserPrincipalName [CurrentUPN] -NewUserPrincipalName [NewUPN]

Resolução 7: Atualizar endereços SMTP de usuário usando atributos do Active Directory no local

Quando atributos de SMTP não estão sincronizados com o Exchange Online de maneira esperada, talvez você precise atualizar os atributos do Active Directory local. Para atualizar atributos do local do Active Directory para que o endereço de e-mail correto é exibido no Exchange on-line, use a resolução 2 para manipular os atributos que estão listados na tabela a seguir.
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Nome do atributo local do Active DirectoryValor de atributo do Active Directory local de exemploEndereços de e-mail Exchange Online de exemplo
proxyAddressesSMTP:user1@contoso.comSMTP principal: user1@contoso.com
SMTP secundário: user1@contoso.onmicrosoft.com
proxyAddressesSMTP:user1@contoso.comSMTP principal: SMTP secundário user1@contoso.onmicrosoft.com: user1@contoso.com
proxyAddressesSMTP:user1@contoso.com
SMTP:User1@sub.contoso.com
SMTP principal: user1@contoso.com
SMTP secundário: user1@sub.contoso.com
SMTP secundário: user1@contoso.onmicrosoft.com
emailUser1@contoso.comSMTP principal: user1@contoso.com
SMTP secundário: user1@contoso.onmicrosoft.com
UserPrincipalNameUser1@contoso.comSMTP principal: user1@contoso.com
SMTP secundário: user1@contoso.onmicrosoft.com
A entrada de endereço de roteamento de E-mail on-line Microsoft (MOERA) que está associado o domínio padrão (por exemplo, user1@contoso.onmicrosoft.com) é um valor interpretado com base no alias de uma conta de usuário. Esse endereço de e-mail do specialty é intrinsecamente vinculado para cada destinatário do Exchange Online, e você não pode gerenciar, excluir ou criar endereços adicionais de MOERA para qualquer destinatário. No entanto, o endereço MOERA pode ser substituído como o endereço SMTP principal usando os atributos no objeto de usuário do Active Directory local.

Observação A presença de dados no atributo proxyAddresses mascara completamente a dados no atributo de email para preenchimento de endereço de e-mail on-line do Exchange.

Observação A presença de dados no atributo proxyAddresses , o atributo de email ou ambos completamente atributos dados de UserPrincipalName máscara de população de endereço de e-mail on-line do Exchange. O UPN pode ser usado para gerenciar endereços de e-mail. No entanto, um administrador pode optar por gerenciar o endereço de email e UPN separadamente preenchendo atributos proxyAddresses ou email .

É altamente recomendável um desses atributos seja usado consistentemente para gerenciar endereços de e-mail on-line do Exchange para usuários sincronizados.

OBTER MAIS INFORMAÇÕES

Os comandos do Windows PowerShell que são mencionados neste artigo exigem o Azure Active Directory módulo para Windows PowerShell. Para obter mais informações sobre o Azure Active Directory módulo para Windows PowerShell, vá paraGerenciar o AD Azure usando o Windows PowerShell.

Para obter mais informações sobre a filtragem de sincronização de diretório por atributos, consulte o artigo do wiki TechNet followingMicrosoft:
Lista de atributos que são sincronizadas pela ferramenta de sincronização do Azure Active Directory
Ainda precisa de ajuda? Vá para o Comunidade do Office 365site ou oFóruns do Azure do Active Directory no site da Web.

Propriedades

ID do artigo: 2643629 - Última revisão: quarta-feira, 2 de julho de 2014 - Revisão: 23.0
A informação contida neste artigo aplica-se a:
  • Microsoft Azure
  • Microsoft Office 365
  • Microsoft Office 365 for enterprises (pre-upgrade)
  • Microsoft Office 365 for education  (pre-upgrade)
  • Windows Intune
  • CRM Online via Office 365 E Plans
  • Microsoft Azure Recovery Services
  • Office 365 Identity Management
Palavras-chave: 
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Clique aqui para ver a versão em Inglês deste artigo: 2643629

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