"Sorry, but we're having trouble signing you in" and "80041317" or "80043431" error when a federated user tries to sign in to Office 365, Windows Azure, or Windows Intune

Article translations Article translations
Article ID: 2647020 - View products that this article applies to.
Expand all | Collapse all

PROBLEM

When a federated user tries to sign in to a Microsoft cloud service such as Office 365, Windows Azure, or Windows Intune from a sign-in webpage whose URL starts with "https://login.microsoftonline.com/login," authentication for that user fails. Additionally, the user receives the following error message:
Sorry, but we're having trouble signing you in

Please try again in a few minutes. If this doesn't work, you might want to contact your admin and report the following error:
80041317 or 80043431

CAUSE

This issue occurs when the configuration settings of the federated domain for the on-premises Active Directory Federation Services (AD FS) service and for the Windows Azure Active Directory (Windows Azure AD) authentication system are mismatched. This causes the claim that the AD FS service supplies to be malformed and therefore rejected by the Windows Azure AD authentication system. 

Note This can occur after the token-signing certificate is renewed on-premises without updating federation trust data.

To verify that this is the cause of the issue that you're experiencing, follow these steps on a domain-joined computer:
  1. Verify the mismatched attribute between the AD FS service and the Microsoft cloud service. To do this, follow these steps:
    1. Click Start, click All Programs, click Windows Azure Active Directory, and then click Windows Azure Active Directory Module for Windows PowerShell.
    2. At the command prompt, type the following commands. Make sure that you press Enter after you type each command:
      1. $cred = get-credential

        Note When you're prompted, enter your cloud service admin credentials.
      2. Connect-MSOLService –credential:$cred
      3. Set-MSOLADFSContext –Computer:<AD FS 2.0 Server Name>

        Note In this command, the placeholder <AD FS 2.0 Server Name> represents the Windows host name of the primary AD FS server.
      4. Get-MsolFederationProperty -domainname: <Federated Domain Name>

        Note In this command, the <Federated Domain Name> placeholder represents the name of the domain that's already federated with the cloud service for single sign-on (SSO).

      Note
      The command output is divided into the following two sections:
      • The first line of the first section reads "Source: AD FS Server" and represents the configuration that's stored in the local AD FS service.
      • The first line of the second section reads "Source: <Microsoft cloud service>" and represents the configuration that's stored in the identity service.
      The output resembles the following:

      Collapse this imageExpand this image
      Screen shot of output result
  2. Compare the values of each attribute in the two sections to determine whether the values are mismatched. If the values are mismatched, the federated domain configuration has to be updated.

SOLUTION

To resolve this issue, use one of the following methods:

Method 1: Update the configuration of the federated domain
For more information about how to do this, see the "How to update the configuration of the Office 365 federated domain" section of the following article in the Microsoft Knowledge Base:
2647048 How to update or to repair the configuration of the Office 365 federated domain

Method 2: Repair the configuration of the federated domain
If method 1 doesn't resolve the issue, try to repair the federated trust. For more information about how to do this, see the "How to repair the configuration of the Office 365 federated domain" section of the following article in the Microsoft Knowledge Base:
2647048 How to update or to repair the configuration of the Office 365 federated domain

Method 3: Manually update the attributes by using the Windows Azure Active Directory Module for Windows PowerShell
If methods 1 and 2 don't resolve the issue, try to manually update the mismatched attributes. In the Windows PowerShell connection that you used to diagnose the issue, run the appropriate cmdlet from the following table:
Collapse this tableExpand this table
Mismatched attributesError codeCommand to update attributeNotes
FederationServiceIdentifier80043431
Set-MSOLDomainFederationSettings -domainname <Domain.suffix> -issueruri <newURI>
The placeholder <Domain.suffix> represents the federated domain name.

The placeholder <newURI> represents the URI value of the on-premises FederationServiceIdentifier attribute (listed first in the output of the Get-MsolFederationProperty cmdlet).

Still need help? Go to the Office 365 Community website or the Windows Azure Active Directory Forums website.

Properties

Article ID: 2647020 - Last Review: November 13, 2013 - Revision: 17.0
Applies to
  • Windows Azure
  • Microsoft Office 365
  • Microsoft Office 365 for enterprises (pre-upgrade)
  • Microsoft Office 365 for education  (pre-upgrade)
  • CRM Online via Office 365 E Plans
  • Windows Azure Recovery Services
Keywords: 
o365 o365a o365062011 pre-upgrade o365e kbgraphxlink o365022013 after upgrade o365m kbgraphic KB2647020

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com