Attributi duplicati o non validi impediscono la sincronizzazione delle directory in Office 365

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In questo articolo viene descritto Microsoft Office 365, anteprima di Microsoft Office 365 e precedente l'aggiornamento Microsoft Office 365. Le informazioni sull'anteprima di Office 365 in questo articolo vengono fornite e sono soggette a modifiche senza preavviso. Sono inclusi tutti i collegamenti.

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PROBLEMA

In Microsoft Office 365, un amministratore riceve il seguente avviso di messaggio di posta elettronica al termine della sincronizzazione delle directory:
Da: MSOnlineServicesTeam@MicrosoftOnline.com
Oggetto: Segnalazione errori sincronizzazione Directory
La segnalazione di errori nel messaggio di posta elettronica può contenere uno o più dei seguenti messaggi di errore:
  • Esiste già un oggetto sincronizzato con lo stesso indirizzo proxy nella directory di Microsoft Online Services.
  • Impossibile aggiornare questo oggetto perché l'ID utente non viene trovato.
  • Impossibile aggiornare l'oggetto in Microsoft Online Services perché i seguenti attributi associati all'oggetto sono valori che possono essere già associati a un altro oggetto nella directory locale.

CAUSA

Questo problema può verificarsi se gli oggetti utente nello schema di servizi di dominio Active Directory (AD DS) locale duplicato o alias valori non validi e se questi oggetti utente non vengono sincronizzati dallo schema di Active Directory a Office 365 correttamente durante la sincronizzazione delle directory.

Tutti i valori di alias di Office 365 devono essere univoci per una determinata organizzazione. Anche se si dispongono di più suffissi univoci dopo il simbolo di chiocciola (@) dell'indirizzo di Simple Mail Transfer Protocol (SMTP), tutti i valori di alias devono essere univoci.

In un ambiente locale, è possibile alias valori sono gli stessi sono univoci in base a suffissi dopo il simbolo di chiocciola (@) dell'indirizzo SMTP.

Se si creano oggetti con valori di alias duplicato nel cloud per Office 365, per rendere gli alias univoco, un alias è un numero univoco aggiunto. (Ad esempio, se i valori di alias duplicato "Albert", uno di essi diventa "Albert2" automaticamente. Se "Albert2" è già in uso, l'alias diventa "Albert3" e così via.) Tuttavia, se vengono creati oggetti che contengono valori duplicati alias nei propri locali un conflitto di oggetto Active Directory, si verifica quando viene eseguita la sincronizzazione delle directory, e l'oggetto sincronizzazione ha esito negativo.

SOLUZIONE

Per risolvere il problema, determinare i valori duplicati e i valori in conflitto con altri oggetti di Active Directory. A tale scopo, è possibile utilizzare lo strumento di preparazione distribuzione di Office 365 oppure Microsoft Online Services Diagnostics e Toolkit di supporto di registrazione (MOSDAL).

Metodo 1: Utilizzare lo strumento di preparazione distribuzione di Office 365

Per ottenere informazioni sugli attributi non validi utilizzando lo strumento di preparazione distribuzione di Office 365, attenersi alla seguente procedura:
  1. In un computer appartenente al dominio, scaricare lo strumento di conformità di Office 365 distribuzione dal seguente sito Web Microsoft:
    http://community.office365.com/en-us/f/183/p/2285/8155.aspx
  2. Estrarre il file compresso e quindi eseguire il file seguente:
    Office365DeploymentReadinessTool.exe
    Nota. Office 365 distribuzione Readiness Tool analizza l'ambiente di dominio per blocchi di distribuzione di Office 365 e visualizza un report dei risultati in una pagina Web.
  3. Nel report, individuare il Pulitura di Active Directorysezione per visualizzare l'elenco dei problemi relativi ad attributi che possono causare problemi di sincronizzazione. Nella schermata riportata di seguito viene illustrato un esempio delPulitura di Active Directory sezione del report:
    Riduci l'immagineEspandi l'immagine

Metodo 2: Utilizzare il Toolkit di supporto MOSDAL

Per ottenere informazioni sugli attributi non validi mediante il Toolkit di supporto MOSDAL, attenersi alla seguente procedura:
  1. Scaricare e installare il Toolkit di supporto MOSDAL dal sito Web Microsoft riportato di seguito:
    http://www.microsoft.com/download/en/details.aspx?ID=626
  2. Eseguire il Toolkit di supporto MOSDAL, selezionare Single Sign-On (SSO) dall'elenco dei servizi di Office 365 e quindi fare clic su Successivo.
  3. Quando viene richiesto di immettere le credenziali, immettere l'ID utente e quindi fare clic su Successivo. La password non viene salvata e viene utilizzata solo per simulare un tentativo di autenticazione e i risultati registrati.
  4. Nella schermata di riprodurre problema, fare clic su Successivo.
  5. Al termine del report, individuare il file MOSDALREPORT.zip nella libreria Documents\MOSDAL. Si trovano i file di report che contengono informazioni sugli attributi non validi nel file MOSDALREPORT\Admin_Applications\Directory_Synchronization_Tool\DirSyncObjects.xml.

Determinare conflitti di attributo sono causati da oggetti che non sono stati creati in Active Directory di Windows Azure tramite la sincronizzazione delle directory

Per determinare i conflitti di attributo sono causati da oggetti utente creati utilizzando gli strumenti di gestione di Office 365 (e che non sono stati creati in Active Directory di Windows Azure tramite la sincronizzazione delle directory), attenersi alla seguente procedura:
  1. Determinare gli attributi univoci di on-premise account utente di Active Directory. Per farlo, in un computer con installati gli strumenti di supporto di Windows, attenersi alla seguente procedura:
    1. Fare clic Inizio, fare clic su Eseguire, tipo Ldp.exe, quindi fare clic su OK.
    2. Fare clic Connessione, fare clic su Connettersi, digitare il nome del computer di un controller di dominio Active Directory e quindi fare clic su OK.
    3. Fare clic Connessione, fare clic su Associazione, quindi fare clic su OK.
    4. Fare clic Visualizzazione, fare clic su Visualizzazione struttura ad albero, selezionare il dominio di Active Directory nel BaseDN elenco a discesa, quindi fare clic su OK.
    5. Nel riquadro di spostamento individuare e fare doppio clic sull'oggetto che non è la sincronizzazione in modo corretto. Nel riquadro dettagli sul lato destro della finestra sono elencati tutti gli attributi di oggetto. Nell'esempio seguente vengono illustrati gli attributi dell'oggetto:

      Riduci l'immagineEspandi l'immagine
    6. Registrare i valori del userPrincipalName attributo e ogni indirizzo SMTP nel multivalore proxyAddresses attributo. Questi valori è necessario in un secondo momento.
      Riduci questa tabellaEspandi questa tabella
      Nome dell'attributoEsempioNote
      proxyAddressesproxyAddresses (3): X500: /o = Exchange/ou = Exchange Administrative Group (FYDIBOHF23SPDLT) / cn = Recipients/cn = 1ae75fca0d3a4303802cea9ca50fcd4f-7628376; SMTP:7628376@Service.contoso.com; SMTP:7628376@contoso.com;
      • Il numero viene visualizzato tra parentesi accanto all'etichetta dell'attributo indica il numero di valori di indirizzo proxy nell'attributo multivalore.
      • Ogni valore di indirizzo proxy distinte è indicato da un punto e virgola (;).
      • Il valore dell'indirizzo proxy SMTP primario è indicato da lettere maiuscole "SMTP:"
      userPrincipalName7628376@contoso.com
      Nota.Ldp.exe è incluso in Windows Server 2008 e negli strumenti di supporto di Windows Server 2003. Gli strumenti di supporto di Windows Server 2003 sono inclusi nel supporto di installazione di Windows Server 2003. In alternativa, per ottenere lo strumento, visitare il seguente sito Web Microsoft:
      http://go.microsoft.com/fwlink/?LinkId=100114
  2. Connettersi a Office 365 utilizzando il Windows Azure Active Directory Module per Windows PowerShell. A tale scopo, attenersi alla seguente procedura:
    1. Fare clic Inizio, fare clic su Tutti i programmi, fare clic su Windows Azure Active Directory, quindi fare clic su Modulo di Active Directory di Windows Azure per Windows PowerShell.
    2. Digitare i seguenti comandi nell'ordine in cui vengono presentati e premere INVIO dopo ciascun comando:
      • $cred = get-credential
        Nota. Quando richiesto, immettere le credenziali di amministratore di Office 365.
      • Connect-MSOLService ?credential $cred
      Lasciare aperta la finestra di console. È necessario utilizzarlo nel passaggio successivo.
  3. Controllo per il duplicato userPrincipalName attributi in Office 365.

    Nella connessione alla console che è stato aperto nel passaggio 2, digitare i seguenti comandi nell'ordine in cui vengono presentati e premere INVIO dopo ciascun comando:
    • $userUPN = "<search UPN>"
      Nota. In questo comando, il segnaposto"<search upn="">"</search>rappresenta ilUserPrincipalName attributo annotato nel passaggio 1f.
    • get-MSOLUser ?UserPrincipalName $userUPN | where {$_.LastDirSyncTime -eq $null}
    Lasciare aperta la finestra di console. Si utilizzerà nuovamente nel passaggio successivo.
  4. Controllo duplicato proxyAddresses attributi. Nella connessione alla console che è stato aperto nel passaggio 2, digitare i seguenti comandi nell'ordine in cui vengono presentati e premere INVIO dopo ciascun comando:
    • $SessionExO = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri https://ps.outlook.com/powershell/ -Credential $Cred -Authentication Basic - AllowRedirection
    • Import-PSSession $sessionExO -prefix:Cloud
  5. Per ogni voce di indirizzo proxy annotato nel passaggio 1f, digitare i seguenti comandi nell'ordine in cui vengono presentati e premere INVIO dopo ciascun comando:
    • $proxyAddress = "<search proxyAddress>"

      Nota. In questo comando, il segnaposto"<search proxyaddress="">"</search>rappresenta il valore di unproxyAddressesattributo annotato nel passaggio 1f.
    • get-cloudmailbox | where {[string] $str = ($_.EmailAddresses); $str.tolower().Contains($proxyAddress.tolower()) 
      -eq $true} | foreach {get-MSOLUser -UserPrincipalName $_.MicrosoftOnlineServicesID | 
      where {($_.LastDirSyncTime -eq $null)}}
Gli elementi che vengono restituiti dopo aver eseguito i comandi nel passaggio 3 e 4 rappresentano gli oggetti utente che non sono state create tramite la sincronizzazione delle directory e che dispongono di attributi in conflitto con l'oggetto non viene sincronizzati correttamente.

Dopo aver determinato i valori degli attributi in conflitto o non valido, è possibile risolvere il problema attenendosi alla procedura nel seguente articolo della Microsoft Knowledge Base:
2643629Non sincronizzare singoli oggetti di servizi di dominio Active Directory di Active Directory di Windows Azure in Office 365

ULTERIORI INFORMAZIONI

I comandi di Windows PowerShell in questo articolo richiedono il Windows Azure Active Directory Module per Windows PowerShell. Per ulteriori informazioni su Windows Azure Active Directory Module per Windows PowerShell, visitare il seguente sito Web Microsoft:
Ulteriore assistenza? Vai al Community di Office 365 .

Proprietà

Identificativo articolo: 2647098 - Ultima modifica: mercoledì 3 aprile 2013 - Revisione: 15.1
Le informazioni in questo articolo si applicano a:
  • Microsoft Office 365 for enterprises (pre-upgrade)
  • Microsoft Office 365 for education  (pre-upgrade)
  • Microsoft Office 365 Enterprise preview
  • Windows Azure Active Directory
Chiavi: 
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