Zduplikowane lub nieprawidłowe atrybuty zapobiegać synchronizacji katalogów w usłudze Office 365

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 2647098 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

PROBLEM

Usługi Microsoft Office 365 administrator otrzymuje następujące ostrzeżenie wiadomość e-mail po zakończeniu synchronizacji katalogów:
Od: MSOnlineServicesTeam@MicrosoftOnline.com
Przedmiot: Raport o błędach synchronizacji katalogu
Raport o błędach w otrzymanej wiadomości e-mail mogą zawierać jeden lub więcej z następujących komunikatów o błędach:
  • Synchronizowanego obiektu z tym samym adresem proxy już istnieje w katalogu programu Microsoft Online Services.
  • Nie można zaktualizować tego obiektu, ponieważ nie odnaleziono Identyfikatora użytkownika.
  • Nie można zaktualizować tego obiektu w witrynie Microsoft Online Services, ponieważ następujące atrybuty skojarzone z tym obiektem wartości, które mogą być już skojarzony z innym obiektem w katalogu lokalnym.

PRZYCZYNA

Ten problem może wystąpić, jeśli obiektów użytkowników w schemacie lokalnej Usługi domenowe w usłudze Active Directory (AD DS) ma duplikat lub alias nieprawidłową wartość, a te obiekty użytkownika nie zostały zsynchronizowane ze schematu AD DS do usługi Office 365 poprawnie podczas synchronizacji katalogów.

Wszystkie wartości alias w usłudze Office 365 muszą być unikatowe dla danej organizacji. Nawet jeśli masz wiele unikatowych sufiksów po znaku (@) w adres Simple Mail Transfer Protocol (SMTP), wszystkie wartości alias musi być unikatowy.

W środowisku lokalnym, może mieć alias wartości, które są takie same, tak długo, jak są one unikatowe w oparciu o sufiksy po znaku (@) w polu adres SMTP.

Po utworzeniu obiektów, które mają wartości zduplikowanych aliasów w chmurze usługi Office 365, aby aliasy unikatowe, jeden alias ma unikatowy numer do niego. (Na przykład, jeśli wartości Zduplikowany alias "Albert", jeden z nich automatycznie staje się "Albert2". Jeśli "Albert2" jest już używana, alias staje się "Albert3" i tak dalej). Jednak jeśli obiekty, które mają wartości zduplikowanych aliasów są tworzone w lokalnym AD DS kolizji obiektów występuje podczas uruchamiania synchronizacji katalogów, a nie obiektów synchronizacji.

ROZWIĄZANIE

Aby rozwiązać ten problem, należy ustalić zduplikowane wartości i wartości, które są w konflikcie z innymi obiektami AD DS. Aby to zrobić, można użyć narzędzia korygowania błędów DirSync IdFix lub narzędzia diagnostyczne Microsoft Online Services i zestaw narzędzi obsługi rejestrowania (MOSDAL).

Metoda 1: Użyj narzędzia korygowania błędów IdFix DirSync

Użyj narzędzia korygowania błędów DirSync IdFix zidentyfikowanie zduplikowane lub nieprawidłowe atrybuty. Aby rozwiązać zduplikowane atrybuty za pomocą narzędzia IdFix, zobacz następujący artykuł z bazy wiedzy Microsoft Knowledge Base:
2857385 "Duplikat" jest wyświetlany w kolumnie błąd na dwa lub więcej obiektów po uruchomieniu narzędzia IdFix
Aby uzyskać więcej informacji dotyczących narzędzia IdFix przejdź do Narzędzie korygowania błędów IdFix DirSync.

Metoda 2: Użyj narzędzi obsługi MOSDAL

Aby uzyskać informacje dotyczące nieprawidłowe atrybuty za pomocą zestawu narzędzi obsługi MOSDAL, wykonaj następujące kroki:
  1. Pobierz i zainstaluj zestaw narzędzi obsługi MOSDAL z następującej witryny firmy Microsoft:
    http://www.microsoft.com/download/en/details.aspx?id=626
  2. Uruchomienie zestawu narzędzi obsługi MOSDAL, zaznacz Pojedynczy znak na rejestracji jednokrotnej (SSO) z listy usługi Office 365, a następnie kliknij Dalej.
  3. Gdy zostanie wyświetlony monit o wprowadzenie poświadczeń, wprowadź identyfikator użytkownika, a następnie kliknij przycisk Dalej. Hasło nie jest zapisywany i jest używany tylko do symulowania próba uwierzytelnienia i rejestrować wyniki.
  4. Na ekranie odtworzyć Problem kliknij przycisk Dalej.
  5. Gdy raport zostanie zakończone, zlokalizuj plik MOSDALREPORT.zip w bibliotece Documents\MOSDAL. Pliki raportów, które zawierają informacje o nieprawidłowe atrybuty znajdują się w pliku MOSDALREPORT\Admin_Applications\Directory_Synchronization_Tool\DirSyncObjects.xml.

Określić atrybut konfliktów, które są powodowane przez obiekty, które nie były tworzone w programie Microsoft Azure AD za pośrednictwem synchronizacji katalogów

Aby sprawdzić konflikty atrybutów, które są spowodowane przez obiektów użytkowników, które zostały utworzone przy użyciu narzędzia do zarządzania Office 365 (i które nie były tworzone w Azure AD za pośrednictwem synchronizacji katalogów), wykonaj następujące kroki:
  1. Określić unikatowe atrybuty lokalnego konta użytkownika AD DS. Aby to zrobić, na komputerze, który ma zainstalowane narzędzia obsługi systemu Windows, wykonaj następujące kroki:
    1. Kliknij przycisk Start, kliknij polecenie Uruchom, wpisz Ldp.exe, a następnie kliknij przycisk OK.
    2. Kliknij połączenie, kliknij przycisk Połącz, wpisz nazwę komputera z kontrolerem domeny AD DS, a następnie kliknij przycisk OK.
    3. Kliknij połączenie, kliknij polecenie Powiąż, a następnie kliknij przycisk OK.
    4. Kliknij menu Widok, kliknij W widoku drzewa, wybierz domeny AD DS wBazowa nazwa wyróżniająca Lista rozwijana lista, a następnie kliknij przycisk OK.
    5. W okienku nawigacji zlokalizuj i kliknij dwukrotnie obiekt, który nie jest poprawnie synchronizacji. W okienku szczegółów po prawej stronie okna wyświetla listę wszystkich atrybutów obiektu. W poniższym przykładzie pokazano atrybuty obiektu:

      Zwiń ten obrazekRozwiń ten obrazek
      Zrzut obiektu, który nie jest synchronizowanie poprawnie, przedstawiający wszystkie atrybuty obiektu ekranu
    6. Rejestrowanie wartości userPrincipalName atrybut i poszczególne adresy SMTP na atrybut wielowartościowy proxyAddresses atrybut. Te wartości będą konieczne później.
      Zwiń tę tabelęRozwiń tę tabelę
      Nazwa atrybutuPrzykładNotatki
      proxyAddressesproxyAddresses (3): x 500: / o = Exchange/ou = Exchange Administrative Group (FYDIBOHF23SPDLT) / cn = Recipients/cn = 1ae75fca0d3a4303802cea9ca50fcd4f-7628376; SMTP:7628376@Service.contoso.com; SMTP:7628376@contoso.com;
      • Numer, który jest wyświetlany w nawiasach obok etykiety atrybut wskazuje liczbę wartości adresów serwera proxy w atrybucie wielowartościowym.
      • Każda wartość adresu proxy odrębne jest wskazywane przez średnik (;).
      • Wartość adresu podstawowego serwera proxy SMTP jest wskazywany przez wielkie "SMTP:"
      userPrincipalName7628376@contoso.com
      Uwaga Ldp.exe znajduje się w systemie Windows Server 2008 i narzędzi obsługi systemu Windows Server 2003. Narzędzia obsługi systemu Windows Server 2003 są zawarte w nośniku instalacyjnym systemu Windows Server 2003. Lub, aby uzyskać narzędzie, przejdź do następującej witryny firmy Microsoft:
      http://go.microsoft.com/fwlink/?LinkId=100114
  2. Podłącz do usługi Office 365 przy użyciu Azure Active Directory moduł dla środowiska Windows PowerShell. Aby to zrobić, wykonaj następujące kroki:
    1. Kliknij przycisk Start, kliknij polecenie Wszystkie programy, kliknij przycisk Windows Azure Active Directory, a następnie kliknij Windows Azure Active Directory modułu dla Windows PowerShell.
    2. Wpisz następujące polecenia w kolejności, w której są przedstawiane i naciśnij klawisz Enter po wpisaniu każdego polecenia:
      • $cred = get-credential
        Uwaga Gdy zostanie wyświetlony monit, wprowadź swoje poświadczenia administratora usługi Office 365.
      • Connect-MSOLService –credential $cred
      Pozostaw otwarte okno konsoli. Trzeba będzie go używać w następnym kroku.
  3. Sprawdź duplikat userPrincipalName atrybuty w usłudze Office 365.

    W połączeniu konsoli otwartego w kroku 2 wpisz następujące polecenia w kolejności, w której są przedstawiane i naciśnij klawisz Enter po wpisaniu każdego polecenia:
    • $userUPN = "<search UPN>"
      Uwaga W tym poleceniu symbol zastępczy"<search upn="">"</search> reprezentuje UserPrincipalName atrybut, który rejestrowane w kroku 1f.
    • get-MSOLUser –UserPrincipalName $userUPN | where {$_.LastDirSyncTime -eq $null}
    Pozostaw otwarte okno konsoli. Można będzie użyć go ponownie w następnym kroku.
  4. Sprawdzanie duplikatów proxyAddresses atrybuty. W połączeniu konsoli otwartego w kroku 2 wpisz następujące polecenia w kolejności, w której są przedstawiane i naciśnij klawisz Enter po wpisaniu każdego polecenia:
    • $SessionExO = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri https://outlook.office365.com/powershell-liveid/ -Credential $Cred -Authentication Basic - AllowRedirection
    • Import-PSSession $sessionExO -prefix:Cloud
  5. Dla każdego wpisu adres serwera proxy, odnotowanej w kroku 1f wpisz następujące polecenia w kolejności, w której są przedstawiane i naciśnij klawisz Enter po wpisaniu każdego polecenia:
    • $proxyAddress = "<search proxyAddress>"

      Uwaga W tym poleceniu symbol zastępczy"<search proxyaddress="">"</search> reprezentuje wartość proxyAddresses atrybut, który rejestrowane w kroku 1f.
    • get-mailbox | where {[string] $str = ($_.EmailAddresses); $str.tolower().Contains($proxyAddress.tolower()) 
      -eq $true} | foreach {get-MSOLUser -UserPrincipalName $_.MicrosoftOnlineServicesID | 
      where {($_.LastDirSyncTime -eq $null)}}
Elementy, które są zwracane po uruchomieniu polecenia w kroku 3 i 4 reprezentują obiektów użytkowników, które nie były utworzone za pośrednictwem synchronizacji katalogów, które mają atrybuty, które są w konflikcie z obiektu, który nie jest poprawnie synchronizacji.

Po określeniu wartości atrybutów powodujących konflikty lub nieprawidłowy, należy rozwiązać problem, wykonując kroki opisane w następującym artykule z bazy wiedzy Microsoft Knowledge Base:
2643629 Jeden lub więcej obiektów nie Synchronizuj podczas korzystania z narzędzia Azure Active Directory Sync

WIĘCEJ INFORMACJI

Polecenia środowiska Windows PowerShell w tym artykule wymagają Azure Active Directory moduł dla środowiska Windows PowerShell. Aby uzyskać więcej informacji na temat Azure Active Directory modułu dla Windows PowerShell przejdź do następującej witryny firmy Microsoft:
Nadal potrzebujesz pomocy? Przejdź do Społeczności użytkowników usługi Office 365 witryny sieci Web.

Właściwości

Numer ID artykułu: 2647098 - Ostatnia weryfikacja: 2 lipca 2014 - Weryfikacja: 24.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Office 365 for enterprises (pre-upgrade)
  • Microsoft Office 365 for education  (pre-upgrade)
  • Office 365 Identity Management
Słowa kluczowe: 
o365 mosdal4.5 o365a o365022013 after upgrade o365062011 pre-upgrade o365e kbgraphxlink o365m kbgraphic kbmt KB2647098 KbMtpl
Przetłumaczone maszynowo
WAŻNE: Ten artykuł został przetłumaczony przy użyciu oprogramowania firmy Microsoft do tłumaczenia maszynowego i może być poprawiony przy użyciu technologii Community Translation Framework (CTF). Firma Microsoft udostępnia artykuły tłumaczone maszynowo, poprawione przez społeczność, a także tłumaczone przez tłumaczy profesjonalnych, aby zapewnić dostęp do wszystkich artykułów w bazie wiedzy w wielu językach. Artykuły tłumaczone maszynowo i poprawione mogą zawierać błędy pisowni, składniowe i gramatyczne. Firma Microsoft nie ponosi odpowiedzialności za żadne nieścisłości, błędy ani szkody spowodowane przez niepoprawne tłumaczenia zawartości ani przez korzystanie z niej przez klientów. Więcej o strukturze CTF: http://support.microsoft.com/gp/machine-translation-corrections/pl.
Anglojęzyczna wersja tego artykułu to: 2647098

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com