You cannot use WMI to manage CSV resources in Windows Server 2008 R2

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Article ID: 2648385 - View products that this article applies to.
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Symptoms

Consider the following scenario:
  • You create more than one Cluster Shared Volume (CSV) resource on a cluster node that is running Windows Server 2008 R2.
  • You use Windows Management Instrumentation (WMI) to manage a CSV resource. For example, you use the MSCluster_ClusterSharedVolume::TurnOnRedirectedAccess() method to enable direct I/O on a CSV resource.
  • The operation fails if there is an offline CSV resource that is ahead of other CSV resources in the order of resource enumeration.
In this scenario, the operation fails and you receive the following error message:
Generic error
Additionally, the extended error information reports the following message:
The cluster resource is not online.

Cause

This issue occurs because of a logic error when the Cluster service checks whether the managed resource is online.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    Collapse this tableExpand this table
    VersionProductSR_LevelService branch
    6.1.760 0 . 21xxxWindows Server 2008 R2RTMLDR
    6.1.760 1 . 21xxxWindows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Cluswmi.dll6.1.7600.21097540,67224-Nov-201107:12x64
Cluswmi.mofNot applicable76,75224-Nov-201100:36Not applicable
Cluswmiuninstall.mofNot applicable17613-Jul-200920:22Not applicable
Cluswmi.dll6.1.7601.21866542,20824-Nov-201107:06x64
Cluswmi.mofNot applicable76,75224-Nov-201100:50Not applicable
Cluswmiuninstall.mofNot applicable17620-Nov-201003:54Not applicable
For all supported IA-64–based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Cluswmi.dll6.1.7600.21097884,73624-Nov-201105:44IA-64
Cluswmi.mofNot applicable76,75224-Nov-201100:10Not applicable
Cluswmiuninstall.mofNot applicable17613-Jul-200920:22Not applicable
Cluswmi.dll6.1.7601.21866887,29624-Nov-201105:35IA-64
Cluswmi.mofNot applicable76,75224-Nov-201100:07Not applicable
Cluswmiuninstall.mofNot applicable17620-Nov-201003:39Not applicable

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information about how to map a certificate to a user account, visit the following Microsoft website:
General information about how to map a certificate to a user account

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_microsoft-windows-f..overcluster-cluswmi_31bf3856ad364e35_6.1.7600.21097_none_18e5434bd2a68192.manifest
File versionNot applicable
File size6,668
Date (UTC)25-Nov-2011
Time (UTC)21:06
PlatformNot applicable
File nameAmd64_microsoft-windows-f..overcluster-cluswmi_31bf3856ad364e35_6.1.7601.21866_none_1aeb398fcfb54a39.manifest
File versionNot applicable
File size6,668
Date (UTC)25-Nov-2011
Time (UTC)21:05
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size32,896
Date (UTC)26-Nov-2011
Time (UTC)09:06
PlatformNot applicable
Additional files for all supported IA-64–based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameIa64_microsoft-windows-f..overcluster-cluswmi_31bf3856ad364e35_6.1.7600.21097_none_bcc84bbe1a471958.manifest
File versionNot applicable
File size6,666
Date (UTC)24-Nov-2011
Time (UTC)07:45
PlatformNot applicable
File nameIa64_microsoft-windows-f..overcluster-cluswmi_31bf3856ad364e35_6.1.7601.21866_none_bece42021755e1ff.manifest
File versionNot applicable
File size6,666
Date (UTC)24-Nov-2011
Time (UTC)07:38
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size7,944
Date (UTC)26-Nov-2011
Time (UTC)09:06
PlatformNot applicable

Properties

Article ID: 2648385 - Last Review: January 4, 2013 - Revision: 2.0
Applies to
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 for Itanium-Based Systems
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseinter KB2648385

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