Não é possível instalar RDS CALs automaticamente por meio de Windows PowerShell no Windows Server 2008 R2

Traduções de Artigos Traduções de Artigos
Artigo: 2648662 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Considere o seguinte cenário:
  • Você pode instalar o serviço de função licenciamento remota da área de trabalho (Licenciamento de RD) em um computador que esteja executando o Windows Server 2008 R2.
  • Instale o pacote de hotfix 2618115 no computador.
  • Tente instalar licenças de acesso de cliente de serviços de área de trabalho remota (RDS CALs) automaticamente usando o Windows PowerShell.
  • Você pode selecionar Telefone ou Navegador da Web como o método de conexão.
  • O servidor de licenciamento de RD não tem uma conexão ativa com a Internet.
Nesse cenário, você não pode instalar RDS CALs e a seguinte mensagem de erro:
Acesso ao objeto em RDS:\LicenseServer\LicenseKeyPacks\LicenseKeyPack é negado para o cmdlet New-Item. Não foi possível criar um pacote de chaves de licença, porque a entrada não era válida ou permissões foram insuficientes.

Em linha: 1 char: 9

+ Novo Item< -path="" rds:\licenseserver\licensekeypacks="" -connectionmethod="">

+ CategoryInfo: PermissionDenied: (:) [Novo Item], AccessViolationException + FullyQualifiedErrorId: PermissionDenied,Microsoft.PowerShell.Commands.NewItemCommand

Causa

Esse problema ocorre porque o servidor de licenciamento de RD desnecessariamente verifica se ela é autenticada ou não. Esse comportamento requer acesso à Internet. Portanto, a verificação de autenticação falhar se o servidor de licenciamento de RD não tiver uma conexão ativa com a Internet.

Resolução

Informações sobre o hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplica este hotfix somente aos sistemas que apresentarem o problema descrito neste artigo. Este hotfix pode receber testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção de "Download de Hotfix disponível" na parte superior deste artigo do Knowledge Base. Se não aparecer nesta seção, entre em contato com o suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação Se ocorrerem problemas adicionais, ou se for necessária a qualquer solução de problemas, você talvez precise criar uma solicitação de serviço. Os custos de suporte normais serão aplicados a questões de suporte adicional e problemas que não sejam específicos deste hotfix. Para uma lista completa dos números de telefone de suporte e atendimento ao cliente da Microsoft ou para criar uma solicitação de serviço, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, você deve estar executando o Windows Server 2008 R2 Service Pack 1 (SP1).

Para obter mais informações sobre como obter um service pack do Windows 7 ou Windows Server 2008 R2, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
976932Informações sobre o Service Pack 1 para o Windows 7 e do Windows Server 2008 R2
Este hotfix é dependente do hotfix 2618115. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
2618115 Você não pode ativar um servidor de licenciamento de RD ou instalar RDS CALs automaticamente por meio de Windows PowerShell no Windows Server 2008 R2

Informações do registro

Para usar o hotfix neste pacote, não é necessário fazer alterações no registro.

Requisito de reinicialização

Você deve reiniciar o computador após aplicar esse hotfix.

Informações sobre o

Esse hotfix não substitui um hotfix lançado anteriormente.

Informações sobre o arquivo

A versão global deste hotfix instala arquivos que possuem os atributos listados nas tabelas a seguir. As datas e horas destes arquivos estão listadas no tempo Universal Coordenado (UTC). As datas e horários desses arquivos no computador local são exibidos em sua hora local junto com a diferença de horário de verão (DST) atual. Além disso, as datas e horas podem ser alterados quando você realizar algumas operações nos arquivos.
Observações sobre o arquivo do Windows Server 2008 R2
Importante Os hotfixes do Windows 7 e os hotfixes do Windows Server 2008 R2 estão incluídos nos pacotes para o mesmos. No entanto, os hotfixes na página solicitação de Hotfix estão listados em ambos os sistemas operacionais. Para solicitar o pacote de hotfix que se aplica a um ou ambos os sistemas operacionais, selecione o hotfix listado em "Windows 7/Windows Server 2008 R2" na página. Sempre consulte a seção "Aplica-se A" nos artigos para determinar o que cada hotfix se aplica ao sistema operacional real.
  • Os arquivos que se aplicam a um produto específico, SR_Level (RTM, SPn), e ramificação do serviço (LDR, GDR) pode ser identificada ao examinar os números de versão do arquivo, conforme mostrado na tabela a seguir.
    Reduzir esta tabelaExpandir esta tabela
    VersãoProdutoSR_LevelRamificação do serviço
    6.1.760 0. 16xxxWindows Server 2008 R2RTMGDR
    6.1.760 0. 21xxxWindows Server 2008 R2RTMLDR
    6.1.760 1. 17xxxWindows Server 2008 R2SP1GDR
    6.1.760 1. 21xxxWindows Server 2008 R2SP1LDR
  • Os arquivos MANIFEST (. manifest) e MUM (. mum) instalados para cada ambiente são listados separadamente na seção "informações de arquivo adicionais para o Windows Server 2008 R2". MUM e arquivos de MANIFESTO e os arquivos de catálogo (. cat) de segurança associadas, são extremamente importantes para manter o estado dos componentes atualizados. Os arquivos de catálogo de segurança, para o qual os atributos não estiverem listados, são assinados com uma assinatura digital da Microsoft.
Para todas as versões baseadas em x64 do Windows Server 2008 R2
Reduzir esta tabelaExpandir esta tabela
Nome do arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
LicMgr. exe6.1.7600.16385410,62414-Jul-200901: 39.x64
Lrwizdll.dll6.1.7600.21097586,24024-Nov-201107: 14.x64
Lserver_pkconfig.XMLNão aplicável20,99411-Nov-200923: 30.Não aplicável
LicMgr. exe6.1.7601.17514410,62420-Nov-201013: 24x64
Lrwizdll.dll6.1.7601.21866586,75224-Nov-201107: 08.x64
Lserver_pkconfig.XMLNão aplicável20,99405-Nov-201001: 57Não aplicável

Como contornar

Para contornar esse problema, use um ou ambos os métodos a seguir:
  • Conecte o servidor à Internet e, em seguida, execute novamente o comando Windows PowerShell.
  • Se o computador não tiver uma conexão ativa com a Internet, use o console do Gerenciador de licenciamento de RD para selecionar o Telefone ou Navegador da Web sobre o Método de conexão guia.

Ponto Da Situação

A Microsoft confirmou que esse é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informação

Para obter mais informações sobre a terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software Microsoft

Informações adicionais sobre arquivos

Informações de arquivo adicionais para o Windows Server 2008 R2

Arquivos adicionais para todas as versões baseadas em x64 do Windows Server 2008 R2
Reduzir esta tabelaExpandir esta tabela
Nome do arquivoAmd64_4853300404aae42e01ed5f9baeefe55c_31bf3856ad364e35_6.1.7600.21097_none_c67b74171c7402f8.manifest
Versão do arquivoNão aplicável
Tamanho do arquivo727
Data (UTC)24-Nov-2011
Hora (UTC)16: 42
PlataformaNão aplicável
Nome do arquivoAmd64_559fd094b9ae753be338c95787e9a71c_31bf3856ad364e35_6.1.7601.21866_none_36392be73b6017a5.manifest
Versão do arquivoNão aplicável
Tamanho do arquivo727
Data (UTC)24-Nov-2011
Hora (UTC)16: 42
PlataformaNão aplicável
Nome do arquivoAmd64_microsoft-windows-t...-licensingadminpack_31bf3856ad364e35_6.1.7600.21097_none_a0b5a4c1e25a5b6a.manifest
Versão do arquivoNão aplicável
Tamanho do arquivo5,083
Data (UTC)24-Nov-2011
Hora (UTC)16: 42
PlataformaNão aplicável
Nome do arquivoAmd64_microsoft-windows-t...-licensingadminpack_31bf3856ad364e35_6.1.7601.21866_none_a2bb9b05df692411.manifest
Versão do arquivoNão aplicável
Tamanho do arquivo5,083
Data (UTC)24-Nov-2011
Hora (UTC)16: 42
PlataformaNão aplicável
Nome do arquivoUpdate.mum
Versão do arquivoNão aplicável
Tamanho do arquivo1,963
Data (UTC)24-Nov-2011
Hora (UTC)16: 42
PlataformaNão aplicável

Propriedades

Artigo: 2648662 - Última revisão: 11 de janeiro de 2012 - Revisão: 1.0
A informação contida neste artigo aplica-se a:
  • Windows Server 2008 R2 Service Pack 1 nas seguintes plataformas
    • Windows Server 2008 R2 Standard
    • Windows Server 2008 R2 Foundation
    • Windows Server 2008 R2 Enterprise
    • Windows Server 2008 R2 Datacenter
Palavras-chave: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseinter kbmt KB2648662 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 2648662

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com