ผู้ใช้ภายนอกไม่สามารถเชื่อมต่อกับ RDS ที่มีการเผยแพร่บนเซิร์ฟเวอร์ที่ใช้ Windows Server 2008 R2 เกตเวย์ของ RD ผ่าน Forefront UAG

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 2649422 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

มีการเผยแพร่บริการเดสก์ท็อประยะไกล (RDS) บนเซิร์ฟเวอร์ของเกตเวย์เดสก์ท็อประยะไกล (เกตเวย์ของ RD) ที่กำลังเรียกใช้ Windows Server 2008 R2 ผ่าน Forefront ร่วมเข้าเกตเวย์ (UAG) ในสภาพแวดล้อมของเครือข่าย บางครั้ง ผู้ใช้ภายนอกไม่สามารถเชื่อมต่อกับ RDS เผยแพร่ และจะได้รับข้อความแสดงข้อผิดพลาดต่อไปนี้:


คอมพิวเตอร์ของคุณไม่สามารถเชื่อมต่อไปยังคอมพิวเตอร์ระยะไกลได้เนื่องจากเซิร์ฟเวอร์ของเกตเวย์ของเดสก์ท็อประยะไกลถึงจำนวนสูงสุดที่อนุญาตให้ใช้การเชื่อมต่อ ลองเชื่อมต่อใหม่ในภายหลัง หรือติดต่อผู้ดูแลระบบเครือข่ายของคุณสำหรับความช่วยเหลือ


นอกจากนี้ เหตุการณ์ที่มีลักษณะต่อไปนี้ไว้บนเซิร์ฟเวอร์ของเกตเวย์ของ RD:

รหัสเหตุการณ์: 203
แหล่งที่มา: Microsoft-Windows-TerminalServices-Gateway
ชื่อที่เป็นสัญลักษณ์: AAG_EVENT_MAX_CONNECTIONS_REACHED
ข้อความ: จำนวนของการเชื่อมต่อไปยังเซิร์ฟเวอร์ของเกตเวย์ของ RD พร้อมกันได้ถึงจำนวนสูงสุดที่ถูกกำหนด โดยผู้ดูแล เซิร์ฟเวอร์ถูกดังนั้นจึงไม่สามารถรับการเชื่อมต่อใหม่ใด ๆ ความพยายามในการเชื่อมต่อ โดยผู้ใช้ "% 1" ในคอมพิวเตอร์ไคลเอนต์ "% 2" โดยใช้วิธีการรับรองความถูกต้อง "% 3" ถูกปฏิเสธ สำหรับข้อมูลเกี่ยวกับวิธีการปรับเปลี่ยนข้อจำกัดของการเชื่อมต่อสูงสุด ดูหัวข้อ "ระบุตัวสูงสุดจำนวนของอนุญาตการเชื่อมต่อสำหรับ RD Gateway" ในวิธีใช้เกตเวย์ของ RD

สาเหตุ

ปัญหานี้เกิดขึ้นเนื่องจากการเชื่อมต่อผู้ใช้จะไม่ได้ถูกปิดอย่างถูกต้อง ดังนั้น จะ leaked tunnels บางเครือข่าย Forefront (ขอบ) เมื่อจำนวนของการเชื่อมต่อไปยังเซิร์ฟเวอร์ของเกตเวย์ของ RD พร้อมกันได้ถึงจำนวนสูงสุด จะมีปฏิเสธคำขอการเชื่อมต่อใหม่ทั้งหมด

การแก้ไข

ข้อมูลโปรแกรมแก้ไขด่วน

โปรแกรมแก้ไขด่วนที่สนับสนุนได้จาก Microsoft อย่างไรก็ตาม โปรแกรมแก้ไขด่วนนี้มุ่งหวังเพื่อการแก้ไขปัญหาที่อธิบายไว้ในบทความนี้นั้น ใช้ hotfix นี้เฉพาะกับระบบต่าง ๆ ที่พบปัญหาที่อธิบายไว้ในบทความนี้ โปรแกรมแก้ไขด่วนนี้อาจได้รับการทดสอบเพิ่มเติม ดังนั้น ถ้าคุณจะไม่รุนแรงผลกระทบจากปัญหานี้ เราขอแนะนำให้ คุณรอการปรับปรุงซอฟต์แวร์ถัดไปที่ประกอบด้วยโปรแกรมแก้ไขด่วนนี้

หากโปรแกรมแก้ไขด่วนพร้อมดาวน์โหลด คุณจะเห็นส่วน "โปรแกรมแก้ไขด่วนพร้อมใช้งานดาวน์โหลด" ที่ด้านบนของบทความฐานความรู้นี้ หากส่วนนี้ไม่ปรากฏขึ้น ติดต่อบริการลูกค้าของ Microsoft และวิธีการขอรับโปรแกรมแก้ไขด่วน

หมายเหตุ หากเกิดปัญหาเพิ่มเติม หรือแก้ไข คุณอาจต้องสร้างการร้องขอบริการแยกต่างหาก ค่าใช้จ่ายในการสนับสนุนปกติจะไปคำถามเพิ่มเติมและเรื่องอื่น ๆ ที่ไม่สามารถจัดโปรแกรมแก้ไขด่วนนี้เฉพาะ สำหรับรายการทั้งหมด ของหมายเลขโทรศัพท์ฝ่ายสนับสนุนและการบริการลูกค้าของ Microsoft หรือเมื่อ ต้องสร้างการร้องขอบริการแยกต่างหาก เยี่ยมชมเว็บไซต์ต่อไปนี้ของ Microsoft:
ฝ่าย
หมายเหตุ แบบฟอร์ม "ดาวน์โหลดโปรแกรมแก้ไขด่วนพร้อมใช้งาน" แสดงภาษาที่ซึ่งมีโปรแกรมแก้ไขด่วนพร้อมใช้งาน ถ้าคุณไม่เห็นภาษาของคุณ เป็น เพราะโปรแกรมแก้ไขด่วนจะไม่พร้อมใช้งานสำหรับภาษานั้น

ข้อกำหนดเบื้องต้น

เมื่อต้องใช้โปรแกรมแก้ไขด่วนนี้ คุณต้องเรียกใช้ Windows Server 2008 R2 หรือ Windows Server 2008 R2 Service Pack 1 (SP1) นอกจากนี้ คุณต้องมีบริการบทบาทของเกตเวย์ของเดสก์ท็อประยะไกลเปิดใช้งาน

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการขอรับ service pack Windows 7 หรือ Windows Server 2008 R2 คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
976932ข้อมูลเกี่ยวกับ Service Pack 1 สำหรับ Windows 7 และ Windows Server 2008 R2

ข้อมูลรีจิสทรี

เมื่อต้องใช้โปรแกรมแก้ไขด่วนในแพคเกจนี้ คุณไม่จำเป็นต้องทำการเปลี่ยนแปลงใด ๆ ในรีจิสทรี

ความต้องการเริ่มการทำงาน

คุณไม่ต้องเริ่มระบบของคอมพิวเตอร์ใหม่หลังจากที่คุณใช้โปรแกรมแก้ไขด่วนนี้ เมื่อต้องการหลีกเลี่ยงการเริ่มการทำงาน หยุดบริการบทบาทของเกตเวย์ของเดสก์ท็อประยะไกล

ข้อมูลการแทนที่โปรแกรมแก้ไขด่วน

โปรแกรมแก้ไขด่วนนี้ไม่ได้แทนด่วนก่อนหน้านี้

แฟ้มข้อมูล

รุ่นสากลของโปรแกรมแก้ไขด่วนนี้ติดตั้งแฟ้มที่มีแอตทริบิวต์ที่ระบุไว้ในตารางต่อไปนี้ วันและเวลาของแฟ้มเหล่านี้แสดงในรูปแบบการเวลามาตรฐานสากล (UTC) วันและเวลาของแฟ้มเหล่านี้บนเครื่องคอมพิวเตอร์ของคุณจะแสดงอยู่ในเวลาท้องถิ่นของคุณพร้อมมีฤดูกาล (DST) นอกจากนี้ วันและเวลาอาจเปลี่ยนแปลงเมื่อคุณดำเนินการบางอย่างในแฟ้ม
หมายเหตุข้อมูลแฟ้มของ Windows Server 2008 R2
  • แฟ้มที่ใช้กับผลิตภัณฑ์เฉพาะ การกำหนดเวลา (RTM, SPn), และสาขาเซอร์วิส (LDR, GDR) สามารถระบุได้ ด้วยการตรวจสอบหมายเลขรุ่นของแฟ้มดังที่แสดงในตารางต่อไปนี้:
    ยุบตารางนี้ขยายตารางนี้
    รุ่นผลิตภัณฑ์กำหนดเวลาสาขาเซอร์วิส
    6.1.760 0.21xxxWindows Server 2008 R2RTMLDR
    6.1.760 1.21xxxWindows Server 2008 R2SP1LDR
  • แฟ้ม MANIFEST (.manifest) และแฟ้ม MUM (.mum) ที่มีการติดตั้งสำหรับแต่ละสภาพแวดล้อม แสดงรายการแยกต่างหาก ในส่วน "ข้อมูลเพิ่มเติมของแฟ้มสำหรับ Windows Server 2008 R2" MUM และแฟ้ม MANIFEST และ แฟ้มแค็ตตาล็อก (.cat) การรักษาความปลอดภัยที่เกี่ยวข้อง มีความสำคัญอย่างมากเมื่อต้องรักษาสถานะของคอมโพเนนต์ที่ปรับปรุงแล้ว แฟ้มแค็ตตาล็อกความปลอดภัย ที่แอตทริบิวต์ไม่อยู่ ถูกเซ็นชื่อ ด้วยลายเซ็นดิจิทัลของ Microsoft
สำหรับรายการทั้งหมดที่ได้รับการสนับสนุน Windows Server 2008 R2 รุ่นที่ใช้ x64
ยุบตารางนี้ขยายตารางนี้
ชื่อแฟ้มรุ่นของแฟ้มขนาดของแฟ้มวันเวลาแพลตฟอร์ม
Aaedge.dll6.1.7600.21100305,66430 2011 พฤศจิกายน06:30x 64
Tsproxy-edgeadapter-ppdlic.xrm-msไม่เกี่ยวข้อง3,01830 2011 พฤศจิกายน06:57ไม่เกี่ยวข้อง
Aaedge.dll6.1.7601.21869308,22430 2011 พฤศจิกายน06:15x 64
Tsproxy-edgeadapter-ppdlic.xrm-msไม่เกี่ยวข้อง3,01830 2011 พฤศจิกายน06:39ไม่เกี่ยวข้อง

สถานะ

Microsoft ยืนยันว่า ปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ในส่วน"ใช้งาน"

ข้อมูลเพิ่มเติม

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับคำศัพท์เฉพาะการปรับปรุงซอฟต์แวร์ คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
824684คำอธิบายเกี่ยวกับคำศัพท์เฉพาะทางมาตรฐานที่ใช้เพื่ออธิบายการปรับปรุงซอฟต์แวร์ของ Microsoft

ข้อมูลเพิ่มเติมของแฟ้ม

ข้อมูลเพิ่มเติมของแฟ้มสำหรับ Windows Server 2008 R2

แฟ้มเพิ่มเติมสำหรับรายการทั้งหมดที่ได้รับการสนับสนุน Windows Server 2008 R2 รุ่นที่ใช้ x64
ยุบตารางนี้ขยายตารางนี้
ชื่อแฟ้มAmd64_04844210638e2b7c6abc5008c88fcfe6_31bf3856ad364e35_6.1.7600.21100_none_56abd1ab16ac0574.manifest
รุ่นของแฟ้มไม่เกี่ยวข้อง
ขนาดของแฟ้ม711
วัน (UTC)30 2011 พฤศจิกายน
เวลา (UTC)11:33
ชื่อแฟ้มAmd64_f144c73204e76604bc5f8c6cd9825bd4_31bf3856ad364e35_6.1.7601.21869_none_dc69a82e865c566e.manifest
รุ่นของแฟ้มไม่เกี่ยวข้อง
ขนาดของแฟ้ม711
วัน (UTC)30 2011 พฤศจิกายน
เวลา (UTC)11:33
ชื่อแฟ้มAmd64_microsoft-windows-tsproxy-edgeadapter_31bf3856ad364e35_6.1.7600.21100_none_9ada634fff47b9f4.manifest
รุ่นของแฟ้มไม่เกี่ยวข้อง
ขนาดของแฟ้ม99,560
วัน (UTC)30 2011 พฤศจิกายน
เวลา (UTC)11:33
ชื่อแฟ้มAmd64_microsoft-windows-tsproxy-edgeadapter_31bf3856ad364e35_6.1.7601.21869_none_9c890b45fc967e53.manifest
รุ่นของแฟ้มไม่เกี่ยวข้อง
ขนาดของแฟ้ม99,560
วัน (UTC)30 2011 พฤศจิกายน
เวลา (UTC)11:33

คุณสมบัติ

หมายเลขบทความ (Article ID): 2649422 - รีวิวครั้งสุดท้าย: 9 กุมภาพันธ์ 2555 - Revision: 2.0
ใช้กับ
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseinter kbmt KB2649422 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:2649422

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com