คุณพบกับประสิทธิภาพต่ำเมื่อคุณใช้การค้นหาเวลาที่พร้อมใช้งานใน 2011 CRM ของ Microsoft Dynamics

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 2651621 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

อาการ

เมื่อคุณพยายามใช้คุณลักษณะการจัดตารางทรัพยากรการค้นหาเวลาที่พร้อมใช้งานใน Microsoft Dynamics CRM คุณพบกับประสิทธิภาพการทำงานที่ไม่ดี ถ้าคุณใช้การค้นหาเวลาที่พร้อมใช้งานอีกครั้ง และเริ่มการทำงานของแบบสอบถามใหม่ ปรับปรุงประสิทธิภาพการทำงาน และผลลัพธ์ใช้เวลาน้อยมาก

สาเหตุ

ปัญหานี้เกิดขึ้นเนื่องจากหน่วยงานต่าง ๆ ที่เกี่ยวข้องกับการจัดกำหนดการประกอบด้วยการปรับใช้ Microsoft Dynamics CRM และมีการเรียกใช้แบบสอบถาม SQL แบบหลายเรียกแต่ละระเบียนในระหว่างกระบวนการจัดตารางทรัพยากรการค้นหาเวลาที่มีอยู่

การแก้ไข

เมื่อต้องแก้ไขปัญหานี้ ดาวน์โหลด และติดตั้ง 8 ยกเลิกโปรแกรมปรับปรุงสำหรับ Microsoft Dynamics CRM เมื่อต้องการทำเช่นนี้ ดูบทความในฐานความรู้ของ Microsoft ต่อไปนี้:
2600644 โปรแกรมปรับปรุง 8 สำหรับ 2011 CRM ของ Microsoft Dynamics จะพร้อมใช้งาน

หลังจากที่คุณติดตั้งโปรแกรมปรับปรุง คุณควรสร้างรีจิสทรีคีย์ต่อไปนี้บนเซิร์ฟเวอร์ CRM สำหรับหน่วยงานที่เกี่ยวข้องกับการวางแผน:
SchedulingEngine.CacheConfiguration
หลังจากที่คุณทำเช่นนี้ หน่วยงานเหล่านี้จะถูกเพิ่มลงในแคชเพื่อปรับปรุงประสิทธิภาพ

เมื่อต้องสร้างรีจิสทรีคีย์ ให้ทำตามขั้นตอนเหล่านี้:
  1. บนเซิร์ฟเวอร์ Microsoft Dynamics CRM ชี้ไป เริ่มการทำงาน เมนู และชนิดนั้น regedit ในกล่องค้นหาเพื่อเปิดตัวแก้ไขรีจิสทรี
  2. ค้นหาคีย์ย่อยของรีจิสทรีต่อไปนี้:
    HKEY_Local_Machine\Software\Microsoft\MSCRM
  3. คลิกขวา MSCRMชี้ไปที่ ใหม่แล้ว คลิก ค่าสายอักขระ.
  4. ชนิด SchedulingEngine.CacheConfiguration.
  5. คลิกขวาคีย์ใหม่ และจากนั้น คลิก ปรับเปลี่ยน. การแก้ไขที่คุณทำจะคล้ายกับ XML ต่อไปนี้ อย่างไรก็ตาม การปรับเปลี่ยนจะขึ้นอยู่กับหน่วยงานและตัวเลือกที่คุณต้องการใช้ ดูส่วน "ข้อมูลเพิ่มเติม" สำหรับข้อมูลเพิ่มเติม
    <CachingModes>
    <CachingMode name="BookCaching">
    <Calendar>DefaultCache</Calendar>
    <CalendarRule>DefaultCache</CalendarRule>
    <Commitment>DefaultCache</Commitment>
    <ConstraintGroup>DefaultCache</ConstraintGroup>
    <Equipment>Direct</Equipment>
    <PluginType>DefaultCache</PluginType>
    <Resource>Direct</Resource>
    <ResourceGroup>DefaultCache</ResourceGroup>
    <ResourceExpansion>DefaultCache</ResourceExpansion>
    <ResourceGroupExpansion>DefaultCache</ResourceGroupExpansion>
    <ResourceSpec>Direct</ResourceSpec>
    <Schedule>DefaultCache</Schedule>
    <Service>DefaultCache</Service>
    <SystemUser>Direct</SystemUser>
    <Team>DefaultCache</Team>
    </CachingMode> 
    <CachingMode name="SearchCaching">
    <Calendar>DefaultCache</Calendar>
    ... (and other entities like above)
    </CachingMode>
    <CachingMode name="PublishResourceGroupsCaching">
    <Calendar>Direct</Calendar>
    (และอื่น ๆ หน่วยงานที่คล้ายกัน)
    </CachingMode>
    </CachingModes>

ข้อมูลเพิ่มเติม

สำหรับแต่ละหน่วยงานที่คุณเพิ่มลงในแคช ไม่มีค่าสองค่าที่เป็นไปได้: โดยตรง และ DefaultCache.
  • ค่าของ DefaultCacheความพยายามที่ปรับให้เหมาะสมตามจำนวนแบบสอบถาม SQL และเรียกระเบียนทั้งหมดในครั้งเดียว โดยใช้แบบสอบถามเดียว หลังจากที่ระเบียนทั้งหมดจะถูกดึงข้อมูล ข้อมูลถูกเก็บไว้ในแคช HTTP
  • ค่าของ โดยตรง แบบสอบถามสำหรับแต่ละระเบียนโดยใช้แบบสอบถาม SQL แบบแยกต่างหาก

หมายเหตุ ถ้าคุณเพิ่มหน่วยงานเพิ่มเติมลงในแคช การใช้หน่วยความจำอาจเพิ่มขึ้นเล็กน้อยขนาดแคเพิ่มขึ้น

มีอยู่สามชนิดในโหมด:
  • SearchCaching ใช้เมื่อ "ค้นหาเวลาที่พร้อมใช้งาน" หรือถูกดำเนินการตรวจสอบของการนัดหมายบริการ
  • BookCachingใช้เมื่อมีการบันทึกการนัดหมายบริการ
  • PublishResourceGroupCaching ใช้เมื่อกลุ่มทรัพยากรที่จะจัดระเบียบ และดำเนินการ "ประกาศแผนภูมิทรัพยากร"
สามารถกำหนดโหมดสำหรับบางหน่วยงานโดยรวม โดยใช้แท็กทรัพยากรและแท็กResourceGroups หรือ หน่วยงานสามารถกำหนดแยกต่างหากในระดับแอด

หน่วยงานทรัพยากรรวม subtypes ที่ต่อไปนี้:
  • เครื่องมือ
  • SystemUsers
  • ResourceSpec
เอนทิตี ResourceGroups รวม subtypes ที่ต่อไปนี้:
  • ConstraintBasedGroup
  • ทีม

คุณสมบัติ

หมายเลขบทความ (Article ID): 2651621 - รีวิวครั้งสุดท้าย: 13 พฤษภาคม 2555 - Revision: 1.0
ใช้กับ
  • Microsoft Dynamics CRM 2011
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbmt KB2651621 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:2651621

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com