Help and Support

OFF2000 : Windows Installer apparaît au démarrage de chaque programme

Numéro d'article:265194
Dernière mise à jour:lundi 17 avril 2006
Version:5.0
Cet article peut contenir des liens vers des informations en langue anglaise (pas encore traduites).
IMPORTANT : cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, pensez à le sauvegarder et assurez-vous que vous savez le restaurer en cas de problème. Pour plus d'informations sur la sauvegarde, la restauration et la modification du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
256986 (http://support.microsoft.com/kb/256986/) Description du Registre de Microsoft Windows
Sommaire

Symptômes

À chaque fois que vous démarrez un programme Office, une boîte de dialogue contenant le message suivant s'affiche pour Windows Installer :
Préparation de l'installation...
Celle-ci est suivie d'une autre boîte de dialogue contenant le message suivant :
Veuillez patienter pendant que Windows configure Édition Office
Édition Office est l'édition d'Office que vous avez installée.

Retour au début

Cause

Ces messages peuvent apparaître si l'une des valeurs DWORD suivantes (ou toutes) du Registre ne se trouvent pas dans la clé HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\LanguageResources  :
UILanguage
HelpLanguage
InstallLanguage

Retour au début

Résolution

Pour résoudre ce problème, utilisez chacune des méthodes suivantes dans l'ordre dans lequel elles sont présentées, jusqu'à la résolution du problème. Après avoir résolu le problème, n'utilisez pas les méthodes restantes.

Retour au début

Méthode 1 : Utilisation de l'Outil de version linguistique

1.Dans votre navigateur Web, reportez-vous au site Web de Microsoft à l'adresse suivante (en anglais) :
http://www.microsoft.com/office/ork/2000/appndx/toolbox.htm#orktools (http://www.microsoft.com/office/ork/2000/appndx/toolbox.htm#orktools)
Enregistrez le programme Orktools.exe sur votre bureau, lorsque vous y êtes invité.
2.Installez Orktools.exe en double-cliquant dessus sur votre bureau.
3.Cliquez sur I accept the terms of the License Agreement, puis sur Next.
4.Indiquez le chemin d'accès à l'emplacement d'installation, puis cliquez sur Next.
5.Sous la fonctionnalité Tools, cliquez sur chacune des sous-fonctionnalités, à l'exception de la sous-fonctionnalité Office Language Version. Modifiez l'état d'installation sur Not Available. Laissez la sous-fonctionnalité Office Language Version définie sur l'état d'installation par défaut Run from My Computer.
6.Cliquez sur Install Now.
7.Lorsque l'installation est terminée, dans le menu Démarrer, pointez sur Programmes, pointez sur Microsoft Office Tools, sur Microsoft Office 2000 Resource Kit Tools, puis cliquez sur Language Version.
8.Sélectionnez la langue pour votre version d'Office dans la liste Use defaults for. Par exemple, si vous avez une version anglaise (États-Unis) d'Office, cliquez sur English.
9.Cliquez sur OK.

Retour au début

Méthode 2 : Modification du Registre

AVERTISSEMENT : toute mauvaise utilisation de l'Éditeur du Registre peut générer des problèmes sérieux, pouvant vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantir que les problèmes résultant d'une mauvaise utilisation de l'Éditeur du Registre puissent être résolus. Vous assumez l'ensemble des risques liés à l'utilisation de cet outil.
1.Cliquez sur Démarrer, puis sur Exécuter.
2.Dans la zone Ouvrir, tapez Regedit, puis cliquez sur OK.
3.Recherchez la clé suivante et cliquez dessus :
HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common
4.Sélectionnez la valeur DWORD UserData pour la clé ci-dessus.
5.Dans le menu Edition, cliquez sur Renommer.
6.Renommez la valeur DWORD UserData en UserDataOld.
7.Recherchez la clé suivante :
HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common
8.Recherchez la valeur suivante : OSAShortcut. Si elle n'existe pas, créez-la. Dans le menu Edition, cliquez sur Nouveau, puis sur Dword. Nommez la valeur OSAShortcut, puis définissez la valeur sur 1.
9.Dans le menu Registre, cliquez sur Quitter.
10.Démarrez l'un des programmes Office. REMARQUE : les mêmes boîtes de dialogue Windows Installer apparaissent une fois de plus.

11.Lorsque vous y êtes invité, tapez votre nom et vos initiales dans la boîte de dialogue Nom d'utilisateur, puis cliquez sur OK.

Retour au début

Méthode 3 : Réinstallation de Microsoft Access

Pour résoudre ce problème, renommez les fichiers Msaccess.exe et System.mdw, puis réinstallez Microsoft Access. Pour cela, appliquez la méthode adaptée au système d'exploitation de votre ordinateur.

REMARQUE : par défaut, le fichier Msaccess.exe est installé dans le dossier "C:\Program Files\Microsoft Office\Office10" et le fichier System.mdw est installé dans le dossier "C:\Program Files\CommonFiles\SYSTEM".

Microsoft Windows 98 ou Microsoft Windows NT 4.0 :
1.Quittez toutes les instances de Word, y compris Microsoft Outlook si Word est sélectionné comme votre éditeur de messagerie électronique.
2.Cliquez sur Démarrer, pointez sur Rechercher, puis cliquez sur Fichiers ou dossiers.
3.Dans la zone Nommé, tapez Msaccess.exe.
4.Dans la zone Rechercher dans, sélectionnez votre disque dur local. (Si vous exécutez Word à partir d'un serveur réseau, sélectionnez un autre emplacement de modèle d'utilisateur.)
5.Cliquez sur Rechercher pour rechercher le fichier.
6.Pour chaque occurrence du fichier Msaccess.exe qui apparaît dans le programme de recherche, cliquez avec le bouton droit sur le fichier. Cliquez sur Renommer dans le menu contextuel. Donnez un nouveau nom au fichier, tel que OldMsaccess.exe ou Msaccess.exe-1.dot, puis appuyez sur ENTRÉE.
7.Répétez les étapes 3 à 6 pour renommer le fichier System.mdw.
8.Dans le menu Fichier, cliquez sur Fermer pour fermer la boîte de dialogue Rechercher.
9.Cliquez sur Démarrer, pointez sur Programmes, puis cliquez sur Microsoft Access. Si vous êtes invité à fournir le CD-ROM de l'application, insérez-le, puis cliquez sur OK pour continuer le programme d'installation de l'application.
10.Une fois le programme d'installation terminé, démarrez Microsoft Access.
11.Dans le menu Fichier de Microsoft Access, cliquez sur Quitter pour quitter Microsoft Access, puis redémarrez Microsoft Access.
Microsoft Windows Millennium Edition ou Microsoft Windows 2000 :
1.Quittez toutes les instances de Word, y compris Outlook si Word est sélectionné comme votre éditeur de messagerie électronique.
2.Cliquez sur Démarrer, pointez sur Rechercher, puis cliquez sur Des fichiers ou des dossiers.
3.Dans la zone Rechercher les fichiers ou les dossiers nommés, tapez Msaccess.exe.
4.Dans la zone Rechercher dans, sélectionnez votre disque dur local. (Si vous exécutez Word à partir d'un serveur réseau, sélectionnez un autre emplacement de modèle d'utilisateur.)
5.Cliquez sur Rechercher pour rechercher le fichier.
6.Cliquez avec le bouton droit sur chaque occurrence du fichier Msaccess.exe qui s'affiche dans la boîte de dialogue Résultats de la recherche. Cliquez sur Renommer dans le menu contextuel. Donnez un nouveau nom au fichier, tel que OldMsaccess.exe ou Msaccess.exe-1.dot, puis appuyez sur ENTRÉE.
7.Répétez les étapes 3 à 6 pour renommer le fichier System.mdw.
8.Dans le menu Fichier, cliquez sur Fermer pour quitter le programme Rechercher.
9.Cliquez sur Démarrer, pointez sur Programmes, puis cliquez sur Microsoft Access. Si vous êtes invité à fournir le CD-ROM de l'application, insérez-le, puis cliquez sur OK pour continuer le programme d'installation de l'application.
10.Une fois le programme d'installation terminé, démarrez Microsoft Access.
11.Dans le menu Fichier de Microsoft Access, cliquez sur Quitter pour quitter Microsoft Access, puis redémarrez Microsoft Access.
Microsoft Windows XP :
1.Quittez toutes les instances de Word, y compris Outlook si Word est sélectionné comme votre éditeur de messagerie électronique.
2.Cliquez sur Démarrer, puis sur Rechercher.
3.Sous Que voulez-vous rechercher ?, cliquez sur Tous les fichiers et dossiers.
4.Dans la zone Une partie ou l'ensemble du nom, tapez Msaccess.exe.
5.Dans la zone Rechercher dans, sélectionnez votre disque dur local. (Si vous exécutez Word à partir d'un serveur réseau, sélectionnez un autre emplacement de modèle d'utilisateur.)
6.Cliquez sur Rechercher pour rechercher le fichier.
7.Pour chaque occurrence du fichier Msaccess.exe qui s'affiche dans la boîte de dialogue Résultats de la recherche, cliquez avec le bouton droit sur le fichier, puis cliquez sur Renommer dans le menu contextuel. Donnez un nouveau nom au fichier, tel que OldMsaccess.exe ou Msaccess.exe-1.dot, puis appuyez sur ENTRÉE.
8.Répétez les étapes 3 à 7 pour renommer le fichier System.mdw.
9.Dans le menu Fichier, cliquez sur Fermer pour fermer Résultats de la recherche.
10.Cliquez sur Démarrer, pointez sur Tous les programmes, puis cliquez sur Microsoft Access. Si vous êtes invité à fournir le CD-ROM de l'application, insérez-le, puis cliquez sur OK pour continuer le programme d'installation de l'application.
11.Une fois le programme d'installation terminé, démarrez Microsoft Access.
12.Dans le menu Fichier de Microsoft Access, cliquez sur Quitter pour quitter Microsoft Access, puis redémarrez Microsoft Access.

Retour au début


Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
?Microsoft Excel 2000 Standard
?Microsoft Access 2000 Standard Edition
?Microsoft FrontPage 2000 Standard
?Microsoft Office 2000 Édition Standard
?Microsoft Outlook 2000 Standard
?Microsoft PowerPoint 2000 Standard
?Microsoft Publisher 2000 Standard
?Microsoft Word 2000 Standard Edition

Retour au début

Mots-clés : 
kbbug kbpending KB265194

Retour au début

L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Traductions disponibles

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.