Help and Support

文書番号: 265194 - 最終更新日: 2006年4月17日 - リビジョン: 5.0

[OFF2000] アプリケーションを起動するたびに Windows インストーラが表示される

重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずレジストリをバックアップし、システムの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細については、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
256986? (http://support.microsoft.com/kb/256986/ ) Microsoft Windows レジストリの説明

目次

すべて展開する | すべて折りたたむ

現象

Office アプリケーションを起動するたびに、以下のメッセージと共に Windows インストーラのダイアログ ボックスが表示されます。
インストールの準備中 ...
この後に、以下のメッセージと共に別のダイアログ ボックスが表示されます。
Windows で Office Edition を設定しています。しばらくお待ちください。
Office Edition は、インストールされている Office のエディション名です。

原因

これらのメッセージは、レジストリ内の HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\LanguageResources キーに、以下の DWORD 値のいずれか (またはすべて) がない場合に、表示されることがあります。
UILanguage
HelpLanguage
InstallLanguage

解決方法

この問題を解決するには、以下の方法を記載されている順に、問題が解決するまで実行します。問題が解決した場合は、それ以降の方法は実行しないでください。

方法 1 : Language Version ツールを使用する

  1. Web ブラウザで、以下のマイクロソフト Web サイトにアクセスし、[ORKTools.exe] の左側のアイコンをクリックします。
    http://www.microsoft.com/office/ork/2000/appndx/toolbox.htm#orktools (http://www.microsoft.com/office/ork/2000/appndx/toolbox.htm#orktools)
    ダウンロードの確認のダイアログ ボックスが表示されたら、Orktools.exe プログラムをデスクトップに保存します。
  2. デスクトップにある Orktools.exe をダブルクリックしてインストールします。
  3. [I accept the terms in the License Agreement] をクリックし、[Next] をクリックします。
  4. インストール場所のパスを指定し、[Next] をクリックします。
  5. 一覧の [Tools] の下の [Office Language Version] を除く各項目をクリックし、一覧の [Not Available] をクリックします。[Office Language Version] は、デフォルトのインストール状態 [Run from My Computer] が設定されたままにします。
  6. [Install Now] をクリックします。
  7. インストールが完了したら、[スタート] ボタンをクリックし、[プログラム]、[Microsoft Office Tools]、[Microsoft Office 2000 Resource Kit Tools] の順にポイントし、[Language Version] をクリックします。
  8. [Use defaults for] ボックスの一覧で、使用している Office のバージョンの言語を選択します。たとえば、日本語版の Office を使用している場合は、[Japanese] をクリックします。
  9. [OK] をクリックします。

方法 2 : レジストリを変更する

警告 : レジストリ エディタの使い方を誤ると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリ エディタの誤用により発生した問題に関しては、一切責任を負わないものとします。レジストリ エディタは、自己の責任においてご使用ください。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。
  2. [名前] ボックスに Regedit と入力し、[OK] をクリックします。
  3. 次のキーを見つけてクリックします。
    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common
  4. 上記のキーの UserData という DWORD 値をクリックします。
  5. [編集] メニューの [名前の変更] をクリックします。
  6. UserData という DWORD 値の名前を UserDataOld に変更します。
  7. 同じキーに、OSAShortcut という値が存在し、データが 1 に設定されていることを確認します。この値が存在しない場合は作成します。作成するには、[編集] メニューの [新規] をポイントし、[DWORD 値] をクリックします。その値に OSAShortcut という名前を付け、値を 1 に設定します。
  8. [レジストリ] メニューの [レジストリ エディタの終了] をクリックします。
  9. 任意の Office プログラムを起動します。

    : 同じ Windows インストーラのダイアログ ボックスがもう一度表示されます。

  10. [ユーザー名] ダイアログ ボックスが表示されたら、ユーザー名と頭文字を入力し、[OK] をクリックします。

方法 3 : Microsoft Access を再インストールする

この問題を解決するには、Msaccess.exe ファイルおよび System.mdw ファイルの名前を変更してから、Microsoft Access を再インストールします。これを行うには、使用しているコンピュータのオペレーティング システムに応じて、以下の手順を実行します。

: デフォルトでは、Msaccess.exe ファイルは C:\Program Files\Microsoft Office\Office フォルダに、System.mdw ファイルは C:\Program Files\Common Files\SYSTEM フォルダにインストールされます。

Microsoft Windows 98 または Microsoft Windows NT 4.0
  1. Microsoft Access のインスタンスをすべて終了します。
  2. [スタート] ボタンをクリックし、[検索] をポイントし、[ファイルやフォルダ] をクリックします。
  3. [名前] ボックスに Msaccess.exe と入力します。
  4. [探す場所] ボックスの一覧で、ローカル ハード ドライブを選択します (ネットワーク サーバーから Microsoft Access を実行している場合は、適切な検索場所を選択します)。
  5. [検索開始] をクリックして、ファイルを検索します。
  6. [検索結果] ウィンドウに表示された各 Msaccess.exe ファイルを右クリックします。ショートカット メニューの [名前の変更] をクリックします。ファイルに、OldMsaccess.exe または Msaccess.exe-1.dot などの新しい名前を付けて、Enter キーを押します。
  7. 手順 3. 〜 6. を繰り返し、System.mdw ファイルの名前を変更します。
  8. [ファイル] メニューの [閉じる] をクリックして [検索] ウィンドウを閉じます。
  9. [スタート] ボタンをクリックし、[プログラム] をポイントし、[Microsoft Access] をクリックします。アプリケーション CD-ROM を挿入するように求めるメッセージが表示されたら、CD-ROM を挿入して [OK] をクリックし、アプリケーションのセットアップを続行します。
  10. セットアップが完了したら、Microsoft Access を起動します。
  11. Microsoft Access で、[ファイル] メニューの [終了] をクリックして Microsoft Access を終了し、再度 Microsoft Access を起動します。
Microsoft Windows Millennium Edition (Me) または Microsoft Windows 2000
  1. Microsoft Access のインスタンスをすべて終了します。
  2. [スタート] ボタンをクリックし、[検索] をポイントし、[ファイルやフォルダ] をクリックします。
  3. [ファイルまたはフォルダの名前] ボックスに Msaccess.exe と入力します。
  4. [探す場所] ボックスの一覧で、ローカル ハード ドライブを選択します (ネットワーク サーバーから Microsoft Access を実行している場合は、適切な検索場所を選択します)。
  5. [検索開始] をクリックして、ファイルを検索します。
  6. [検索結果] ウィンドウに表示された各 Msaccess.exe ファイルを右クリックします。ショートカット メニューの [名前の変更] をクリックします。ファイルに、OldMsaccess.exe または Msaccess.exe-1.dot などの新しい名前を付けて、Enter キーを押します。
  7. 手順 3. 〜 6. を繰り返し、System.mdw ファイルの名前を変更します。
  8. [ファイル] メニューの [閉じる] をクリックし、検索プログラムを終了します。
  9. [スタート] ボタンをクリックし、[プログラム] をポイントし、[Microsoft Access] をクリックします。アプリケーション CD-ROM を挿入するように求めるメッセージが表示されたら、CD-ROM を挿入して [OK] をクリックし、アプリケーションのセットアップを続行します。
  10. セットアップが完了したら、Microsoft Access を起動します。
  11. Microsoft Access で、[ファイル] メニューの [終了] をクリックして Microsoft Access を終了し、再度 Microsoft Access を起動します。
Microsoft Windows XP
  1. Microsoft Access のインスタンスをすべて終了します。
  2. [スタート] ボタンをクリックし、[検索] をクリックします。
  3. [何を検索しますか] の下の [ファイルとフォルダすべて] をクリックします。
  4. [ファイル名のすべてまたは一部] ボックスに Msaccess.exe と入力します。
  5. [探す場所] ボックスの一覧で、ローカル ハード ドライブを選択します (ネットワーク サーバーから Microsoft Access を実行している場合は、適切な検索場所を選択します)。
  6. [検索] をクリックして、ファイルを検索します。
  7. [検索結果] ウィンドウに表示された各 Msaccess.exe ファイルを右クリックします。ショートカット メニューの [名前の変更] をクリックします。ファイルに、OldMsaccess.exe または Msaccess.exe-1.dot などの新しい名前を付けて、Enter キーを押します。
  8. 手順 3. 〜 7. を繰り返し、System.mdw ファイルの名前を変更します。
  9. [ファイル] メニューの [閉じる] をクリックし、[検索結果] ウィンドウを閉じます。
  10. [スタート] ボタンをクリックし、[すべてのプログラム] をポイントし、[Microsoft Access] をクリックします。アプリケーション CD-ROM を挿入するように求めるメッセージが表示されたら、CD-ROM を挿入して [OK] をクリックし、アプリケーションのセットアップを続行します。
  11. セットアップが完了したら、Microsoft Access を起動します。
  12. Microsoft Access で、[ファイル] メニューの [終了] をクリックして Microsoft Access を終了し、再度 Microsoft Access を起動します。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 265194? (http://support.microsoft.com/kb/265194/EN-US/ ) (最終更新日 2003-09-22) を基に作成したものです。

この資料は以下の製品について記述したものです。
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft Office 2000 Standard
  • Microsoft Outlook 2000 Standard Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft Publisher 2000 Standard Edition
  • Microsoft Word 2000 Standard Edition
キーワード:?
kbbug kbpending KB265194
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

サポート技術情報の翻訳