查看或保存在 Internet Explorer 9 中的历史记录的问题的疑难解答

文章翻译 文章翻译
文章编号: 2652752 - 查看本文应用于的产品
展开全部 | 关闭全部

本文内容

概要

本文讨论了可以帮助您解决问题时,您不能查看或保存您的历史记录,在 Internet Explorer 9 中的故障排除步骤。

原因

查看或保存网页历史记录的问题可能会出现一个或多个以下几个原因:

  • 如果有,则会发生此问题 删除浏览历史记录,在退出 在 Internet 选项中选中的复选框。
  • 如果您的硬盘已满,您可能需要以释放磁盘空间。
  • Internet Explorer 保留您访问过的网页历史记录的天数可能设置为 0 或更少。在这段时间内之后, 会自动删除历史记录。
  • 您的历史记录可能已损坏或被另一个进程锁定。
  • 注册表项可能有损坏的或已修改。
  • 您的用户配置文件可能已损坏。

解决方案

方法 1: 检查以确保未选中删除浏览历史记录,在 Internet 选项中的退出框上。
  1. 通过单击开始按钮打开 Internet Explorer。在搜索框中,键入 Internet Explorer,然后在搜索结果列表中,单击Internet Explorer
  2. 单击工具按钮,然后单击Internet 选项
  3. 常规选项卡,然后在浏览历史记录下,请确保删除在退出浏览历史记录中未检查。
检查问题是否得到解决。如果问题得到解决,则您已完成这篇文章。如果问题未解决,请转到下一个方法。


方法 2: 检查以查看您的硬盘上是否有足够的可用空间
  1. 通过单击开始按钮打开 Internet Explorer。在搜索框中,键入Internet Explorer,然后在搜索结果列表中,单击Internet Explorer
  2. 单击工具按钮,然后单击Internet 选项
  3. 常规选项卡,然后在浏览历史记录下,单击设置。在要使用的磁盘空间,请确保为250 MB,并在历史记录下的磁盘空间设置下,确保网页保存在历史记录的天数设置为 20。
    注意: 如果您不希望保留网页历史记录,请将天数设置为 0。
检查问题是否得到解决。如果问题得到解决,则您已完成这篇文章。如果问题未解决,请转到下一个方法。


方法 3: 删除临时 Internet 文件

它是一个不错的主意,删除临时 Internet 文件,定期以释放驱动器空间。

  1. 通过单击开始按钮打开 Internet Explorer。在搜索框中,键入Internet Explorer,然后在搜索结果列表中,单击Internet Explorer
  2. 单击工具按钮,然后单击Internet 选项
  3. 常规选项卡,然后在浏览历史记录,请单击删除。
  4. 删除浏览历史记录对话框中,在选择临时 Internet 文件、 Cookie 和历史记录,单击删除,然后单击确定。?

    所做的更改将生效的下次您打开 Internet Explorer
检查问题是否得到解决。如果问题得到解决,则您已完成这篇文章。如果问题未解决,请转到下一个方法。


方法 4: 重置 Internet Explorer 设置

警告:重置 Internet Explorer 是不可逆的。重置,所有以前的设置都将丢失,无法恢复。若要重置 Internet Explorer 设置,请参阅 重置 Internet Explorer 9 设置。

检查问题是否得到解决。如果问题得到解决,则您已完成这篇文章。如果问题未解决,请转到下一个方法。



方法 5: 重建您的浏览历史记录

下面介绍了如何显示隐藏的文件和文件夹。

  1. 通过单击开始按钮、 单击控制面板,单击外观和个性化设置,然后单击 $文件夹选项打开文件夹选项。
  2. 单击视图选项卡。
  3. 高级设置单击显示隐藏的文件、 文件夹和驱动器并取消选中隐藏受保护的操作系统文件,然后单击确定
下面介绍了如何手动删除浏览历史记录。
  1. 关闭所有 Internet Explorer 和 Windows 资源管理器窗口中当前打开。
  2. 单击开始按钮,单击运行,键入%userprofile%\AppData\Local\Microsoft\windows\ ,然后单击确定
  3. 若要手动删除所有历史记录,请删除要删除特定的历史记录,只能删除您不想保留这些文件的整个文件夹的内容。
检查问题是否得到解决。如果问题得到解决,则您已完成这篇文章。如果问题未解决,请转到下一个方法。

高级故障排除

此部分适用于高级计算机用户。如果您不熟悉高级故障排除步骤,请转到"其他支持"部分。

方法 1: 删除您的HKEY_CURRENT_USERS\Software\Microsoft\Windows\CurrentVersion\Internet\Settings\5.0 注册表项

警告:注册表编辑器使用不当会导致严重的问题,可能需要您重新安装操作系统。Microsoft 不能保证问题导致的不正确地使用注册表编辑器可以解决。使用注册表编辑器需要您自担风险。

  1. 单击开始,单击运行,键入regedit,然后单击确定
  2. 找到并单击以下注册表项:

    HKEY_CURRENT_USERS\Software\Microsoft\Windows\Current\Version\Internet\Settings\5.0
  3. 用鼠标右键单击该文件,然后单击删除
  4. 退出注册表编辑器

检查问题是否得到解决。如果问题得到解决,则您已完成这篇文章。如果问题未解决,请转到下一个方法。

方法 2: 修复损坏的用户配置文件

如果您的用户配置文件已损坏,您需要创建新的配置文件,然后将文件从现有配置文件复制到新。若要创建新的用户配置文件,然后将文件复制到它,请按照本文中的步骤操作:

修复已损坏的用户配置文件

检查问题是否得到解决。如果问题得到解决,则您已完成这篇文章。如果未解决问题,请参阅更多支持部分中。

更多信息

如果您无法删除浏览历史记录中的长 Url,请参阅 您不能删除长 Url 从 Windows 7 或 Windows Server 2008 R2 正在运行的计算机上的 Internet Explorer 中的浏览历史记录

其他支持

检查问题是否得到解决。如果问题得到解决,则您已完成这篇文章。如果不解决问题,您还可以使用 Microsoft 客户支持服务网站查找其他解决方案。一些 Microsoft 客户支持服务网站提供的服务包括:

可搜索的知识库: 搜索 Microsoft 产品的自助工具和技术支持信息。

解决方案中心: 查看特定于产品的常见问题和主要支持信息。

Microsoft 的答案: 联系的对应项、 同级和 Microsoft 最有价值专家 (Mvp)

其它支持选项: 使用 web 提出问题,请联系 Microsoft 客户支持服务,或提供反馈。

属性

文章编号: 2652752 - 最后修改: 2012年4月20日 - 修订: 4.0
这篇文章中的信息适用于:
  • Windows Internet Explorer 9
关键字:?
kbmt KB2652752 KbMtzh
机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 2652752
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com