Error message when you move mailboxes from an on-premises environment to Office 365: "Mailbox Move to the cloud fail with error"

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Article ID: 2654376 - View products that this article applies to.
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PROBLEM

In a hybrid deployment of Microsoft Exchange Online in Microsoft Office 365 and on-premises Microsoft Exchange Server, you receive the following error message when you move mailboxes from your on-premises environment to Office 365:

Mailbox Move to the cloud fail with error: Transient error CommunicationErrorTransientException has occurred. The system will retry

CAUSE

This issue may occur if the on-premises Microsoft Forefront Threat Management Gateway (TMG) server blocks HTTP requests from servers in the Office 365 environment. This occurs because of the flood mitigation feature in the Forefront TMG. This mechanism helps lessen flood attacks.

To confirm that this is the issue that you are experiencing, examine the alerts that are displayed in the Forefront TMG management console. To do this, follow these steps:
  1. Open the Forefront TMG Management console.
  2. In the tree, click Monitoring, and then click the Alerts tab.
  3. Check whether a warning that contains the following text is displayed:

    The number of HTTP requests per minute from the source IP address IPAddress exceeded the configured limit. Forefront TMG will block new HTTP requests sent from this IP address.

    If such a warning is displayed, you are experiencing this issue.

SOLUTION

To resolve this issue, configure flood mitigation settings in Forefront TMG to increase the custom limit for the maximum number of HTTP requests per minute. To do this, follow these steps:
  1. Open the Forefront TMG management console, and then, in the tree, click Intrusion Prevention System.
  2. Click the Behavioral Intrusion Detection tab, and then click Configure Flood Mitigation Settings.

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    Screen shot of Behavioral Intrusion Detection tab, highlighted Configure Flood Mitigation Settings
  3. In the Flood Mitigation dialog box, follow these steps:
    1. Click the IP Exceptions tab, and then type the IP addresses that the Office 365 environment uses to connect during the mailbox move operation. To view a list of the IP address ranges and URLs that are used by Exchange Online in Office 365, visit the following Microsoft website:
      http://help.outlook.com/en-us/140/gg263350.aspx
    2. Click the Flood Mitigation tab, and then, next to Maximum HTTP Requests per minute per IP address, click Edit. In the Custom limit box, type a number to increase the limit.

      Note The custom limit applies to IP addresses that are listed on the IP Exceptions tab. Increase only the custom limit. In the following example screen shot, the custom limit is set to 6,000. Depending on the number of mailboxes that are being moved, this number may not be sufficient. If you still receive the error message, increase the custom limit.

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      Screen shot of Flood Mitigation settings
    3. Click OK.

MORE INFORMATION

For more information about this issue, visit the following Office 365 Community website:

Office 365 Move Mailbox fails with transient exception

For more information about flood mitigation in the Forefront TMG, visit the following Microsoft TechNet website:

Overview of flood mitigation

Still need help? Go to the Office 365 Community website.

Properties

Article ID: 2654376 - Last Review: July 9, 2014 - Revision: 14.0
Applies to
  • Microsoft Office 365
Keywords: 
o365 o365a o365e o365022013 kbgraphxlink o365m hybrid kbgraphic KB2654376

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