Error message when you try to synchronize a Dynamics CRM 4.0 client to Outlook: "An unknown error occurred while synchronizing data to Outlook"

Article ID: 2655130 - View products that this article applies to.
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SYMPTOMS

You may receive the following error message when you try to synchronize Microsoft Outlook with a Microsoft Dynamics CRM 4.0 Citrix client:
An unknown error occurred while synchronizing data to Outlook.

CAUSE

This issue occurs because, by default, Microsoft SQL Server CE does not support mapped drives.

Note SQL Server CE requires UNC paths.

RESOLUTION

To resolve this issue, follow these steps:
  1. Install Microsoft Dynamics CRM 4.0 Update Rollup 20. For more information about how to download and install Microsoft Dynamics CRM 4.0 Update Rollup 20, visit the following Microsoft website:
    http://www.microsoft.com/download/en/details.aspx?id=28011
  2. Update the environment configuration settings in the Microsoft.crm.se.orgdborgsettingstool.exe.xml file.

    Note By default, the Microsoft.crm.se.orgdborgsettingstool.exe.xml file is located in the following folder:
    \Program Files\Microsoft Dynamics CRM\Server\bin\Tools
  3. Update the ClientExpandPathsToUNC database setting by using the Microsoft.crm.se.orgdborgsettingstool.exe tool. To do this, follow these steps:
    1. Start the Microsoft.crm.se.orgdborgsettingstool.exe tool.

      Note By default, the Microsoft.crm.se.orgdborgsettingstool.exe file is located in the following folder:
      \Program Files\Microsoft Dynamics CRM\Server\bin\Tools
    2. Type the following command, and then press Enter:
      microsoft.crm.se.orgdborgsettingstool update crm_organization ClientExpandPathsToUNC TRUE
      Note In this command, the crm_organization placeholder is the name of your organization.
  4. Verify the updated setting. To do this, type the following command, and then press Enter:
    microsoft.crm.se.orgdborgsettingstool retrieve

REFERENCES

For more information about the Microsoft.crm.se.orgdborgsettingstool.exe tool, see the following article in the Microsoft Knowledge Base:
2479288 A new tool that retrieves and changes the Organization level settings in Microsoft Dynamics CRM 4.0 configurations is available

Properties

Article ID: 2655130 - Last Review: June 9, 2012 - Revision: 4.2
APPLIES TO
  • Microsoft Dynamics CRM 4.0
  • Microsoft Dynamics CRM for Microsoft Office Outlook
Keywords: 
kbmbsmigrate kbsurveynew KB2655130

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