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Not sure if this is the right fix? We've added this issue to our memory dump diagnostic which can confirm.

Symptoms

Consider the following scenario:

  • You have a Windows Server 2008 R2-based Remote Desktop (RD) Session Host server in an Active Directory domain environment.

  • You apply the Printer Redirection Group Policy setting to RD sessions that connect to the server.

  • You repeatedly establish RD sessions to the server from a client computer that has multiple printers installed.

In this scenario, the logon time increases every time that you establish an RD connection. Additionally, the % Privileged Time count increases in the Svchost.exe process that hosts the User-mode Plug-and-Play Service (Umpnpmgr.dll) on the server. This behavior occurs every time that you log on, log off, or reestablish an RD session.

This behavior may cause performance issues such as slow boot, slow logon, system hangs, or failure to redirect printers and mapped drives.

Cause

This issue occurs because the Remote Desktop Services Device Redirector service creates a new port every time that an RD session is established. However, the inactive ports are not recycled. Instead, the inactive ports for the redirected printers accumulate under the following registry key on the server:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\DeviceClasses\{28d78fad-5a12-11d1-ae5b-0000f803a8c2}\##?#Root#RDPBUS#0000#{28d78fad-5a12-11d1-ae5b-0000f803a8c2}\

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 or Windows Server 2008 R2 Service Pack 1 (SP1). Additionally, you must have the RD Session Host role service installed on the computer.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2008 R2 file information notes
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.1.760
    0.21xxx

    Windows Server 2008 R2

    RTM

    LDR

    6.1.760
    1.21xxx

    Windows Server 2008 R2

    SP1

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Umrdp.dll

6.1.7600.21124

195,584

11-Jan-2012

06:28

x64

Umrdp.dll

6.1.7601.21895

214,528

11-Jan-2012

06:23

x64

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

After you install this hotfix, yo To have us fix this problem for you, go to the "Here's an easy fix" section. If you prefer to fix this problem manually, go to the "Let me fix it myself" section.

Here's an easy fix

To fix this problem automatically, click the Download button. In the File Download dialog box, click Run or Open, and then follow the steps in the easy fix wizard.

  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.

  • If you’re not on the computer that has the problem, save the easy fix solution to a flash drive or a CD, and then run it on the computer that has the problem.


Notes

  • This Fixit can also used to cleanup inactive Terminal Server Ports on all versions of Windows Server 2003 and Windows Server 2008, Windows 7 in a VDI scenario and can be automated to run on a scheduled basis. For more information, please see http://blogs.technet.com/b/askperf/archive/2012/03/06/performance-issues-due-to-inactive-terminal-server-ports.aspx.

  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.

  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

For more information about printer redirection, visit the following Microsoft website:

General information about printer redirectionFor more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2

File name

Amd64_3fa953577d7d1ef5281e74af83e76b68_31bf3856ad364e35_6.1.7600.21124_none_283f0e03f23d0d0a.manifest

File version

Not Applicable

File size

723

Date (UTC)

11-Jan-2012

Time (UTC)

11:12

Platform

Not Applicable

File name

Amd64_5bfeae5b817170f1bd59c2ed5ba20fcf_31bf3856ad364e35_6.1.7601.21895_none_d2977157f84c5304.manifest

File version

Not Applicable

File size

723

Date (UTC)

11-Jan-2012

Time (UTC)

11:12

Platform

Not Applicable

File name

Amd64_microsoft-windows-t..ices-portredirector_31bf3856ad364e35_6.1.7600.21124_none_be673547d7e28cb7.manifest

File version

Not Applicable

File size

20,927

Date (UTC)

11-Jan-2012

Time (UTC)

07:22

Platform

Not Applicable

File name

Amd64_microsoft-windows-t..ices-portredirector_31bf3856ad364e35_6.1.7601.21895_none_c0030b01d540a24f.manifest

File version

Not Applicable

File size

20,927

Date (UTC)

11-Jan-2012

Time (UTC)

07:27

Platform

Not Applicable

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