An Exchange Server 2007 Client Access server responds slowly or stops responding when users try to synchronize Exchange ActiveSync devices with their mailboxes

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Article ID: 2656040 - View products that this article applies to.
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Symptoms

When users try to synchronize Exchange ActiveSync (EAS) devices with their mailboxes in Microsoft Exchange Server 2007 environments, they encounter retryable errors. Additionally, the Microsoft Exchange Server 2007 Client Access server responds slowly or stops responding.

Cause

This issue occurs because EAS devices make continuous retries when they encounter retryable errors during the synchronization. This causes redundant communication to the Client Access server.


Resolution

To resolve this issue, install the following update rollup:
2608656 Description of Update Rollup 6 for Exchange Server 2007 Service Pack 3


Note After you apply this update rollup, the Exchange Server 2007 server will drop EAS sessions if the number of sessions for a user exceeds the session limit. When the number of sessions is dropped lower than the limit, new requests can be automatically processed.

Registry key information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
After you apply this update rollup, to configure the EAS session limit on the Exchange Server 2007 server, following these steps: 
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then select the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem
  3. On the Edit menu, point to New, and then click DWORD (32-bit) value.
  4. Type Maximum Allowed EAS Sessions Per User, and then press ENTER.
  5. Right-click Maximum Allowed EAS Sessions Per User, and then click Modify.
  6. In the Value data box, type CustomValue, and then click OK.
  7. Exit Registry Editor.


Note
By default, the limit is 16.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information about EAS, visit the following Microsoft website:
General information about Exchange ActiveSync
The Troubleshoot ActiveSync with Exchange Server guided walkthrough helps troubleshoot the following issues:
  • Unable to create a profile on the device
  • Unable to connect to the server
  • Mail issues
  • Calendaring issues
  • Delays on device/CAS performance

Properties

Article ID: 2656040 - Last Review: February 18, 2014 - Revision: 3.0
Applies to
  • Microsoft Exchange Server 2007 Service Pack 3, when used with:
    • Microsoft Exchange Server 2007 Enterprise Edition
    • Microsoft Exchange Server 2007 Standard Edition
Keywords: 
kbqfe kbfix kbExpertiseInter kbsurveynew KB2656040

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