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Symptoms

When you install Windows Anytime Upgrade on a Windows 7-based computer, you may receive the following error message:

Windows Anytime Upgrade was not successful
The upgrade was not successful. Please try the upgrade again.


Additionally, you may see the following errors in the Windows Anytime Upgrade Upgrade.log file:

  • <Date> <Time>, Error WAU DoTransmogrify failed due to error 0x800f081f.

  • <Date> <Time>, Error WAU UpgradeSKU failed. Exiting.

  • <Date> <Time>, Error WAU Windows Anytime Upgrade ‚ was not successful.

Cause

This issue can occur if Windows 7 Service Pack 1 (SP1) was downloaded by Windows Update but has not yet been installed. For more information about this service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Resolution

To have us fix this problem for you, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me



To fix this problem automatically, click the Fix it button or link. Then click Run in the File Download dialog box, and follow the steps in the Fix it wizard.




Notes

  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.

  • If you are not on the computer that has the problem, you should save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.


Then, go to the "Did this fix the problem?" section.



Let me fix it myself

Uninstall Windows 7 Service Pack 1

To resolve this issue, uninstall Service Pack 1 by using the DISM command. To do this, follow these steps for your version of Windows 7.

For the 32-bit version of Windows 7

  1. Click Start, and then type cmd in the Search box.

  2. Right-click cmd.exe, and then click Run as administrator.

  3. Type the following command, and then press Enter:

    dism.exe /online /remove-package /packagename:Package_for_KB976932~31bf3856ad364e35~x86~~6.1.1.17514

  4. After the removal is complete, type exit, and then press Enter.

  5. Restart the computer.


For the 64-bit version of Windows 7

  1. Click Start, and then type cmd in the Search box.

  2. Right-click cmd.exe, and then click Run as administrator.

  3. Type the following command, and then press Enter:

    dism.exe /online /remove-package /packagename:Package_for_KB976932~31bf3856ad364e35~amd64~~6.1.1.17514

  4. After the removal is complete, type exit, and then press Enter.

  5. Restart the computer.


Determine whether you installed the Beta version of Windows 7 SP1

If you installed the Beta version of Windows 7 SP1, you cannot upgrade immediately by using Windows Anytime Upgrade. You have to uninstall the Beta version and then restart Windows Anytime Upgrade. To Uninstall the Beta version, follow these steps for your version of Windows 7.

Note If you uninstalled the Beta version of Windows 7 SP1 and you continue to receive the error, you may have remnants of the Beta version on your PC. These steps will also clean any remnants of the Beta version from your PC.

For the 32-bit version of Windows 7

  1. Click Start, and then type cmd in the Search box

  2. Right-click cmd.exe, and then click Run as administrator.

  3. Type the following command, and then press Enter:

    dism.exe /online /remove-package /packagename:Package_for_KB976932~31bf3856ad364e35~x86~~6.1.1.17105

  4. After the removal is complete, type exit, and then press Enter.

  5. Restart the computer.


For the 64-bit version of Windows 7

  1. Click Start, and then type cmd in the Search box.

  2. Right-click cmd.exe, and then click Run as administrator.

  3. Type the following command, and then press Enter:

    dism.exe /online /remove-package /packagename:Package_for_KB976932~31bf3856ad364e35~amd64~~6.1.1.17105

  4. After the removal is complete, type exit, and then press Enter.

  5. Restart the computer.




Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support.

  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, leave a comment on the "Fix it for me" blog, or send us an email message.

More Information

You may see error code 0x800f081 in the Windows Anytime Upgrade log file. This error code indicates that Windows Update has downloaded the Windows 7 SP1 update but that the update has not yet been installed. You can review this log to see whether the error occurred. The Windows Upgrade.log is in the following location:

%userprofile%\AppData\Local\Microsoft\Windows\Windows Anytime Upgrade\update.log
To review this log file to see whether the error has occurred, follow these steps:

  1. Click Start, and then click Computer.

  2. Copy the following text, click Start, and then paste the following text into the Search box:

    %userprofile%\AppData\Local\Microsoft\Windows\Windows Anytime Upgrade

  3. Click the Windows Anytime Upgrade folder in the search results at the top.

  4. Double-click the Update.log file in this folder.

  5. In Notepad, click Find on the Edit menu.

  6. Copy and paste the following text into the Find what text box, and then click Find.

    0x800f081

    If the error occurred, you see entries in the log file that resemble the following:

    • 2011-11-25 15:59:19, Error WAU DoTransmogrify failed due to error 0x800f081f.

    • 2011-11-25 15:59:19, Error WAU UpgradeSKU failed. Exiting.

    • 2011-11-25 15:59:19, Error WAU Windows Anytime Upgrade ‚ was not successful.


    Note The date and time at the start of each line in the log file will correspond to when the log file was updated with the information.

To resolve this issue, follow the steps in the "Resolution" section.

References

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

2632965 Windows Anytime Upgrade Error "The upgrade was not successful. Please try the upgrade again." on a Windows 7 computer with Multilingual User Interface (MUI)

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