Cómo solucionar problemas con el modo de espera, el modo de hibernación y el apagado del equipo en Windows 2000

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Síntomas

Puede que experimente alguno de los siguientes síntomas:
  • Al intentar apagar el equipo basado en Windows 2000, el equipo deja de responder (se bloquea), quizás con la pantalla en negro. Además, el equipo podría detenerse o no apagarse cuando el proceso de apagado llega a la pantalla que informa de que es seguro apagar el equipo.
  • No aparece la opción Suspender cuando intenta apagar el equipo.
  • El equipo se bloquea o aparece un mensaje de error "stop 0x9F" cuando está en modo de suspensión.
  • No aparece la opción Hibernar cuando intenta apagar el equipo ni tampoco aparece en la ficha Hibernar de la herramienta de opciones de energía del Panel de control.
NOTA: los modos de suspensión y de hibernación no están disponibles cuando se inicia el equipo en el modo a prueba de errores. Este comportamiento es por diseño, porque el controlador del adaptador de vídeo estándar (VGA) se carga al iniciar el equipo en el modo a prueba de errores.

Causa

Este comportamiento se puede dar si tiene instalado en el equipo un controlador de dispositivo OEM o un servicio de otro fabricante.

Solución

Para resolver este problema, consulte los siguientes artículos en Microsoft Knowledge Base:
242495 Solucionar problemas de Administración avanzada de energía en Windows 2000
246243 Troubleshooting STOP 0x9F Error Messages in Windows 2000
Si ninguno de estos artículos le ayuda a solucionar el problema del comportamiento de apagado del equipo, utilice los pasos de las secciones siguientes para buscar el controlador de dispositivo o el servicio que causa el problema.

Este artículo contiene las secciones siguientes:
  • Cómo iniciar el equipo en modo a prueba de errores
  • Cómo guardar una copia de los controladores que se están ejecutando
  • Cómo guardar una copia de los servicios que se están ejecutando
  • Cómo comparar los controladores que se están ejecutando
  • Cómo crear un segundo perfil para problemas de controladores
  • Cómo solucionar problemas con los servicios
  • Cómo crear un segundo perfil para problemas de servicios
  • Cómo utilizar una instalación paralela para identificar el controlador o el programa que causa el problema de comportamiento del apagado

Cómo iniciar el equipo en modo a prueba de errores

NOTA: en el procedimiento siguiente se supone que puede apagar el equipo cuando está en modo a prueba de errores. A veces, un controlador se puede convertir en un controlador de filtro inferior o superior de un controlador que se carga en modo a prueba de errores. Esto puede también impedir que el equipo se apague cuando está en modo a prueba de errores. Si el problema se produce con un servicio, inicie el equipo en modo a prueba de errores, siguiendo los pasos de la sección "Cómo guardar una copia de los servicios que se están ejecutando" y, a continuación, siga los pasos de la sección "Cómo solucionar problemas con los servicios" de este artículo.

Inicie el equipo en Modo a prueba de errores e inicie la sesión con privilegios administrativos. Para iniciar el equipo en modo a prueba de errores, reinicie el equipo, mantenga presionada la tecla F8 y, a continuación, elija Modo a prueba de errores en el menú Inicio de Windows 2000.

Si aparece un mensaje de error "STOP: 0x0000001e KMODE_EXCEPTION_NOT_HANDLED" al intentar iniciar el equipo en modo a prueba de errores, consulte el artículo siguiente en Microsoft Knowledge Base:
261807 DirectCD 3.01 Prevents Starting in Safe Mode in Windows 2000

Cómo guardar una copia de los controladores que se están ejecutando

Para guardar una copia de los controladores que se están ejecutando:
  1. Haga clic con el botón secundario del mouse (ratón) en el icono Mi PC del escritorio y luego haga clic en Administrar para abrir Administración del equipo.
  2. En Herramientas del sistema, expanda Información del sistema.
  3. Expanda Entorno de software y, a continuación, haga clic en la carpeta Controladores.
  4. Haga clic en la columna Nombre para clasificar los controladores por nombre y, a continuación, en la columna Estado para ordenar la columna por estado. Observe que todos los controladores que se están ejecutando se muestran en orden alfabético.
  5. Exporte la lista de controladores:
    1. En el menú Acción, haga clic en Exportar lista.
    2. En el cuadro Nombre de archivo, escriba controladores .
    3. En el cuadro Guardar como tipo, haga clic en Texto (delimitado por comas) (*.csv).
    4. Guarde el archivo en un disquete o en otra ubicación y, a continuación, compruebe que el archivo se guarda como Controladores.csv.

Cómo guardar una copia de los servicios que se están ejecutando

Para guardar una copia de los servicios que se están ejecutando:
  1. Haga clic con el botón secundario del mouse (ratón) en el icono Mi PC del escritorio y luego haga clic en Administrar para abrir Administración del equipo.
  2. En Administración del equipo, busque y expanda Servicios y aplicaciones.
  3. Haga clic en Servicios y, a continuación, en Detalles en el menú Ver.
  4. Haga clic en la columna Estado y, después, de nuevo en la columna Estado para clasificar los servicios por estado con los servicios iniciados en la parte superior de la lista.
  5. Exporte la lista de servicios:
    1. En el menú Acción, haga clic en Exportar lista.
    2. En el cuadro Nombre de archivo, escriba servicios .
    3. En el cuadro Guardar como tipo, haga clic en Texto (delimitado por comas) (*.csv).
    4. Guarde el archivo en un disco flexible o en otra ubicación y, a continuación, compruebe que el archivo se guarda como Servicios.csv.
  6. Apague el equipo.

Cómo comparar los controladores que se están ejecutando

Para comparar los controladores que se están ejecutando con los que se estaban ejecutando en modo a prueba de errores:
  1. Reinicie el equipo, inicie la sesión y, a continuación, siga los pasos 1 a 5 de la sección "Cómo guardar una copia de los controladores que se están ejecutando" de este artículo.
  2. Para comparar los controladores que se están ejecutando con los que se estaban ejecutando cuando inició el equipo en modo a prueba de errores:
    1. Inicie Microsoft Excel u otro programa de hoja de cálculo que pueda abrir archivos de texto delimitado por comas (.csv) y, a continuación, abra el archivo Controladores.csv que guardó cuando inició el equipo en modo a prueba de errores. Recuerde que puede imprimir el archivo en otro equipo si el suyo no tiene instalado un programa de hoja de cálculo.
    2. Compare la lista de controladores que se están ejecutando en el equipo con la lista de los que se estaban ejecutando en el equipo en modo a prueba de errores. Recuerde que cualquier controlador de otro fabricante que se esté ejecutando en el equipo y que no se estaba ejecutando cuando el equipo estaba en modo a prueba de errores podría estar causando el comportamiento de apagado.
    3. Si puede identificar controladores OEM de otro fabricante que se están ejecutando, intente desinstalar los controladores de dispositivo. También puede desinstalar o deshabilitar el dispositivo en el Administrador de dispositivos. Si desinstala un dispositivo Plug and Play en el Administrador de dispositivos, es posible que Windows 2000 vuelva a detectarlo cuando reinicie el equipo. Podría ser necesario quitar físicamente el hardware o cambiar el nombre del archivo .inf de la instalación OEM de ese dispositivo.

      Al instalar un controlador OEM, el programa Windows Installer copia el archivo oemsetup.inf de OEM en la carpeta %SystemRoot%\INF y cambia el nombre del archivo oemsetup.inf a OEM#.inf donde # es un número que aumenta para cada controlador OEM que se instala.

      Después de instalar el controlador OEM, inicie el Explorador de Windows y mueva temporalmente todos los archivos %SystemRoot%\INF\OEM#.inf y Oem#.pnf (donde # es un número) a otra ubicación. Si desea identificar un archivo Oem#.inf concreto, puede abrirlo en el Bloc de notas. Para obtener información adicional acerca de controladores de dispositivo, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
      199276 How to Manage Devices in Windows 2000
      268852 How to Force Windows 2000 to Use Standard VGA Compatible Driver
  3. Después de desinstalar o deshabilitar el dispositivo que está causando el comportamiento de apagado, reinicie el equipo varias veces para comprobar que se apaga correctamente y póngase en contacto con el fabricante OEM para informarle del comportamiento y preguntarle si existen controladores actualizados para el dispositivo.
NOTA: si utiliza el dispositivo que está causando el problema de apagado sólo de vez en cuando, puede crear un nuevo perfil de hardware en el que pueda iniciar el equipo con el dispositivo habilitado o deshabilitado. Puede configurar el dispositivo como deshabilitado en el perfil de hardware predeterminado y como habilitado en el nuevo perfil de hardware.

Cómo crear un segundo perfil para problemas de controladores

Para configurar el dispositivo como deshabilitado en el perfil de hardware predeterminado y como habilitado en el nuevo perfil de hardware:
  1. Haga clic en Inicio, seleccione Configuración y haga clic en Panel de control.
  2. Haga doble clic en Sistema y, a continuación, haga clic en Perfiles de hardware en la ficha Hardware.
  3. Haga clic en Copiar, escriba no-apagado en el cuadro Para y, a continuación, haga clic en Aceptar para guardar una copia del perfil.
  4. En la ficha Hardware, haga clic en Administrador de dispositivos.
  5. En Administrador de dispositivos, haga clic con el botón secundario del mouse (ratón) en el dispositivo que impide que se apague el equipo y, a continuación, haga clic en Propiedades.
  6. En el cuadro Uso del dispositivo, haga clic en la opción para no utilizar el dispositivo en el perfil de hardware actual (deshabilitado).
Al hacerlo, el equipo se apaga correctamente cuando lo inicia con el perfil predeterminado. Cuando desee utilizar el dispositivo que origina el problema de apagado, inicie el equipo con el nuevo perfil, el de no apagado, que tiene ese dispositivo habilitado.

Si el problema de apagado no lo causa un controlador de dispositivo, lo podría causar un servicio de otro fabricante. Solucione los problemas de servicios de la misma manera que soluciona los de controladores.

Cómo solucionar problemas con los servicios

Para solucionar el problema que el equipo tenga con un servicio:
  1. Reinicie el equipo, inicie la sesión y compare los servicios que se están ejecutando con los que se estaban ejecutando cuando inició el equipo en modo a prueba de errores:
    1. Haga clic con el botón secundario del mouse (ratón) en el icono Mi PC del escritorio y luego haga clic en Administrar para abrir Administración del equipo.
    2. Busque y expanda Servicios y aplicaciones.
    3. Haga clic en Servicios y, a continuación, en Detalles en el menú Ver.
    4. Haga clic en la columna Estado y, después, de nuevo en la columna Estado para clasificar los servicios por estado con los servicios iniciados en la parte superior de la lista.
    5. Inicie Excel u otro programa de hoja de cálculo que pueda abrir archivos de texto delimitado por comas y, después, abra el archivo Servicios.csv que guardó. Recuerde que puede imprimir el archivo en otro equipo si el suyo no tiene instalado un programa de hoja de cálculo.
    6. Compare la lista de servicios que se están ejecutando en el equipo con la lista de los que se estaban ejecutando en el equipo en modo a prueba de errores. Recuerde que cualquier servicio de otro fabricante que se esté ejecutando en el equipo y que no se estaba ejecutando cuando el equipo estaba en modo a prueba de errores podría estar causando el comportamiento de apagado.
    7. Si puede identificar servicios OEM de otro fabricante que se están ejecutando, intente desinstalar o deshabilitar el servicio.
  2. Después de desinstalar o deshabilitar el servicio que está causando el comportamiento de apagado, reinicie el equipo varias veces para comprobar que se apaga correctamente y póngase en contacto con el fabricante OEM para informarle del comportamiento y preguntarle si existe una actualización que solucione el problema.
NOTA: si utiliza el servicio que está causando el problema de apagado sólo de vez en cuando, puede crear un nuevo perfil de hardware en el que pueda iniciar el equipo con el servicio habilitado o deshabilitado. Puede configurar el servicio como deshabilitado en el perfil de hardware predeterminado y como habilitado en el nuevo perfil de hardware.

Cómo crear un segundo perfil para problemas de servicios

Para crear un segundo perfil, configure el servicio como deshabilitado en el perfil de hardware predeterminado y como habilitado en el nuevo perfil de hardware:
  1. Haga clic en Inicio, seleccione Configuración y haga clic en Panel de control.
  2. En el Panel de control, haga doble clic en Sistema.
  3. Haga clic en Perfiles de hardware en la ficha Hardware.
  4. Haga clic en Copiar, escriba no-apagado en el cuadro Para y, a continuación, haga clic en Aceptar para guardar una copia del perfil.
Para deshabilitar un servicio en el perfil predeterminado:
  1. Haga clic en Inicio, seleccione Buscar y haga clic en Archivos o carpetas.
  2. En el cuadro Buscar archivos o carpetas con el nombre, escriba services.msc .
  3. En el cuadro Buscar en, haga clic en Discos duros locales y, a continuación, en Buscar ahora.
  4. Haga doble clic en el archivo Services.msc.
  5. En el cuadro de diálogo Servicios, haga clic con el botón secundario del mouse (ratón) en el servicio que causa el problema de apagado y, a continuación, haga clic en Propiedades.
  6. Haga clic en Deshabilitar en la ficha Iniciar sesión para deshabilitar un servicio en el perfil predeterminado.
Al hacerlo, el equipo se apaga correctamente cuando lo inicia con el perfil predeterminado. Cuando desee utilizar el dispositivo que origina el problema de apagado, inicie el equipo con el nuevo perfil, el de no apagado, que tiene ese dispositivo habilitado.

Cómo utilizar una instalación paralela para identificar el controlador o el programa que causa el problema de comportamiento del apagado

Instale una nueva copia de Windows 2000 en otra partición del equipo. Cuando haya instalado la copia, instale los controladores de otros fabricantes (o los programas que instalan o inician servicios) de uno en uno en esa instalación paralela. Reinicie el equipo varias veces, cada vez que instale un nuevo controlador o programa. Cuando la instalación paralela muestre el mismo comportamiento de apagado, el último controlador o programa que ha instalado es el que causa el problema de apagado. Para solucionar el problema, quite el controlador o programa de la instalación original. Cuando lo haya hecho, elimine la instalación paralela.

Más información

Para obtener información adicional acerca de la solución de problemas de apagado, el modo de suspensión y el modo de hibernación, haga clic en los números de artículos siguientes para verlos en Microsoft Knowledge Base:
257562 Hibernate and Standby Are Not Available When Using Standard VGA
237551 Advanced Power Management Features Are Disabled with Terminal Services
259889 Standby Option Not Available in Multiple-Processor Configuration
255182 Hibernate Tab Is Not Available in Power Options Tool in Control Panel
197477 El sistema no puede ponerse en modo de suspensión porque...
257199 Device Driver Error Message Is Displayed When the Computer Enters Standby or Hibernate Mode
247480 Error Message After Setting Hibernation on Computer with Modem
247290 APM Standby Option Is Missing on PCs Without a Battery
252471 Error Message: Removable Storage Manager Refused the Request to Hibernate or Suspend the System
259623 Standby Feature Is Available on Computers with a Battery or ACPI
211205 Dell and IBM Notebook Computers May Not Suspend
247238 Standby in Shut Down Not Available in IBM ThinkPad 380XD When APM Is Enabled
211271 Cannot Hibernate Windows 2000 After Installing or Uninstalling McAfee AntiVirus 3.1.4

Propiedades

Id. de artículo: 266169 - Última revisión: miércoles, 20 de septiembre de 2006 - Versión: 5.0
La información de este artículo se refiere a:
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Palabras clave: 
kberrmsg kbhowto KB266169

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