Problemen met de modus Stand-by, de Slaapstand en het afsluiten van de computer in Windows 2000 oplossen

Vertaalde artikelen Vertaalde artikelen
Artikel ID: 266169 - Bekijk de producten waarop dit artikel van toepassing is.
Dit artikel is eerder gepubliceerd onder NL266169
Alles uitklappen | Alles samenvouwen

Op deze pagina

Symptomen

Een of meer van de volgende symptomen kunnen zich voordoen:
  • Bij het afsluiten van een Windows 2000-computer kan het zijn dat deze vastloopt, mogelijk met een zwart scherm. Het is ook mogelijk dat de computer vastloopt of zichzelf niet uitschakelt wanneer het scherm 'U kunt de computer nu uitschakelen' wordt weergegeven.
  • De optie Stand-by is niet beschikbaar bij het afsluiten van de computer.
  • De computer loopt vast of er verschijnt een foutbericht met 'stop 0x9F' wanneer de modus Stand-by actief is.
  • De optie Slaapstand is niet beschikbaar bij het afsluiten van de computer en er is geen tabblad Slaapstand in het onderdeel Energiebeheer van het Configuratiescherm.
Opmerking de modus Stand-by en de modus Slaapstand zijn geen van beide beschikbaar wanneer u de computer opstart in de Veilige modus. Dit is inherent aan het ontwerp. Wanneer de computer in de Veilige modus wordt opgestart, wordt namelijk het VGA-stuurprogramma (Standard Display Adapter) geladen.

Oorzaak

Dit gedrag kan zich echter ook voordoen wanneer u een OEM-apparaatstuurprogramma of service van derden gebruikt.

Oplossing

Raadpleeg de volgende Microsoft Knowledge Base-artikelen voor meer informatie over het oplossen van dit probleem:
242495Problemen met Geavanceerd energiebeheer oplossen in Windows 2000
246243Problemen als oorzaak van het foutbericht STOP 0x9F in Windows 2000 oplossen
Als de informatie in deze artikelen niet tot een oplossing leidt, voert u de stappen in de volgende secties uit om na te gaan welk stuurprogramma of welke service het afsluitprobleem veroorzaakt.

Dit artikel bevat de volgende secties:
  • De computer opstarten in de Veilige modus
  • Een lijst van de actieve stuurprogramma's opslaan
  • Een lijst van de actieve services opslaan
  • De actieve stuurprogramma's vergelijken
  • Een tweede profiel maken bij problemen met stuurprogramma's
  • Problemen met services oplossen
  • Een tweede profiel maken bij problemen met services
  • Met een parallelle installatie vaststellen welk stuurprogramma of programma het afsluitprobleem veroorzaakt

De computer opstarten in de Veilige modus

Opmerking in de volgende procedure wordt ervan uitgegaan dat de computer kan worden afgesloten in de Veilige modus. Soms wordt een stuurprogramma een lager of hoger filterstuurprogramma voor een stuurprogramma dat in de Veilige modus wordt geladen. Ook hierdoor is het mogelijk dat de computer niet kan worden afgesloten in de Veilige modus. Als het probleem door een service wordt veroorzaakt, start u de computer in de Veilige modus aan de hand van de stappen in de sectie 'Een lijst van de actieve services opslaan' en volgt u daarna de stappen in de sectie 'Problemen met een service oplossen' van dit artikel.

Start de computer op in de Veilige modus en meld u aan als beheerder. Als u de computer in de Veilige modus wilt opstarten, start u de computer opnieuw op, houdt u F8 ingedrukt en kiest u Veilige modus in het menu Opstarten van Windows 2000.

Als daarbij het foutbericht 'STOP: 0x0000001e KMODE_EXCEPTION_NOT_HANDLED' wordt weergegeven, raadpleegt u het volgende artikel in de Microsoft Knowledge Base:
261807DirectCD 3.01 verhindert dat Windows 2000 in de Veilige modus wordt gestart

Een lijst van de actieve stuurprogramma's opslaan

Ga als volgt te werk om een overzicht van de actieve stuurprogramma's op te slaan:
  1. Klik met de rechtermuisknop op het pictogram Deze computer op het bureaublad en klik op Beheren om Computerbeheer te openen.
  2. Vouw onder Systeemwerkset de structuur Systeeminfo uit.
  3. Vouw Softwareomgeving uit en klik op de map Stuurprogramma's.
  4. Klik op de kolom Naam om de stuurprogramma's op naam te rangschikken en klik vervolgens op Status om die kolom te rangschikken op status. De actieve stuurprogramma's worden in alfabetische volgorde weergegeven.
  5. Exporteer de lijst met stuurprogramma's als volgt:
    1. Open het menu Actie en klik op Lijst exporteren.
    2. Typ stuurprogramma's in het vak Bestandsnaam.
    3. Klik in het vak Opslaan als op Tekst (gescheiden door komma's) (*.csv).
    4. Kopieer het bestand naar een diskette of een andere locatie en controleer of de bestandsnaam Stuurprogramma's.csv is.

Een lijst van de actieve services opslaan

Ga als volgt te werk om een overzicht van de actieve services op te slaan:
  1. Klik met de rechtermuisknop op het pictogram Deze computer op het bureaublad en klik op Beheren om Computerbeheer te openen.
  2. Vouw Services en toepassingen uit in Computerbeheer.
  3. Klik op Services, open het menu Beeld en klik op Details.
  4. Klik op de kolom Status en klik nogmaals op de kolom Status om de services te rangschikken op status, met de gestarte services bovenaan.
  5. Exporteer de lijst met services als volgt:
    1. Open het menu Actie en klik op Lijst exporteren.
    2. Typ services in het vak Bestandsnaam.
    3. Klik in het vak Opslaan als op Tekst (gescheiden door komma's) (*.csv).
    4. Kopieer het bestand naar een diskette of een andere locatie en controleer of de bestandsnaam Services.csv is.
  6. Sluit de computer af.

De actieve stuurprogramma's vergelijken

Ga als volgt te werk om de stuurprogramma's die nu actief zijn, te vergelijken met de stuurprogramma's die actief waren in de Veilige modus:
  1. Start de computer opnieuw op, meld u aan en voer stap 1-5 in de sectie 'Een lijst van de actieve stuurprogramma's opslaan' van dit artikel uit.
  2. Ga als volgt te werk om de stuurprogramma's die nu actief zijn, te vergelijken met de stuurprogramma's die actief waren in de Veilige modus:
    1. Start Microsoft Excel of een ander spreadsheetprogramma waarmee tekstbestanden met een komma als scheidingsteken(.csv) kunnen worden geopend, en open het bestand Stuurprogramma's.csv dat u hebt opgeslagen nadat de computer in de Veilige modus werd opgestart. Als er geen spreadsheetprogramma op uw computer is geïnstalleerd, kunt u dit bestand eventueel op een andere computer afdrukken.
    2. Vergelijk de lijst met stuurprogramma's die nu actief zijn, met de stuurprogramma's die actief waren in de Veilige modus. Stuurprogramma's van derden die nu actief zijn maar niet actief waren in de Veilige modus, kunnen de oorzaak zijn van het afsluitprobleem.
    3. Als u kunt achterhalen welke OEM-stuurprogramma's van derden actief zijn, kunt u proberen het probleem te verhelpen door deze stuurprogramma's van de computer te verwijderen. U kunt de stuurprogramma's verwijderen of uitschakelen via Apparaatbeheer. Als u een Plug en Play-apparaat verwijdert met Apparaatbeheer, kan het zijn dat Windows 2000 dit apparaat opnieuw detecteert wanneer de computer opnieuw wordt opgestart. In dat geval verwijdert u de feitelijke hardware of geeft u het .inf-installatiebestand voor het apparaat een andere naam.

      Wanneer u een OEM-stuurprogramma installeert, wordt het OEM-bestand oemsetup.inf naar de map %SystemRoot%\INF gekopieerd en wordt de naam van het bestand oemsetup.inf gewijzigd in OEM#.inf, waarbij # een oplopend nummer is voor elk geïnstalleerd OEM-stuurprogramma.

      Nadat u het OEM-stuurprogramma hebt geïnstalleerd, start u Windows Verkenner en verplaatst u de bestanden %SystemRoot%\INF\Oem#.inf en Oem#.pnf (waarbij # een nummer is) tijdelijk naar een andere locatie. Als u een specifiek Oem#.inf-bestand wilt identificeren, opent u het bestand in Kladblok.Als u meer informatie wilt over stuurprogramma's, klikt u op de volgende artikelnummers in de Microsoft Knowledge Base:
      199276Het gebruik van Apparaatbeheer in Windows 2000
      268852Windows 2000 forceren een standaard VGA-compatibel stuurprogramma te gebruiken
  3. Nadat u het apparaat dat de oorzaak is van het afsluitprobleem, hebt verwijderd of uitgeschakeld, start u de computer een aantal keren opnieuw op om te zien of het afsluiten correct verloopt. Als dat het geval is, meldt u dit probleem bij de fabrikant van het apparaat en informeert u of er inmiddels bijgewerkte stuurprogramma's beschikbaar zijn.
Opmerking als u het apparaat dat het afsluitprobleem veroorzaakt, maar zelden gebruikt, kunt u een nieuw hardwareprofiel maken en de computer opstarten met het apparaat in- of uitgeschakeld. U kunt het apparaat in het standaardprofiel bijvoorbeeld instellen als uitgeschakeld en in het nieuwe hardwareprofiel als ingeschakeld.

Een tweede profiel maken bij problemen met stuurprogramma's

Ga als volgt te werk om het apparaat uit te schakelen in het standaardprofiel en vervolgens in te schakelen in het nieuwe hardwareprofiel:
  1. Klik op Start, wijs Instellingen aan en klik op Configuratiescherm.
  2. Dubbelklik op Systeem, open het tabblad Hardware en klik op Hardwareprofielen.
  3. Klik op Kopiëren, typ afsluitprobleem in het vak Naar en klik op OK om een kopie van het profiel op te slaan.
  4. Open het tabblad Hardware en klik op Apparaatbeheer.
  5. Klik in Apparaatbeheer met de rechtermuisknop op het apparaat dat verhindert dat de computer wordt afgesloten en klik op Eigenschappen.
  6. Klik in het vak Apparaatgebruik op Dit apparaat niet gebruiken in huidig hardwareprofiel (uitschakelen).
Als u de computer vervolgens met het standaardprofiel opstart, sluit de computer zonder problemen af. Wanneer u de service die de oorzaak is van het afsluitprobleem wilt gebruiken, start u de computer opnieuw op met het nieuwe profiel 'afsluitprobleem', waarin de service is ingeschakeld.

Als het afsluitprobleem niet door een stuurprogramma wordt veroorzaakt, kan de oorzaak bij een service van derden liggen. U volgt daarvoor dezelfde procedure als bij de stuurprogramma's.

Problemen met services oplossen

Ga als volgt te werk om problemen met een service op te lossen:
  1. Start de computer opnieuw op, meld u aan en vergelijk de services die nu actief zijn met de services die actief waren in de Veilige modus:
    1. Klik met de rechtermuisknop op het pictogram Deze computer op het bureaublad en klik op Beheren om Computerbeheer te openen.
    2. Vouw Services en toepassingen uit.
    3. Klik op Services, open het menu Beeld en klik op Details.
    4. Klik op de kolom Status en klik nogmaals op de kolom Status om de services te rangschikken op status, met de gestarte services bovenaan.
    5. Start Excel of een ander spreadsheetprogramma waarin tekstbestanden met een komma als scheidingsteken kunnen worden geopend, en open het bestand Services.csv dat u eerder hebt opgeslagen. Als er geen spreadsheetprogramma op uw computer is geïnstalleerd, kunt u dit bestand eventueel op een andere computer afdrukken.
    6. Vergelijk de lijst met services die nu actief zijn, met de services die actief waren in de Veilige modus. Services van derden die nu actief zijn maar niet actief waren in de Veilige modus, kunnen de oorzaak zijn van het afsluitprobleem.
    7. Als u kunt achterhalen welke OEM-services van derden actief zijn, kunt u proberen het probleem te verhelpen door deze services van de computer te verwijderen of uit te schakelen.
  2. Nadat u de service die de oorzaak is van het afsluitprobleem, hebt verwijderd of uitgeschakeld, start u de computer een aantal keren opnieuw op om te zien of het afsluiten correct verloopt. Als dat het geval is, meldt u dit probleem bij de leverancier van de service en informeert u of er een versie beschikbaar is die dit probleem niet veroorzaakt.
Opmerking als u de service die het afsluitprobleem veroorzaakt, maar zelden gebruikt, kunt u een nieuw hardwareprofiel maken en de computer opstarten met de service in- of uitgeschakeld. U kunt de service in het standaardprofiel bijvoorbeeld instellen als uitgeschakeld en in het nieuwe hardwareprofiel als ingeschakeld.

Een tweede profiel maken bij problemen met services

Maak een tweede profiel, waarbij u de service in het standaardhardwareprofiel instelt als uitgeschakeld en in het nieuwe hardwareprofiel als ingeschakeld. U doet dit als volgt:
  1. Klik op Start, wijs Instellingen aan en klik op Configuratiescherm.
  2. Dubbelklik in het Configuratiescherm op Systeem.
  3. Open het tabblad Hardware en klik op Hardwareprofielen.
  4. Klik op Kopiëren, typ afsluitprobleem in het vak Naar en klik op OK om een kopie van het profiel op te slaan.
Ga als volgt te werk om een service uit te schakelen in het standaardprofiel:
  1. Klik op Start, wijs Zoeken aan en klik op Bestanden of mappen.
  2. Typ in het vak Zoeken naar bestanden of mappen met deze naam de zoektekst services.msc.
  3. Klik in het vak Zoeken in op Lokale vaste schijven en klik op Nu zoeken.
  4. Dubbelklik op het bestand Services.msc.
  5. Klik in het dialoogvenster Services met de rechtermuisknop op de service die het afsluitprobleem veroorzaakt en klik op Eigenschappen.
  6. Open het tabblad Aanmelden en klik op Uitschakelen om de service uit te schakelen in het standaardprofiel.
Als u de computer vervolgens met het standaardprofiel opstart, sluit de computer zonder problemen af. Wanneer u de service die de oorzaak is van het afsluitprobleem wilt gebruiken, start u de computer opnieuw op met het nieuwe profiel 'afsluitprobleem', waarin de service is ingeschakeld.

Met een parallelle installatie vaststellen welk stuurprogramma of programma het afsluitprobleem veroorzaakt

Installeer Windows 2000 op een afzonderlijke partitie van de computer. Installeer vervolgens op deze parallelle installatie een voor een stuurprogramma's van derden (of programma's waarmee services worden geïnstalleerd of gestart). Start de computer na de installatie van elk stuurprogramma of programma een aantal keren opnieuw op. Als de parallelle installatie hetzelfde afsluitprobleem vertoont, ligt de oorzaak bij het laatste stuurprogramma of programma dat u hebt geïnstalleerd. U kunt het probleem oplossen door dit stuurprogramma of programma van uw werkpartitie te verwijderen. Vervolgens verwijdert u ook de parallelle installatie.

Meer informatie

Als u meer informatie wilt over het oplossen van problemen met het afsluiten van de computer, de modus Stand-by en de Slaapstand, klikt u op de volgende artikelnummers in de Microsoft Knowledge Base:
257562Slaapstand en stand-bymodus zijn niet beschikbaar bij gebruik van standaard VGA
237551Geavanceerde energiebeheerfuncties worden uitgeschakeld met Terminal Services
259889Stand-bymodus is niet beschikbaar in een configuratie met meerdere processors
255182Het tabblad Slaapstand is niet beschikbaar in het onderdeel Energiebeheer van het Configuratiescherm
197477De stand-bymodus kan niet worden geactiveerd omdat...
257199Foutbericht met betrekking tot stuurprogramma wordt weergegeven wanneer de computer in de stand-bymodus of slaapstand wordt gezet
247480Foutbericht na instellen slaapstand op computer met modem
247290Optie voor stand-by ontbreekt op computers zonder accu
252471Foutbericht: Beheer van Verwisselbare opslag heeft de aanvraag voor slaapstand of wachtstand voor het systeem geweigerd
259623Stand-bymodus is beschikbaar op computers met een accu of ACPI
211205Notebookcomputers van Dell en IBM worden niet goed in de wachtstand geplaatst
247238Stand-by bij afsluiten niet beschikbaar in IBM ThinkPad 380XD wanneer APM is ingeschakeld
211271Windows 2000 kan niet in de slaapstand worden gezet na het installeren of verwijderen van McAfee AntiVirus 3.1.4

Eigenschappen

Artikel ID: 266169 - Laatste beoordeling: woensdag 11 oktober 2006 - Wijziging: 5.0
De informatie in dit artikel is van toepassing op:
  • Microsoft Windows® 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
Trefwoorden: 
kberrmsg kbhowto kbpowerman kbsafemod KB266169

Geef ons feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com