Como solucionar problemas com o Modo de espera, Modo de hibernação e desligamento do computador no Windows 2000

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Sintomas

Você pode enfrentar um ou mais dos seguintes sintomas:
  • Ao tentar desligar o computador com base no Windows 2000, o computador poderá parar de responder (travar), possivelmente em uma tela preta. Além disso, o computador poderá travar ou não desligar quando o procedimento de desligamento exibir a tela "O computador já pode ser desligado com segurança".
  • Não há opção de Espera ao tentar desligar o computador.
  • O computador paralisa ou você recebe uma mensagem de erro "stop 0x9F" quando o computador está no Modo de espera.
  • Não há opção de Hibernação ao tentar desligar o computador e não há uma guia Hibernação na ferramenta Opções de energia no Painel de controle.
OBSERVAÇÃO: Os modos de espera e de hibernação não estão disponíveis ao iniciar o computador no Modo de segurança. Esse comportamento é padronizado, pois o driver do Adaptador de Vídeo Padrão (VGA) é carregado ao iniciar o computador no Modo de segurança.

Causa

Esse comportamento pode ocorrer quando você tem um driver de dispositivo ou serviço OEM de terceiro instalado no computador.

Resolução

Para solucionar esse problema, visualize os seguintes artigos na Base de Dados de Conhecimento Microsoft (alguns artigos podem estar em inglês):
242495 Solucionando problemas de administração avançada de energia no Windows 2000
246243 Solucionando problemas da mensagem de erro STOP 0x9F no Windows
Se nenhum desses artigos ajudar a solucionar o problema de desligamento, utilize os passos nas seções a seguir para ajudá-lo a encontrar o driver de dispositivo ou serviço que está causando o problema.

Este artigo contém as seguintes seções:
  • Como iniciar o computador no Modo de segurança
  • Como salvar uma cópia dos drivers em execução
  • Como salvar uma cópia dos serviços em execução
  • Como comparar os drivers em execução
  • Como criar um segundo perfil para os problemas de driver
  • Como solucionar problemas com serviços
  • Como criar um segundo perfil para os problemas de serviço
  • Como utilizar uma instalação paralela para identificar o driver ou o programa que está causando o problema de desligamento

Como iniciar o computador no Modo de segurança

OBSERVAÇÃO: O procedimento a seguir supõe que você possa desligar o computador quando no Modo de segurança. Às vezes, um driver pode se tornar um driver de filtro inferior ou superior para um driver que carrega no Modo de segurança; isso também pode impedir que o computador seja desligado quando no Modo de segurança. Se o problema for com um serviço, inicie o computador no Modo de segurança, seguindo os passos na seção "Como salvar uma cópia dos serviços em execução" e execute os passos na seção "Como solucionar problemas com serviços" neste artigo.

Inicie o computador no Modo de segurança e faça logon com privilégios administrativos. Para iniciar o computador no Modo de segurança, reinicie o computador, pressione e mantenha pressionada a tecla F8 e escolha Modo de segurança no menu Iniciar do Windows 2000.

Se receber uma mensagem de erro "STOP: 0x0000001e KMODE_EXCEPTION_NOT_HANDLED" ao tentar iniciar o computador no Modo de segurança, consulte o seguinte artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
261807 DirectCD 3.01 Impede a inicialização do Modo de segurança no Windows 2000

Como salvar uma cópia dos drivers em execução

Para salvar uma cópia dos drivers em execução:
  1. Clique com o botão direito do mouse no ícone Meu Computador na área de trabalho e clique em Gerenciar para abrir o Gerenciamento do computador.
  2. Sob Ferramentas do sistema, expanda Informações do sistema.
  3. Expanda Ambiente de software e clique na pasta Drivers.
  4. Clique na coluna Nome para classificar os drivers por nome e clique na coluna Estado para classificar a coluna por estado. Observe que todos os drivers em execução são exibidos em ordem alfabética.
  5. Exporte a lista de drivers:
    1. No menu Ação, clique em Exportar lista.
    2. Na caixa Nome do arquivo, digite drivers.
    3. Na caixa Salvar como tipo, clique em Texto (delimitado por vírgulas) (*.csv).
    4. Salve o arquivo em um disquete ou em outro local e verifique se o arquivo está salvo como Drivers.csv.

Como salvar uma cópia dos serviços em execução

Para salvar uma cópia dos serviços em execução:
  1. Clique com o botão direito do mouse no ícone Meu Computador na área de trabalho e clique em Gerenciar para abrir o Gerenciamento do computador.
  2. No Gerenciamento do computador, localize e expanda Serviços e aplicativos.
  3. Clique em Serviços e clique em Detalhes no menu Exibir.
  4. Clique na coluna Status e clique novamente na coluna Status para classificar os serviços por status com os serviços iniciados no topo da lista.
  5. Exporte a lista de serviços:
    1. No menu Ação, clique em Exportar lista.
    2. Na caixa Nome do arquivo, digite serviços.
    3. Na caixa Salvar como tipo, clique em Texto (delimitado por vírgulas) (*.csv).
    4. Salve o arquivo em um disquete ou em outro local e verifique se o arquivo está salvo como Serviços.csv.
  6. Desligue o computador.

Como comparar os drivers em execução

Para comparar os drivers em execução com os drivers que estavam em execução no Modo de segurança:
  1. Reinicie o computador, faça logon e execute as etapas 1 a 5 na seção "Como salvar uma cópia dos drivers em execução" neste artigo.
  2. Compare os drivers em execução com os drivers que estavam executando ao iniciar o computador no Modo de segurança:
    1. Inicie o Microsoft Excel ou outro programa de planilha que possa abrir arquivos de texto delimitados por vírgula (.cvs) e abra o arquivo Drivers.csv salvo ao iniciar o computador no Modo de segurança. Observe que é possível que você queira imprimir esse arquivo em outro computador se o computador não tiver um programa de planilha instalado.
    2. Compare a lista de drivers em execução no computador com a lista de drivers que estavam sendo executados no computador em Modo de segurança. Observe que quaisquer drivers de terceiros em execução no computador e que não estavam executando quando o computador estava no Modo de segurança podem estar causando o problema de desligamento.
    3. Se você puder identificar os drivers OEM de terceiros em execução, tente desinstalar os drivers de dispositivo. Você também pode desinstalar ou desativar o dispositivo no Gerenciador de dispositivos. Note que se você desinstalar um dispositivo Plug and Play no Gerenciador de dispositivos, o Windows 2000 poderá detectar o dispositivo novamente ao iniciar o computador. Talvez seja necessário remover fisicamente o hardware ou renomear o arquivo .inf da instalação OEM para esse dispositivo.

      Ao instalar um driver OEM, o programa Windows Installer copia o arquivo oemsetup.inf do OEM para a pasta %SystemRoot%\INF e renomeia o arquivo oemsetup.inf para OEM#.inf, em que # é um número de incremento para cada driver OEM instalado.

      Após a instalação do driver OEM, inicie o Windows Explorer e tente mover temporariamente quaisquer arquivos %SystemRoot%\INF\Oem#.inf e Oem#.pnf (em que # é um número) para um outro local. Se desejar identificar um arquivo Oem#.inf, você poderá abri-lo no Bloco de notas.Para obter informações adicionais sobre drivers de dispositivo, clique nos números abaixo para exibir os artigos na Base de Dados de Conhecimento Microsoft:
      199276 Como administrar dispositivos no Windows
      268852 Como forçar o Windows a utilizar o driver compatível com VGA padrão
  3. Após a desinstalação ou a desativação do dispositivo que está causando o problema de desligamento, reinicie o computador várias vezes para verificar se ele desliga corretamente e entre em contato com o fabricante OEM para relatar o comportamento e perguntar se há drivers atualizados disponíveis para o dispositivo.
OBSERVAÇÃO: Se você utilizar o dispositivo que está causando o problema de desligamento somente de vez em quando, poderá criar um novo perfil de hardware no qual será possível iniciar o computador com o dispositivo ativado ou não. Você pode configurar o dispositivo como desativado no perfil de hardware padrão e definir o dispositivo de problema como ativado no novo perfil de hardware.

Como criar um segundo perfil para os problemas de drivers

Para definir o dispositivo como desabilitado no perfil de hardware padrão e definir o dispositivo de problema como habilitado no novo perfil de hardware:
  1. Clique em Iniciar, aponte para Configurações e clique em Painel de controle.
  2. Clique duas vezes em Sistema e clique em Perfis de Hardware na guia Hardware.
  3. Clique em Copiar, digite no-shutdown na caixa Para e clique em OK para salvar uma cópia do perfil.
  4. Na guia Hardware, clique em Gerenciador de dispositivos.
  5. No Gerenciador de dispositivos, clique com o botão direito do mouse no dispositivo que impede o desligamento do computador e clique em Propriedades.
  6. Na caixa Uso do dispositivo, clique em Não usar este dispositivo (desativar).
Ao fazer isso, o computador desliga normalmente ao iniciá-lo com o perfil padrão. Quando quiser usar o dispositivo que causa o problema de desligamento, inicie o computador com o novo perfil no-shutdown que tem o dispositivo ativado.

Se o problema de desligamento não for causado por um driver de dispositivo, o comportamento poderá ser causado por um serviço de terceiros. Solucione os problemas de serviços da mesma forma que solucionou os de drivers.

Como solucionar problemas nos serviços

Para solucionar um problema que o computador está enfrentando com o serviço:
  1. Reinicie o computador, faça logon e compare os serviços em execução com os serviços que estavam sendo executados ao iniciar o computador no Modo de segurança:
    1. Clique com o botão direito do mouse no ícone Meu Computador na área de trabalho e clique em Gerenciar para abrir o Gerenciamento do computador.
    2. Localize e expanda Serviços e aplicativos.
    3. Clique em Serviços e clique em Detalhes no menu Exibir.
    4. Clique na coluna Status e clique novamente na coluna Status para classificar os serviços por status com os serviços iniciados no topo da lista.
    5. Inicie o Excel ou outro programa de planilha que possa abrir arquivos de texto delimitados por vírgula e abra o arquivo Serviços.csv salvo. Observe que é possível que você queira imprimir esse arquivo em outro computador se o computador não tiver um programa de planilha instalado.
    6. Compare a lista de serviços em execução no computador com a lista de serviços que estavam sendo executados no Modo de segurança. Observe que quaisquer serviços de terceiros em execução no computador que não estavam sendo executados quando o computador estava no Modo de segurança podem estar causando o problema de desligamento.
    7. Se você puder identificar os serviços OEM de terceiros em execução, tente desinstalar ou desativar o serviço.
  2. Após a desinstalação ou a desativação do serviço que está causando o problema de desligamento, reinicie o computador várias vezes para verificar se ele desliga corretamente e entre em contato com o fornecedor OEM para relatar o comportamento e perguntar se há uma atualização disponível para solucionar o problema.
OBSERVAÇÃO: Se você utilizar somente o serviço que está causando o problema de desligamento de vez em quando, poderá criar um novo perfil de hardware no qual será possível iniciar o computador com o serviço ativado ou não. Você pode configurar o serviço como desativado no perfil de hardware padrão e definir o dispositivo de problema como ativado no novo perfil de hardware.

Como criar um segundo perfil para os problemas de drivers

Para definir o dispositivo como desabilitado no perfil de hardware padrão e definir o dispositivo de problema como habilitado no novo perfil de hardware:
  1. Clique em Iniciar, aponte para Configurações e clique em Painel de controle.
  2. No Painel de controle, clique duas vezes em Sistema.
  3. Clique em Perfis de hardware na guia Hardware.
  4. Clique em Copiar, digite no-shutdown na caixa Para e clique em OK para salvar uma cópia do perfil.
Para desativar um serviço no perfil padrão:
  1. Clique em Iniciar, aponte para Pesquisar e clique em Arquivos ou pastas.
  2. Na caixa Pesquisar por pastas ou arquivos, digite services.msc.
  3. Na caixa Examinar, clique em Unidades de Disco Local e clique em Pesquisar.
  4. Clique duas vezes no arquivo Services.msc.
  5. Na caixa de diálogo Serviços, clique com o botão direito do mouse no serviço que está causando o problema de desligamento e clique em Propriedades.
  6. Clique em Desativar na guia Logon para desativar o serviço no perfil padrão.
Ao fazer isso, o computador desliga normalmente quando você o inicia com o perfil padrão. Quando quiser usar o dispositivo que causa o problema de desligamento, inicie o computador com o novo perfil no-shutdown que tem o dispositivo ativado.

Como usar uma instalação paralela para identificar o driver ou o programa que está causando o comportamento do desligamento

Instale uma nova cópia do Windows 2000 em uma partição separada do computador. Após a instalação da nova cópia, instale drivers de terceiros (ou programas que instalam ou iniciam serviços), um de cada vez, na instalação paralela. Reinicie o computador várias vezes toda vez que instalar um novo driver ou programa. Quando a instalação paralela exibe o mesmo problema de desligamento, o último driver ou programa instalado é o driver ou o programa que está causando o problema. Para resolver isso, remova o driver ou o programa da instalação original. Depois de fazer isso, exclua a instalação paralela.

Mais Informações

Para obter informações adicionais sobre como solucionar problemas que podem ocorrer com o desligamento, o Modo de espera e o Modo de hibernação, clique nos números abaixo para exibir os artigos na Base de Dados de Conhecimento Microsoft (as páginas podem estar em inglês):
257562 Hibernação e espera não estão disponíveis ao usar o VGA padrão
237551 Os recursos de gerenciamento avançado de energia são desativados com o Terminal Services
259889 A opção Modo de espera não está disponível na configuração de diversos processadores
255182 A guia de hibernação não está disponível na ferramenta Opções de energia do Painel de controle
197477 O sistema não pode ir para o Modo de espera porque...
257199 A mensagem de erro no driver de dispositivo é exibida quando o computador entra em Modo de espera ou hibernação
247480 Aparece uma mensagem de erro depois de configurar a hibernação em um computador com modem
247290 A opção de Modo de espera do APM está ausente em PCs sem uma bateria
252471 Mensagem de erro: O Gerenciador de armazenamento removível recusou a solicitação de hibernação ou de suspender o sistema
259623 O recurso de Modo de espera está disponível em computadores com uma bateria ou ACPI
211205 Os notebooks Dell e IBM podem não entrar em estado de suspensão
247238 O modo de espera em "Desligar" não está disponível no IBM ThinkPad 380XD quando o APM está ativado
211271 Não é possível colocar o Windows 2000 em Modo de hibernação após instalar ou desinstalar o McAfee AntiVirus 3.1.4

Propriedades

ID do artigo: 266169 - Última revisão: sexta-feira, 20 de outubro de 2006 - Revisão: 5.0
A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
Palavras-chave: 
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